1. levander's Avatar
    When my phone has been idle for so long, say 5 minutes, the screen goes dark like it's supposed to. Then I get a call, the slider shows up on the screen and I slide it to answer the call. I get the Google Voice call screening message (just like I want to happen) saying "press 1 to accept, press 2 for voicemail...". Now on the screen I can hit the dial pad button to pull up the dial pad. On the dial pad, I hit 1 and then the Atrix's screen goes blank. So, I hit the power button at the top of the phone. The dial pad shows up again. And, I hit 1 again. So, the screen goes blank again...

    Before too long it's too late and the call has gone into voice mail. So, I have to call the person who called me back and say "sorry, something's weird with Google Voice..."

    Anybody know how to get call screening working right with Google Voice and an Atrix?

    I do have the Google Voice app installed.
    08-26-2011 08:25 PM
  2. bayskipper's Avatar
    I just tested to make sure it works, and yes call screening works fine. I'm also able to jump-in on the caller's voicemail message by pressing star. Sorry, I'm not sure what you can do - have you made sure you are on the latest version of everything?
    08-27-2011 01:20 PM
  3. levander's Avatar
    bayskipper, call screening does work for me, sometimes. I tried call screening on my Atrix by calling it from my home phone, and it worked. Then I called a friend, told him to wait 5 minutes then call me back on my mobile phone, it didn't work...

    The differences between the two tests could have been one, 1.) my friend maybe waited long to call, making the phone "more idle" somehow? Or, 2.) the home phone calls my mobile phone much more often than my friend does. I know there's some thing on the Google Voice servers where if you're someone who's already called that Google Voice number, it doesn't re-ask your name for call screening... So there's some variable about if you've called before? My friend was not asked his name when he called, but I'm wondering if this effects it somehow?

    Google Voice version: 0.4.2.32

    From the home screen, I click on the lower far-right button (four boxes icon), then from the popup menu choose "Settings". I get these versions:

    Android version: 2.3.4
    System Version: 4.5.91.MB860.ATT.en.US

    The phone's Android install was recently upgraded just by me receiving so message on the phone saying a new version available and I just clicked "OK, install it". I think this was me being updated to Gingerbread. But, the problem has been there before the phone was upgraded to Gingerbread.
    08-27-2011 02:20 PM
  4. levander's Avatar
    The issue has got to have something to do with the idling....

    Cause when I hit "1" as in the original description above and the screen goes blank, that's what it seems to be doing, going back into an idle state...
    08-27-2011 02:21 PM
  5. levander's Avatar
    Is there some public bug database for Google Voice? I'd be willing to dig through that to try to fix it.
    08-27-2011 02:25 PM
  6. mattbta's Avatar
    This happens to me on a stock build attempting to enter key presses after the initial connection. Very frustrating for my daily bridge calls.

    Doesn't happen on ROMS though.
    08-31-2011 08:42 PM
LINK TO POST COPIED TO CLIPBOARD