1. ranova's Avatar
    Theres a new version of the Swype beta that is IMMENSELY better than the preloaded swype that comes with the atrix, it literally fixes all the annoying things of the older Swype versions:
    Swype Android keyboard updated with a number of improvements | Android Central

    They even now support qHD and it uses Google Voice Search to text instead of Vlingo!

    Current versions
    Installer: 1.1.20186 (12.01)
    SwypeBETA - STANDARD: 2.29.71.20203 (all languages)
    SwypeBETA - MICRO: 2.29.71.20186 (English + Spanish only)

    Unfortunately, because the Atrix comes with Swype preinstalled, you have to remove that preinstalled version (i.e. YOU MUST BE ROOTED) to install the beta:
    1. Use Root Explorer (make sure to mount R/W), Terminal, ADB to backup and then delete Swype.apk from /system/app and libSwypecore.so from /System/lib
    2. Download the installer from https://beta.swype.com/android/get/ (on your phone)
    3. Use installer to login and install latest version of swype


    If you want to get in the latest beta, sign up over here. Registrations are open right now, hurry before they close them again!

    Long version of steps for ADB (Thanks for playin4sheezy on XDA):
    • goto command prompt
    • type the following:

    adb shell
    su
    mkdir /mnt/sdcard/swype_backup
    mount -o rw,remount /dev/block/mmcblk0p12 /system
    cp /system/app/Swype.apk /mnt/sdcard/swype_backup
    cp /system/lib/libSwypeCore.so /mnt/sdcard/swype_backup
    rm /system/app/Swype.apk
    rm /system/lib/libSwypeCore.so
    03-12-2011 10:32 PM
  2. BrianTufo's Avatar
    I can say the install was super easy and the new swype is much nicer than what came loaded on the phone.
    03-12-2011 10:55 PM
  3. jd914's Avatar
    It worked for me even though I had to re register because my prior Swype account was linked to my Nexus One and was not installing on my Atrix.
    03-12-2011 11:45 PM
  4. ranova's Avatar
    It worked for me even though I had to re register because my prior Swype account was linked to my Nexus One and was not installing on my Atrix.
    yeah, you can only have one phone linked to your beta account - and you can only reset it once.

    Login to your account at beta.swype.com to reset it
    03-13-2011 01:11 AM
  5. wpbfjr's Avatar
    silly as it sounds, swype beta will get me to root my atrix...

    as an old guy, swype is one of top selling points for me to get android..


    AARRGGGHH!!! do i really need windoz vista or 7?

    i'm an old guy on xp sp3...


    answer: no, i don't. full instructions show using .net framework...

    whew!
    03-14-2011 10:21 AM
  6. cordell507's Avatar
    i accidentally didnt delete the lib file and installed the keyboard so it said that it wasnt for my divice and was very dysfunctional so now im searching my entire phone for anything with swype so i can delete it
    03-14-2011 04:19 PM
  7. x2z's Avatar
    Or just delete swype with titanium backup AFTER backing up. Then install with installer. No ADB knowledge needed.
    03-14-2011 05:20 PM
  8. jess.hickey's Avatar
    Has anyone else restarted their phone since installing the new swype? I just had to restart because of the stupid data connectivity issue and now I keep getting repeated FCs on swype. It worked flawlessly until power cycling the phone.

    UPDATE: Uninstalled, reinstalled and seems to be fine. I even did a power cycle after reinstall and all seems fine.

    If this keeps happening, should I just be able to restore the backups of the two files I made and be back where I started?
    03-14-2011 05:37 PM
  9. x2z's Avatar
    Has anyone else restarted their phone since installing the new swype? I just had to restart because of the stupid data connectivity issue and now I keep getting repeated FCs on swype. It worked flawlessly until power cycling the phone.
    Yes I did. dropped the atrix and she power cycled.
    03-14-2011 05:40 PM
  10. jess.hickey's Avatar
    Yes I did. dropped the atrix and she power cycled.
    ....and I'm assuming you had no issue with swype force closing after the restart?
    03-14-2011 05:44 PM
  11. x2z's Avatar
    ....and I'm assuming you had no issue with swype force closing after the restart?
    nope hasn't force closed once. Sorry should have included that before.
    03-14-2011 06:51 PM
  12. IceDree's Avatar
    It doesn't worth giving up the Pre-installed SWYPE for a beta that will expire in couple of months, but I gotta admit the latest beta is better than the one before (which was laggy)
    03-14-2011 08:02 PM
  13. Jonneh's Avatar
    So, say in a couple months or sometime, Swype will update us all when this beta version gets out of beta, and we can update our crappy Atrix swype without needing to root our phones?
    03-14-2011 09:35 PM
  14. wpbfjr's Avatar
    figured issue out...

    will need factory swype to upgrade

    dana
    03-15-2011 12:03 AM
  15. cmusciano's Avatar
    Wanting to update swype is what finally pushed me to root my Atrix. After rooting, this upgrade worked flawlessly. Thanks!
    03-18-2011 01:29 PM
  16. REBELYELLoz's Avatar
    I think I may be ******ed. I followed all the steps, device is rooted, when I try to open the beta swype installer, I am getting a Security warning. "This application comes from an unknown source and for your security only applications from trusted sources can be installed."
    03-25-2011 05:05 PM
LINK TO POST COPIED TO CLIPBOARD