1. Jinrin's Avatar
    For some reason my power button just stopped working. I've had this phone for over a year.

    This has happened before a couple months back. My phone's power button is just unresponsive. I cannot turn on the screen, and must get someone to text me in order to use my phone. In addition when I want to turn off the screen, the power button still doesn't work. The first time this happened, the problem went away after two or three days.

    It has just happened again. Any idea what I can do?
    09-26-2011 10:50 PM
  2. loraque's Avatar
    Pop the battery out, put it back and see if it works. I would get ATT to replace it,
    09-27-2011 06:28 AM
  3. konazxiii's Avatar
    I had this happen once just recently...with my 1007 (July 2010) build.

    I ended up carefully taking it apart and gently blowing the dust off of the exterior and interior portions of the button/switch and it has worked just fine since then.
    09-27-2011 09:48 AM
  4. w4guan's Avatar
    where did you get the tools small enough to take it apart? even the little flatheads I have for glasses are too big.
    09-28-2012 10:37 PM
  5. spagman's Avatar
    Any hardware store has precision tools... I found some at walmart. Watch a captivate disassembly video first before you attempt to open it... The captivate has a tricky "latch" at the top that you need to be careful with.

    Sent from my SGH-I897 using Tapatalk 2
    09-28-2012 11:17 PM