1. thenameisgabe's Avatar
    So, as most of you know, AT&T has an extra 20$ fee for tethering.

    I do not have this add-on on my account, I just have my unlimited data plan from my old iphone.

    Now, I just got the captivate, and installed the drivers for the phone, plugged it in and decided to play around with the modes.

    The samsung modem driver works perfectly and allows me to tether my phone to my computer without any problem (you just have to pick the right USB mode on the phone).

    Would using this mode tip off AT&T and add the tethering to my bill? I don't think that it would but I'm sort of surprised that AT&T didn't disable this mode...

    Is everyone able to do this? or is it just me?
    07-18-2010 02:31 PM
  2. alphadog's Avatar
    Can you give more detail on the samsung modem driver and OS you are using - also what USB mode is required?

    As for tipping AT&T off - i tethered a decent amount on my iPhone. It would be hard for them to spot without doing deep packet inspection. More then likely they would watch for higher then normal data usage, but even then, it would impossible for them to prove tethering. You would get a warning first I'm sure.
    07-18-2010 03:03 PM
  3. gspeed's Avatar
    some of us use pdanet, I don't, but I know it provides wired tethering.

    A lot of Android users use it and they don't get banged up for added data charges.

    I'm assuming you just have to try and find out until someone can confirm that it works on ATT.
    07-18-2010 03:48 PM
  4. thenameisgabe's Avatar
    When I first plugged it in, windows couldn't find drivers for it. (Apparently its a common problem, it takes 2-3 tries before windows gets the drivers).

    I assumed I had to find drivers myself, so I found these on google:

    Download Samsung Galaxy S USB Driver for Windows x64 Driver for Windows XP X64 / Windows Vista64 / Windows 7 x64 - Softpedia

    Upon installing them, the phone worked fine (It just mounted the phone as mass storage, and I could access the internal SD card, not the internal memory, I do not have an external SD card right now). I noted that there was also a driver for a modem though, so I went into the options on the phone.

    If you go to settings->Applications->USB mode, you can find a setting for PC Internet. If you set it to that, it will allow you to use the phone as a modem.

    I'm thinking that this was just an oversight on AT&T's part and it may be removed in future updates, but for now it works, and works well.
    jhnstn00 likes this.
    07-18-2010 03:52 PM
  5. Redneckbutlerboy's Avatar
    Most of the time getting the phone into modem mode is only half the battle. You still need to actually turn on the tethering some how. On supported handsets AT&T wants you to use ACM (AT&T Communication Manager) which is only programed to go over there isp.cingular APN (access point name). That APN is what they add to your account when you pay for tethering and that is how you get blocked when you try to tether without the right plan. The other option is a DUN (dial up network) connection where you program the connection manually. They have this shown in several tutorials on their web site. The trick is in the extra initialization string....all you do is change the isp.cingular at the end to wap.cingular and it bypasses the provisioning and makes the network think your going through the phones browser. After that, if they wanted to dig through packets and such I'm not sure what they would find as thats all over my head. Not sure if this would work on an Android phone as I just picked up my wifes yesterday and mine a few hours ago but this is what I've found to work on WM and Blackberry's in the past.
    07-18-2010 06:16 PM
  6. thenameisgabe's Avatar
    Ah, thats interesting. Thanks for the informed reply. Apparently I did not have to do any of those things, as it just.... works. The computer recognizes it as a network interface and can connect to the internet through it, no extra configuration necessary.

    I don't think ATT will be able to detect it.
    07-18-2010 08:15 PM
  7. alphadog's Avatar
    Ah, thats interesting. Thanks for the informed reply. Apparently I did not have to do any of those things, as it just.... works. The computer recognizes it as a network interface and can connect to the internet through it, no extra configuration necessary.

    I don't think ATT will be able to detect it.
    I agree, but i bet they push an OTA update out quickly to kill it.
    07-18-2010 10:30 PM
  8. alphadog's Avatar
    I just got this working. I had the drivers from Samsung for the Captivate, but that doesn't work for the pC connection. You need to download the full driver pack - it looks like it is generic for all samsung devices. Softpedia also has the 32 bit version - 18 MB file, but once installed the phone is seen as an NDIS driver (network card) and it just works.
    07-19-2010 10:06 AM
  9. Lyanheart's Avatar
    Is there an App that can create a wireless hotspot, ala what Froyo is supposed to be able to do natively (that ATT will probably disable) when it is released? I have an app on my Nokia e71 called Jokuspot that does this flawlessly and I'm probably going to miss it for the rare times it has come in handy.
    07-19-2010 10:15 AM
  10. BoBoCaptivate's Avatar
    I also did this and it is great. It took a few tries (install and uninstall, reboot a few times, etc) with the drivers but ultimately it was the 18 MB file that got it to work for me. Note that samsung has a 3 MB file of drivers on their site but that did not work for me ... I also tried the Kies software but eventually gave up on it since it was giving me problems and just doing the drivers was sufficient. Also, if you are doing mass storage make sure you "mount" on your phone ... by dragging the "notifications" window down.

    Also, I had problems with the PC Internet working while Wi-Fi on the phone was on and connected. (Wanted my computer to use the phone's wifi - necessary for some carrier hotspots I think) Once I turned off the Wi-Fi on the phone (notifications window) then it worked like a charm. I think I did get the Wi-Fi to work by turning it on afterwards ... but it was a little buggy for me. Anyone else have any issues with the Wi-Fi and PC Internet combination?
    jhnstn00 likes this.
    07-22-2010 12:09 PM
  11. BoBoCaptivate's Avatar
    Just as an FYI to all -- the problem with WiFI and PC Internet still is there (for me at least) ... however, it is not a Hardware issue ... PDAnet works fine in this configuration. So, it is a software thing.
    07-24-2010 01:49 PM
  12. jhnstn00's Avatar
    First, I installed the Samsung Drivers for Captivate from Support for Samsung Captivate™ (SGH-i897) SAMSUNG but that didn't completely work, could use mass storage, but not PC internet.

    Second, tried the USB debug: Found in Menu,Settings,Applications,Developement,USB debugging green check on, back to home, then plug in phone via USB. Then that installed more drivers, but still didn't get PC internet.

    Third. Worked for my Netbook Windows XP Home 32bit. Drivers found here Samsung Galaxy S USB Driver for Windows x86 Driver for Windows XP / Windows Vista / Windows 7 Free Download - Softpedia

    Took a few hours, many drivers installed, many forums read (XDA, AT&T, AndroidForums, Android Central) and many reboots of netbook. Yes it is working.

    Haven't tried Samsung Kies, but not sure I will.
    07-25-2010 04:18 PM
  13. pjs2004's Avatar
    I couldn't get the pc internet usb setting method to work for me, on win7 64bit, so I'm using pdanet. That software is great. It works so well and is very easy to set up. I used it before on my old palm phone for tethering. It's not plug-in-and-go like the pc internet method, but it works. You have to have an app running on your laptop and on your phone (which it'll install if you just run the setup on the laptop).
    07-25-2010 07:36 PM
  14. civvy1's Avatar
    I just tethered my netbook to both a grandfathered unlimited account and a new tethering account.

    I installed the official 3mb installer and got mass storage working. I was downloading the Kies downloader as I was reading this thread. On a whim, I changed my usb modem status under settings>application>development to the development mode and reattached.

    Holy Cow! All kinds of drivers suddenly started installing themselves, including Android USB Modem. Hmmm.... So I let it run it's course and finished installing Kies. Rebooted. Upon reboot, turned off wifi for both my computer and my cell phone. Nothing. Turned off the development mode. Set USB settings to prompt. Plugged in the cell phone. Checked PC Connect. I had My Network Places running and saw activity there. It automatically connected through the phone.

    I had my phone, which is grandfathered, tethered and went to dslreport. I got 1.45mb/s down and 75kb/s up to the closest server. Ugh for the upload speed. Anyway, removed my phone and stuck my wife's on- 1.4mb/s up and 60 kb/s down.

    I don't plan on using my tether since I didn't pay for it, but pleased as punch I finally got the darn thing set up after a full day of screwing with the settings. Plus, my wife will be happy, which makes me happy.

    AT&T rep at the store said it would work, they just didn't know how. AT&T support said it wouldn't work. I guess we have to figure it out ourselves. Crappiest documentation for any device- ever.
    08-02-2010 12:07 AM
  15. jhnstn00's Avatar
    code.google.com/p/android-wifi-tether/downloads/detail?name=wireless_tether_2_0_5-pre6.apk&can=2&q=

    Try wireless tether app. Works for me.
    08-03-2010 09:19 PM
LINK TO POST COPIED TO CLIPBOARD