1. dlee1001's Avatar
    Every few days after booting up my Note 2, the location services on my phone stop working. The funny thing is that when this happens, Google Maps and Google Earth can still find my location, but all other apps, such as Facebook, Chrome, and even the Samsung Weather Widget, can't find my location. Rebooting the phone again fixes the issue, but then it comes back after a few days. This leads me to think that it's a software problem instead of a hardware problem; why else would Google Maps and Earth be able to find my location but other apps can't, and that rebooting solves the problem for a few days?

    Does anyone else have the same problem? I don't exactly know when it started happening, but it's a small bother.
    05-12-2013 09:31 PM
  2. mmohn01's Avatar
    I would try a master reset to see if that fixes the issue.

    Sent from my SAMSUNG-SGH-I317 using Android Central Forums
    05-12-2013 10:53 PM
  3. RenoD2010's Avatar
    I bought a LG Optimus G on 5/10. I updated it to JB over the weekend. It has been working fine until tonight. Suddenly, even though maps and navigation know exactly where I am, Google's homepage in my mobile browser (Chrome or Dolphin) as well as Speedtest think I am in France somewhere. I am in NH for the record. This is really frustrating.

    Any help out there?
    05-12-2013 11:13 PM
  4. dlee1001's Avatar
    I bought a LG Optimus G on 5/10. I updated it to JB over the weekend. It has been working fine until tonight. Suddenly, even though maps and navigation know exactly where I am, Google's homepage in my mobile browser (Chrome or Dolphin) as well as Speedtest think I am in France somewhere. I am in NH for the record. This is really frustrating.

    Any help out there?
    If this is true, I'm willing to hazard a guess that it's a known problem with Jelly Bean. You're experiencing a similar (but not exact) issue as I am. I have an app called AndroSensor and it includes details about my location. Without GPS turned on when the location services are broken, the "Location" column says "Unavailable" in the app. Going to Google in any kind of browser yields the message "Precise location unavailable", even if the Google Maps and Google Earth apps themselves can determine my location. I find that to be very weird.

    Rebooting solves the issue, but I don't like rebooting. I'd like to continue to know more people who are having the same or similar issue as I am.
    05-13-2013 12:13 AM
  5. fablis's Avatar
    If this is true, I'm willing to hazard a guess that it's a known problem with Jelly Bean. You're experiencing a similar (but not exact) issue as I am. I have an app called AndroSensor and it includes details about my location. Without GPS turned on when the location services are broken, the "Location" column says "Unavailable" in the app. Going to Google in any kind of browser yields the message "Precise location unavailable", even if the Google Maps and Google Earth apps themselves can determine my location. I find that to be very weird.

    Rebooting solves the issue, but I don't like rebooting. I'd like to continue to know more people who are having the same or similar issue as I am.
    Hi dlee1001,

    I am experiencing the very same issue although not with the same device as I have a Samsung Galaxy Ace 2 using Jelly Bean 4.1.2

    I use the uk google homepage, and when on my home Wi-Fi I see United Kingdom with a blue dot, if I am outside using a different Wi-Fi router I get to see my current city, if I use packet data I see this too, if in the house however I only ever see United Kingdom on home Wi-fi, and if I turn off my Wi-Fi I will then see my current city.

    The real issue for me is the same as yours in that every few days when I go to visit my Google homepage I find that it will say Precise Location not available, and if I refresh the page right away it will show United Kingdom with a grey dot instead of the normal blue one, if I clear all cookies and cache etc it will then change to UNKNOWN... again with the grey dot, and this is the point when I am required to restart the phone in order to get the location to show the blue dot with United Kingdom again. And like you my Google maps can find me no matter what.

    We certainly shouldn't have to reboot the phone like this, do you still have this issue may I ask as I have tried everything to fix this.

    The other issue too is that facebook is unable to check in and find my local places when this issue occurs which is another reason why this needs to be fixed.
    08-19-2013 11:50 AM

Similar Threads

  1. HTC Vivid location services not working
    By shaoliao in forum HTC Vivid
    Replies: 5
    Last Post: 09-29-2013, 10:46 PM
  2. Location services not working
    By karaze49 in forum HTC EVO 4G LTE
    Replies: 7
    Last Post: 06-25-2012, 04:24 PM
  3. Location Services not working after Gb update
    By jainey99 in forum Verizon Droid Incredible 2
    Replies: 1
    Last Post: 07-27-2011, 08:23 PM
  4. Evo 4g Camera not working after OTA update
    By jack31484 in forum HTC EVO 4G
    Replies: 3
    Last Post: 06-20-2011, 11:25 AM
  5. boot screen not working after installing Froyo Kangerade V1.0
    By jrickman in forum General Help and How To
    Replies: 2
    Last Post: 06-20-2010, 12:11 PM
LINK TO POST COPIED TO CLIPBOARD