1. astraelraen's Avatar
    I have a new user with a ATT Galaxy S2.I've been trying to connect his phone to the exchange server with little luck. We can get the phone to actually connect to the exchange server, but it won't sync any mail.

    Whenever you try to sync mail it says it is unable to open a connection to the server due to a security error.

    I'm kind of puzzled right now as to the problem. We have changed no settings on the server and we have a total of probably 12 Android devices connected to the server working perfectly. We currently have a few Motorola, a few HTC and a few Samsung Galaxy 1 devices. This is the first Galaxy S2 device that we have tried to connect.

    Anyone else having issues with exchange?
    10-03-2011 03:47 PM
  2. Gdwheel's Avatar
    Try going to Location and security and select device administrators and make sure it is checked for the email account.
    10-03-2011 04:42 PM
  3. astraelraen's Avatar
    There is nothing under this option on his phone and there is no option to add anything here.

    I noticed on my own Droid X there is an option here for my corporate mail account.

    Any ideas on how to get the Samsung mail app to request to add permissions here? We have resetup the account about 3 times with no luck.

    It doesn't help that I am doing this over the phone the user. I may go by his location tomorrow and see if doing it in person helps rather than relaying commands over the phone.

    A quick google search also suggests putting a password/pin on the device even if the Exchange security policies don't require it. Our security policies do not require a password/pin, but I had him put one on anyway.
    10-03-2011 04:58 PM
  4. MCory's Avatar
    Using ActiveSync & SSL? I think I got a similar message before using SSL
    astraelraen likes this.
    10-03-2011 04:59 PM
  5. Gdwheel's Avatar
    I did not have to add a password or pin. It did require me to accept the security certificates before it would sync, but it popped up pretty quickly and after I activated the account it worked fine.
    astraelraen likes this.
    10-03-2011 05:29 PM
  6. astraelraen's Avatar
    Using ActiveSync & SSL? I think I got a similar message before using SSL
    Yes, we have SSL enabled and accept all certificates enabled as well.

    I did not have to add a password or pin. It did require me to accept the security certificates before it would sync, but it popped up pretty quickly and after I activated the account it worked fine.
    The user said something to the effect of "the exchange server is asking for such and such permissions" and I thought he said yes/accepted them. I will have to ask him to resetup the account and see if maybe he declined this step.

    Thanks guys.
    10-03-2011 05:32 PM
LINK TO POST COPIED TO CLIPBOARD