11-19-2013 08:38 AM
80 ... 234
  1. Magzabillion's Avatar
    I tried to root my At&t Samsung Galaxy S II last night, and now all it does is show the Samsung logo, GT - i9100 and a yellow triangle. Now it won't do anything. Please help me... ):

    it looks like this:
    11-30-2012 03:31 PM
  2. N2B8U's Avatar
    Dead Links. need to root my cousins S2
    03-16-2013 09:47 PM
  3. artyshellz's Avatar
    How do I root my skyrocket if I'm running android 4.1.2 jelly bean?

    Sent from my SGH-I727R using Tapatalk 2
    04-14-2013 02:33 PM
  4. Shubham Chugh's Avatar
    08-31-2013 01:50 AM
  5. Dr Triffid's Avatar
    If you haven't rooted already, but still want to (since most of you will be off contract by now), I would suggest Framaroot. It doesn't require a PC and drivers and the like.

    Download and install the app. When it asks you what exploit you want, SGH-I777 users should choose "Aragorn." There should be a success message and the phone needs to be restarted afterward. After the reboot, the phone will be rooted with SuperSU installed. The app can be uninstalled but it is fairly small and can be kept in case you want to unroot the phone (I haven't tried that yet.)

    For me, it's been OK for the past three days. I installed CWM and TiBU and now have backups. The only glitch I've encountered is that the stock browser wouldn't download my PDFs. That was fixed by going into the advanced settings and swiching the default storage from memory card to device.

    I hope this helps someone else who has been waiting two years to root their GSII.
    Jon Hal likes this.
    11-19-2013 08:38 AM
80 ... 234