1. frozencloud's Avatar
    Hi, I was wondering if anyone is having some Voice Quality issue on their Galaxy S II? I have been using the GSII since release day, and for the passed 2 weeks, a few people informed me on different occasions that my voice is distorted a few min into the conversation (this happens every few phone call). However, my side of the line is crisp and clear. I had to hang up and recall them for it to come back to normal. I tried resetting my phone and the problem still persist. Any suggestion on what to do?
    10-28-2011 04:15 PM
  2. jsntrenkler's Avatar
    I had this happen on my original device. I have exchanged since then and have not noticed the problem. I have noted though that if I raise my voice during a conversation I can hear my voice echo.

    Sent from my SAMSUNG-SGH-I777 using Tapatalk
    10-28-2011 06:32 PM
  3. spettiner's Avatar
    I'm curious about this issue as well. I've had two different people complain to me about this (they were both using iphones, if that matters).
    10-28-2011 07:56 PM
  4. jsntrenkler's Avatar
    My problems appeared to those on land lines as well as cell phones. This will be a interesting forum to watch.

    Sent from my SAMSUNG-SGH-I777 using Tapatalk
    10-28-2011 08:49 PM
  5. frozencloud's Avatar
    My problems appeared to those on land lines as well as cell phones. This will be a interesting forum to watch.

    Sent from my SAMSUNG-SGH-I777 using Tapatalk
    mine are mostly cell phone.
    10-29-2011 05:49 PM
  6. spettiner's Avatar
    We must be the only 2 with this problem.....
    10-31-2011 12:59 PM
  7. frozencloud's Avatar
    We must be the only 2 with this problem.....
    lol....ill say we are the unlucky one. gonna do another reset...if that still doesnt work...imma try to get it replace.
    10-31-2011 03:48 PM
  8. MrMercedes's Avatar
    Install a rom and the problem should be solved....That's what I did. Unnamed Rom to be exact
    11-01-2011 11:44 AM
  9. spettiner's Avatar
    I traded for a new one today. We'll see if that works.
    11-01-2011 03:37 PM
LINK TO POST COPIED TO CLIPBOARD