1. dr. acula's Avatar
    Ever since last night's day light savings' change, all my incoming texts have the wrong time. And they aren't off by one hour, it says they came in anywhere from 20-60 minutes ago. I know this isn't right, but it causes it to put them in the wrong order so I have to scroll up through other messages to see the newest one, which I can only identify based on context. This is extremely annoying.

    I have tried restarting my phone and deleting all messages. Any way to fix this?
    11-06-2011 02:13 PM
  2. jbliv63's Avatar
    Same issue here. Very strange.
    11-06-2011 03:00 PM
  3. codycorexxx's Avatar
    Is it affecting JUST text messages?

    Stock ROM? Unfortunately, I don't have daylight savings, so I can't help there, and I am running CM7. Have you just gone in and messed with date and time settings? I assume the fix would be in there.
    11-06-2011 03:32 PM
  4. dr. acula's Avatar
    It is just text messages. I checked the date and time, they seem fine....

    I downloaded an app called 'time stamp fix' or something like that. Set it to use my phones current time for the time stamp. Fixed the issue, but I don't want to have to run some app just to get SMS working how it should anyway.

    Stock, btw.
    11-06-2011 06:17 PM
  5. frozencloud's Avatar
    my sms is fine, but I use go sms. Not sure if that matters. How is your time set up in the "Date and Time" setup menu? Is it on Automatic (Use network-provided values) or did you set up everything manually?
    11-06-2011 07:37 PM
  6. glorifiedsins's Avatar
    Have you power cycled your phone and searched for updates since the time change. Not experiencing this issue here.
    11-07-2011 03:49 AM
  7. dr. acula's Avatar
    I had it on automatic. After a day of having that app, I have turned it off and things are now working normally.

    Weird.
    11-07-2011 04:27 PM
LINK TO POST COPIED TO CLIPBOARD