1. thompsr2's Avatar
    I have set my incoming mail settings so that all message sizes will be downloaded. However, any emails with attachments are still not downloading to my phone. Any suggestions?
    11-09-2011 02:19 PM
  2. tunie's Avatar
    If you long press the little arrowhead to the right of the attachment, it will drop down revealing the name of the attachment along with a floppy disk icon to the right. If you touch that, it will save the attachment to your downloads folder. I don't believe there is a setting to automatically download all attachments.

    I would suggest either using the Gmail app (though you have to install another app in order to attach docs to an email) or, what I use, K-9 Mail from the market. K-9 is great, but it's a little bit of a pain to set it up. However, once it's set up, you're done and it works great!

    Hope this helps...
    11-09-2011 04:19 PM
  3. thompsr2's Avatar
    I might have to give K-9 a try, if I can't figure this out. It's not just that the attachments aren't downloading, the entire email never enters my inbox. This is for all emails with attachments.
    11-09-2011 04:43 PM
  4. tunie's Avatar
    That sounds like a settings issue, but TW email isn't the most intuitive app you can use. If you're using a gmail email account, you might try the Gmail app before K-9 just to make sure your email is hitting your inbox. If your email isn't hitting your inbox with the gmail app, you may need to go to your Gmail account from your PC and check your email settings there. Under Forwarding and POP/IMAP, you'll want to make sure imap is enabled. This allows two-way communication from gmail to your S2. I have 6 email accounts and have them all set up in K-9. If you decide to try it and have problems getting it set up, just ask in here. A lot of us use K-9, so someone will always be able to help:-)
    11-09-2011 04:54 PM
LINK TO POST COPIED TO CLIPBOARD