1. Deenybird's Avatar
    I am using the UCKH7 one click w/root tool.
    I start download mode by holding volume up and down while plugging in USB. I click the start button but the program hangs at 'factoryfs.img'

    Please help. Thanks.

    AT&T galaxy s2
    12-18-2011 02:50 PM
  2. Deenybird's Avatar
    Just wanted to post that my problem is solved.

    Summary: My AT&T Galaxy SII showed an error on boot (software upgrade failed. connect to kies...). Kies wouldn't even recognize the device so that route was a no go. So as everyone's recommended method of last resort, I decided to flash the device back to stock via odin. I entered download mode (volume up + volume down and plug in usb) and Odin would recognize the device, I would load the stock rom in the PDA slot and hit start and it would begin normally, but it would always fail after a few seconds on 'NAND write start', or 'factoryfs.img'. So I got a 1 click download solution using odin for reverting my phone back to stock. Same thing, it would recognize the phone, but stall out and fail. I also tried flashing clockworkmod via odin but and same problem. People recommended I try heimdall. It would recognize my device, and then fail after 'kernel 100%'.

    I tried both programs on 3 different computers, and must have tried 12 different USB slots amongst all of them. I'm fairly handy with this stuff and I worked for hours on it.

    xtra info: I had successfully used odin on my computer to flash a kernel just a week ago so I know my stock usb cable was working etc...

    Resolution: So I hung my head and drove to the ATT store. After pressing a few buttons on the device and not getting anywhere they sent me to a nearby Device Support Center. I told the girl at the counter that my phone booted to this error screen and that connecting it to Kies did nothing. She asked if it was ok that in the case that she couldn't fix it she would offer me a replacement. I said that was fine and after 10 minutes in the back room she came out with a replacement (free of charge).

    Well that was the good news. For the bad news, unfortunately I still don't know how to fix the problem I had, and don't really know how to avoid it in the future. I thought phone's could only get truly bricked if you messed with PIT files and such. There didn't seem to be anything more I could do than flash with odin or heimdall as those were already last resorts. I know I had the right files, the right drivers, and working usb. No matter how crazy I got with my iphone, a full restore was only a click away by plugging in to iTunes. Somehow I messed up my phone so bad that even the device support center couldn't fix it....? Shouldn't have had to be like that.

    Thank yous: Thanks to ATT for having a walk-in store and for so easily offering up a replacement. Thanks to the many people on the web who offered remedies.

    tl;dr - phone broke, att replaced, still a mystery
    12-19-2011 09:41 PM