1. perrochingon's Avatar
    Hi there,

    I noticed that everyone seems to be having issues with battery drainage after the new update but are any of you experiencing issues when you try to connect to your home wifi? After the update today, i cannot connect to my home network. It keeps saying obtaining IP address but never connects. its very frustrating! if you guys know of a fix for this it would be of great help, thanks!!!
    01-10-2012 11:08 PM
  2. wreckit72's Avatar
    Have you tried resetting your router?
    01-11-2012 06:58 AM
  3. Entropy's Avatar
    Got a Belkin by any chance? UCKK6 is full of all sorts of wifi/bluetooth bugs:
    1) The BT-AMP battery drain issue
    2) Doesn't like Belkin routers and possibly others too
    3) Bluetooth HID (keyboards/mice) is 100% totally and completely broken
    01-11-2012 09:56 AM
  4. perrochingon's Avatar
    Actually, reseting the router is one thing I did not bother doing. Since the Wifi was working just fine before the update, I figured it had something to do with 2.3.6. But I will definitely give it a shot as soon as i get home tonight. Thanks for the tip. I have a 2wire modem/router btw if that helps
    01-11-2012 10:25 AM
  5. wreckit72's Avatar
    I had to reset my router a couple of different times after upgrading. This along with the battery drain issue prompted me to go back to 2.3.4.
    01-11-2012 10:36 AM
  6. perrochingon's Avatar
    Yeah Im definitely considering going back to 2.3.4. I'm going to try reseting the wifi but if it keeps giving me issues and the battery life is really horrible, Im going to go back to 2.3.4. Would you happen to know of a reliable method to go back to 2.3.4? I'm not rooted so I'm not sure if its even possible
    01-11-2012 10:45 AM
  7. wreckit72's Avatar
    01-11-2012 03:02 PM
  8. TwinSac's Avatar
    I also had no connection to my wifi until I rebooted my phone. I even pulled the battery just to take it one step further.
    01-11-2012 05:29 PM
  9. chaplain's Avatar
    And there's the obvious - be sure to check and see if mac filtering is enabled on the router, and either disable it or check to make sure that the mac address for your i-777 is entered correctly.
    01-11-2012 10:26 PM
  10. tsj's Avatar
    make sure you're using a compatable kernel. I was using 2.3.6 and my Wifi wouldn't connect either, Wifi would turn on for about 10 seconds then mysteriously shut off. Flashed Unnamed Rom with Siyah kernel and Voila!
    01-18-2012 10:33 AM
  11. 1Prosperous1's Avatar
    How did you flash Unnamed Rom. I am pretty new to this but trying to help my neighbor's daughter who just wants to use her new computer (mini laptop running android). She is using a 2.3.6. kernel too and cant connect. The computer is recognizing my wifi but is is unsuccesssful when it tries to connect. Any help you can give would be appreciated.
    Thanks,
    Carla
    02-13-2012 01:53 PM
  12. Entropy's Avatar
    How did you flash Unnamed Rom. I am pretty new to this but trying to help my neighbor's daughter who just wants to use her new computer (mini laptop running android). She is using a 2.3.6. kernel too and cant connect. The computer is recognizing my wifi but is is unsuccesssful when it tries to connect. Any help you can give would be appreciated.
    Thanks,
    Carla
    Unnamed is specifically for the AT&T Galaxy S II (there is also a version for the Sprint Galaxy S II, but you must install the version specific for your device.) It will not be of any use on any other device.

    Also, wifi issues like this have nothing to do with Android 2.3.6 - they are specific quirks of the device manufacturers' build. For example, the UCKK6 build for AT&T Galaxy S II devices has majorly broken wifi and just happens to be Android 2.3.6, while the XWKL1 build for international Galaxy S II device is ALSO 2.3.6 but has none of the wifi issues present in UCKK6 despite being only 1-2 weeks newer than UCKK6. This is why I NEVER refer to updates by Android minor version, as it's meaningless in almost all situations.
    02-13-2012 02:51 PM
LINK TO POST COPIED TO CLIPBOARD