1. mviglesias57's Avatar
    I've had some problems with the "sleep of death" on my SGS2 lately, and now, for some reason, it plays the "Over the Horizon" ringtone continuously when I power the phone on. I don't have that ringtone setup for anything or any contacts. If I turn the phone over (face down), the ringtone stops. Does anyone have any idea why it would be doing this?
    01-22-2012 01:29 AM
  2. cwells's Avatar
    I would like to know the answer to the question as well because it does happen to me but not frequently. Anyone know?
    01-25-2012 07:23 PM
  3. tunie's Avatar
    I've had some problems with the "sleep of death" on my SGS2 lately, and now, for some reason, it plays the "Over the Horizon" ringtone continuously when I power the phone on. I don't have that ringtone setup for anything or any contacts. If I turn the phone over (face down), the ringtone stops. Does anyone have any idea why it would be doing this?
    First, I would say if you're experiencing the dreaded SOD, I would exchange it if it's under warranty. I've never had that happen with my S2, so there might be something wrong with yours. In the meantime, I came across this in another forum and it seems to have helped a few folks, so I thought I'd pass it on. I assume you're running everything stock? By the sound of it, your phone wasn't playing a sound at boot up before but it is now? This could be a firmware issue, but I would try the steps below to see if it resolves your SOD and sound issue. The soft reset seems to have helped some folks. I hope it helps both of you:-)

    ------------------<<<<<<<<<<<<<<<<<

    Take out the battery, then press and hold the ON button for 7-10 seconds (the longer the better). Reinsert the battery, then press ON button to start it. This is a soft reset, and wipes the temporary memory and empties all remaining power in the circuits. This helps on many phones and even laptops that won't start properly or show anything on screen.

    If this does not work, try the next step. Again, do as above. But after inserting the battery, do not turn the phone on, but press and hold the ON button and the HOME button at the same time for 7-10 seconds. This is a hard reset, and works best if done after a soft reset. Just be sure the battery has at least some juice in it and isn't empty. If possible, try with another battery if this does not work.
    01-28-2012 11:41 PM
  4. mviglesias57's Avatar
    Thanks for the suggestions. The phone stopped playing the ringtone when it boots on it's own so I'll try them if it does it again.
    01-30-2012 11:50 AM
  5. tunie's Avatar
    Glad it stopped! Let's hope it stays that way:-)
    01-30-2012 09:41 PM
LINK TO POST COPIED TO CLIPBOARD