1. omegaglory23's Avatar
    I have searched for an explanation, andI have yet to find one. I have a GS2 I am running 2.3.6 my phone constantly will constantly stay at 100% battery, and that isn't correct. I contacted AT&T and I have having a new battery sent to me. Problem solved there, downside, I tried to flash CM7 but my phone would not connect via USB at all. I tried placing it in USB mode, but the phone constantly says the cable is connected when it is not. I have done three factory resets trying to correct the issue, but it does not correct anything. I does anyone know how to force the phone to go into USB mode? or how to correct this? I have rooted before, but I used the Un-root method thread on how to undo it.

    Any help is appreciated
    01-29-2012 11:58 AM
  2. GJMX's Avatar
    Check to see if you have the usb drivers on your pc. If not download kies and install on your pc.
    02-29-2012 03:39 PM
  3. Trip64's Avatar
    my first GSII had the physical usb on the phone fail. it would charge but would never connect to any pc. i returned it and got a new one. i put all the same apps on that i had with the first one...(i had it only 3 weeks) and it work fine.

    so try other pc to see if it will even see the phone. with the bad one the pc would see that something was on the usb but it never would discovered that it was a GSII.

    good luck
    03-01-2012 08:27 AM