1. Angelsnecropolis's Avatar
    I had previously successfully installed shostock ROM. Attempted to install CM9 4.0.4 using Odin 1.85. Program got hung up on in the processes of installing the data at 95%. Did rebooted phone and did a recovery of a backup from earlier that day using CMW. Everything else works fine except calling. I can dial out and accept incoming calls but I don't hear a ring or anyone pick up. The other caller is unable to hear me as well. It seems to be picking up because I can see on my phone the speaker and mute options becoming available, not no sound at all. I've even tried calling 1800 numbers and I can't hear their automated system.

    Any ideas??

    Sent from my Samsung Galaxy S II
    04-21-2012 06:12 PM
  2. Jonna09's Avatar
    Sorry to hear that. I don't know what to suggest. There are surely people with more know-how about this who would give better advice.

    Try going through XDA dev forums. Surely people would have botched up the process at some step and still recovered.

    My guess, is that your modem is messed up. Flash a proper one again and see if that helps.
    04-21-2012 06:47 PM
  3. Angelsnecropolis's Avatar
    Yeah I'll post on XDA soon too. My phone just crashed and showed a "Kernal Panic" error. So something is obviously f'ed up. Will have to do more research once I'm at my PC.

    Sent from my Samsung Galaxy S II
    04-21-2012 06:59 PM
  4. Jonna09's Avatar
    Here is something i found on the ShoStock2 thread on XDA, similar to your problem....well your first one at least

    "Originally Posted by 78Staff
    What problems are you seeing with Siyah, I've been running v3.1rc2 for about a week and it's been rock solid..."

    Well in the crow eating dept, Turns out several people that I called/called me either could not hear me at all, or heard a severe echo on their end. Did not see this behavior with 2.1 and CP kernel. Tried a few different modems but basically the same result.

    The only difference was the kernel essentially (and modem). So I re-flashed 1.2 with BLN version of CP (because it's the one I had on the phone) and all is right again in the world as far as phone calls go. People hear me fine, no echo, etc.

    Didn't think a kernel would cause actual call issues, but I guess it can? Anyway back to CherryPicker for now .

    Funny we (or I, I guess) always seem to test apps, speed, etc and neglect to check the one thing the phone was created for in the first place, actually making calls LOL.
    Angelsnecropolis likes this.
    04-21-2012 08:17 PM
  5. Angelsnecropolis's Avatar
    Well I was able to successfully install the latest CM9 ROM based on Android 4.0.4 and also flashed a new Kernal (Siyah v3) but still no dice in making calls. =(

    I'll look specifically about info on fixing the phones modem now.
    04-22-2012 11:36 AM
  6. Angelsnecropolis's Avatar
    AH! Great success! I downloaded and installed he KJ4 CM9 Modem and was able to place calls now! I'm happy.
    You mentioning the modem and kernal is what pointed me in the right direction to find the downloads I needed. Much appreciated. =)
    04-22-2012 11:46 AM