1. blb1980's Avatar
    I'm running a SIM card on my unlocked att phone on straight talk. I have issues all of the time sending picture messages. Is this a phone issue or service issue? Restarting phone and airplane mode off and on temporarily fixes it. Gets annoying though having to constantly do this in order to send a picture message
    06-03-2012 04:41 PM
  2. Lawrence of a Labia's Avatar
    Do your APN settings (Settings > More > Mobile Networks > Access Point Names) match with the ones in this guide?

    http://www.straighttalksim.com/pdf/S...rd_AT&T_R3.pdf
    06-04-2012 11:14 AM
  3. blb1980's Avatar
    Do your APN settings (Settings > More > Mobile Networks > Access Point Names) match with the ones in this guide?

    http://www.straighttalksim.com/pdf/S...rd_AT&T_R3.pdf
    I ended up calling customer service and we went over my apn settings. They told me to change "Straight Talk" to "straighttalk" in apn settings. Restarted phone and seems to be working ok for now. What I don't get is why it sometimes would send and sometime it wouldn't. If I did airplane mode off and on it fixed it temporary or if restarting phone wad was temp fix
    06-04-2012 12:51 PM
  4. blb1980's Avatar
    Do your APN settings (Settings > More > Mobile Networks > Access Point Names) match with the ones in this guide?

    http://www.straighttalksim.com/pdf/S...rd_AT&T_R3.pdf
    It appears that my issue is when I have WiFi turned on I can't send or download pics in the text messages. Is this normal for any phone or should I be able to do this with WiFi on? I have 2.3.6 android on my phone and I've read on other forum about the update causing battery drainage and also some errors with WiFi but no mention of the inability to send/receive pics.
    06-05-2012 01:18 PM
  5. dingbat005's Avatar
    a while back there was a post that mentioned the same thing and I have the issue as well... its EXTREMELY annoying and i forget it all the time... in my experience even if i remember right after i send to switch off wifi it won't go - have to resend while wifi is already off
    06-05-2012 04:47 PM
  6. blb1980's Avatar
    a while back there was a post that mentioned the same thing and I have the issue as well... its EXTREMELY annoying and i forget it all the time... in my experience even if i remember right after i send to switch off wifi it won't go - have to resend while wifi is already off
    I was seriously thinking to go back to virgin Mobile since they came out with the evo 4g but I'd like a solution to the pic issue of possible but I could live with switching WiFi on and off I guess. Still trying to figure out if this is a Samsung issue or a straight talk issue ? I have found it very easy to get a hold of customer service using their online chat agent help. I was going to ask them about it to see what answers they provide
    06-05-2012 05:22 PM
  7. deannamarie816's Avatar
    i cant send picture messages at all. My apn settings are all correct
    09-05-2012 06:58 PM
  8. nonie's Avatar
    I have att i777 gs2 phone, no problem sending or receiving photos in my text messages.
    09-06-2012 07:43 PM
  9. chunkypoo's Avatar
    Hey guys I had a problem like this. Straighttalk sim. Att samsung captivate. Could receive but couldn't send MMS. Data enabled and APN settings correct. Internet worked. Everything except sending MMS. What I didwas for a ccombination of working APN settings from trial and error. I'm using the newest slimbean on sghi897
    First go to your settings.
    Go to mobile networks... Network operator. Let it search until you can manually select. If you can select ATT and the registration is successfull then you can use these settings

    Name: straighttalkATT
    APN: WAP.tracfone
    Port: 80
    Mmsc: http://mmsc.cingular.com
    MMS proxy: proxy.mvno.tracfone.com
    MMS port: 80
    MCC: 310
    MNC: 410
    APN type: default,supl,MMS (no spaces after commas!)

    Hopefully that works for someone having the problem I was. Its tricky and I just kinda figured it out so I wanted to share somehow

    P.S. manually delete all other APN setting by clicking them as if you were to edit, press your menu hard key, and select delete. Gone

    PPS... I have a T-Mobile sim card hence the combo of att and t mobile APN settings. Used T-Mobile for internet and att mms
    sierracozby likes this.
    04-28-2013 05:36 PM
  10. sierracozby's Avatar
    THANK YOU SO MUCH!!! I just got my phone off of Amazon already unlocked and I am using a StraightTalk sim-NOW I CAN SEND AND RECIEVE PHOTOS!!! Thanks! Totally made my day!
    05-17-2013 04:43 AM
  11. carolyn1010's Avatar
    I can't send or recieve picture messages. I have a at&t fusion. HELP!
    05-31-2013 12:22 PM
  12. Jamie Otriz's Avatar
    I have a Motorola Atrix 4G and i can receive MMS but not send my APN settings are as follows
    Name : straighttalk
    APN : WAP.tracfone
    Proxy : 66.209.11.32
    Port : 80
    MMSC : http://mmsc.cingular.com
    MMS Proxy : Proxy.mvno.tracfone.com
    MMS port : 80
    MCC : 310
    MNC : 410
    APN type : default,supl, mms
    APN protocol : IPv4/IPv6
    07-23-2013 10:11 PM
  13. Evalani Tuatoo's Avatar
    What are your settings? I have the same phone but I can't send/receive photos in my text messages...
    09-07-2013 11:13 PM
  14. 2foxxy's Avatar
    I have a HTC inspire. Could send and receive text messages but could only receive mms messages not send. Changed Straight Talk to straighttalk in my apn settings. Now everything's working fine.
    10-03-2013 12:13 AM
  15. Holly Harlin's Avatar
    I'm running a SIM card on my unlocked att phone on straight talk. I have issues all of the time sending picture messages. Is this a phone issue or service issue? Restarting phone and airplane mode off and on temporarily fixes it. Gets annoying though having to constantly do this in order to send a picture message
    10-29-2013 10:28 PM
  16. teamtweezy's Avatar
    I'm running a SIM card on my unlocked att phone on straight talk. I have issues all of the time sending picture messages. Is this a phone issue or service issue? Restarting phone and airplane mode off and on temporarily fixes it. Gets annoying though having to constantly do this in order to send a picture message
    11-28-2014 08:41 AM
  17. karenopiedawg's Avatar
    Just got off the phone with MetroPCS. Because my phone service has limited data, I had it set up not to allow me to use more (and be charged more). All you need to do to send and receive pictures is, turn your mobile data on and your wifi off. They can't both be on. From Home page, click Apps, then Settings, then WiFi - at the top click Off, then use the back arrow, Data usage, mobile data On. Be sure to put wifi back on (after sending and receiving pics) if you're using your home network and don't want to use up all your data.
    06-27-2016 12:14 PM
  18. Leigh Moran's Avatar
    I can't send gallery photos to messages
    12-15-2016 02:53 AM
LINK TO POST COPIED TO CLIPBOARD