05-10-2013 02:52 PM
72 123
  1. archittech7's Avatar
    Sounds like everyone is finally getting to my world. I've been having this problem since the ICS update from GB. I even tried 2 factory resets. I was hoping the 4.04 update would have fixed that issue, but it's still there. I'm thinking the only hope is to root it to JB or back to GB.
    12-30-2012 03:44 PM
  2. mviglesias57's Avatar
    You might try disabling any apps you have running in the background to see if that helps. I installed Task's JB ROM on my phone, and it had the "sleep of death" problem at least once a day. I had Juice Defender running, so I disabled it. No more "sleep of death"...
    12-30-2012 10:02 PM
  3. barotropic's Avatar
    I think I've fixed my Galaxy S2 problems! It has been completely stable, very responsive, with great battery life for 4 days.

    After the 4.0.4 update, I saw the all the problems being described here: spurts of extreme battery discharge, spontaneous reboot, but most often "sleep of death". After the "sleep of death" episode, the phone indicates the battery is dead if you hold the power button. But usually, as soon as you plug in the charger, the battery indicates less than empty, and the phone will boot.

    Per AT&T's advice, I removed lots of apps (mostly geeky, system-oriented apps). No luck. Then I did a factory reset. Better, but no luck - still saw "sleep of death" occasionally. Unacceptable, as my job depends on the phone.

    On a hunch, I tried something else: disabled all the AT&T crapware apps, being specifically concerned about "AT&T Smart Wi-fi".

    Background: I remembered that several months ago I saw this app in the Play store, and it looked useful. I installed it, and my phone became unreliable. I didn't recognize the problem immediately, because I suspected my new SD card was the culprit. After two weeks, I uninstalled the app, and the phone became stable again. A few days ago, I noticed "AT&T Smart Wi-fi" came along with 4.0.4 as a system app, so I disabled it and the phone has been great since.

    Actually, I disabled most of the built-in apps (you can't uninstall them, unfortunately), but I suspect the Smart Wi-fi app was the culprit.4.0.4 Update-disabled_apps.jpg
    maxud and geek4ever like this.
    01-04-2013 09:44 AM
  4. enjoylife949's Avatar
    Thanks for sharing this information. It is funny that right after I read your post yesterday there was an update for AT&T Smart Wi-Fi
    01-05-2013 01:12 PM
  5. Peacen1k's Avatar
    I'd still keep it disabled if you don't get the sleep-of-death anymore. That app is about as useful as a virus.
    01-05-2013 03:55 PM
  6. nonie's Avatar
    Thanks for sharing this information. It is funny that right after I read your post yesterday there was an update for AT&T Smart Wi-Fi
    I assume this is one you downloaded from app store.
    01-05-2013 04:07 PM
  7. Dr Triffid's Avatar
    For the first time since before Christmas, I am posting with a GSII in hand ó since the update failed and hosed my handset.

    I downloaded the update and went through the steps, but on the actual firmware update screen, the progress got to 60 percent, the progress bar stalled, and an "update is failed" message appeared. After the restart, I didn't notice anything immediately wrong, but the phone started crashing twice a day and when I tried to use the camera ó which went black and started spouting error messages ó I knew the li'l buddy was in trouble.

    First stop was AT&T, which quickly informed me that my handset was out of warranty and that they would be happy to point me in the right direction toward making an insurance claim.

    I replied that I really didn't want to pay a $200 deductible for the failure of an update that was sent out while the phone was out of warranty.

    But I didn't have to update, they countered.

    The fact that the phone was interrupting whatever I was doing on it every 15 minutes to inform me that I needed to complete an update could be construed otherwise in some circles, I noted.

    Well, let's try a factory reset ó and then another factory reset, and possibly a third.

    What about the two factory resets I've already tried this evening?

    You probably did them wrong. You need us to guide you.

    Later ...

    Well, it looks like there is something wrong with your phone. You really should talk to the insurance people.

    Why don't I talk to your supervisor?

    Why don't you try talking to Samsung? It's their update, not ours. See what they say and then call us back.

    Sooo ... I tried Samsung and went through two more factory resets. But even though I had registered the phone on their site the day I bought it, they said it was still under warranty and I could still send it to them for repair. That was Dec. 24. I shipped out the phone on Dec. 26 and it returned to my porch this morning.

    Samsung said the camera definitely was hosed and the LCD was not getting a proper charge. They replaced the camera, screen and an unspecified component, while also performing a software update that was not described. The version is still 4.0.3, but I did notice that when the phone is shut off and plugged in, it beeps for a full battery charge. I don't recall that happening before.

    I'm not inclined to try the update again, as for the past week-and-a-half, I was forced to use an old iPhone 3G. I don't think I could go through that again.
    nonie and robcassman like this.
    01-07-2013 11:58 PM
  8. maxud's Avatar
    thank you barotropic,
    I was starting to feel hopeless until I saw your post. I have disabled all ATT crapware, keeping the fingers crossed.
    Will update back in a week. I pretty much had black sleep of death once a day.
    01-08-2013 09:45 AM
  9. nonie's Avatar
    Dr. Truffle, good to know Samsung came through for you. So the update caused all your problems?
    01-08-2013 10:06 AM
  10. Dr Triffid's Avatar
    Oh, yeah. It's working fine now. It's just like when flashing a custom ROM ó stopping halfway through for whatever reason will cause bad things to happen.

    One day later and I have everything back to the way it was on the phone, but now with a 64GB microSD card I received for Christmas. Just like with the 8, 16 and 32GB cards, I feel like I could never fill something that large.
    01-08-2013 06:19 PM
  11. natehoy's Avatar
    4.0.4 was causing my wife's s2 to lock up when idle as well. She missed a number of calls, reminders, etc.

    Factory reset did not help.

    Based on recommendations from a couple of xda threads, i disabled something called at&t smart WiFi, and a bunch of at&t crapware as well.

    It's only been one night, so time will tell.

    Sent from my Nexus 7 using Android Central Forums
    01-10-2013 06:07 AM
  12. maxud's Avatar
    thank you barotropic,
    I was starting to feel hopeless until I saw your post. I have disabled all ATT crapware, keeping the fingers crossed.
    Will update back in a week. I pretty much had black sleep of death once a day.
    It has been 3 days and the phone just works, no more lockups.
    This is awesome and kind of pathetic. I am extremely happy about the fact that the phone works as it suppose to, instead of locking up.
    Another side issue that was resolved is my battery life. With previous 4.0.3 my battery life would be 6 hours, with Android os consuming large percentage of battery life.
    After 4.0.4 upgrade, I am back to having ~50% left at the end of the day.
    01-10-2013 12:03 PM
  13. natehoy's Avatar
    Update... Currently two full days since disabling the at&t crap, no lockups and battery life is reportedly much better.

    My wife is very happy that she can actually leave Wi-Fi on without the battery being zeroed out in a few hours.

    This should never have been an issue, but I'm very happy ICS has such an easy way to disable the crapps.

    Sent from my Nexus 7 using Android Central Forums
    01-11-2013 07:20 PM
  14. barotropic's Avatar
    An update to my post on fixing my GSII problems by disabling AT&T apps: After a nearly a week, the phone is mostly stable. I have seen 2 sleep death episodes, and one may have actually been my fault - battery usage has been so low recently that I forget to charge the phone, and the battery may have died a natural death during the night! But the other was the classic sleep of death, so the problem is not completely gone.

    On the bright side, I have never, since buying the phone 14 months ago, seen such good performance and low battery drain as I see now. Apps are very snappy, and a battery at 100% in the morning will drop to around 70% at the end of the day with my normal usage pattern. I used to charge it at every opportunity.

    I certainly wish I could count perfect behavior, but I don't think we're there yet. I'm considering making a daily habit or restarting the phone each morning, to see if that helps. I remember it being a good idea on older, less stable versions of Windows.

    In any case, be sure to disable the apps referenced above, and at least the "AT&T smart wifi" app". Like others, I am appalled that AT&T produces something so detrimental to the phone experience, then has the gall to force it into the OS, and subsequently seems clueless that it is a huge source of problems. It really motivates me to pursue a Nexus phone from Google next time around.
    01-12-2013 11:56 AM
  15. natehoy's Avatar
    Another day, another lack of problems since the crap was disabled. The very first sleep-of-death and the phone is going cyanogenmod. I'm just looking for an excuse to vanilla it. :-)

    One advantage the s2 had over my phone (a thunderbolt on Verizon) is that when the thunderbolt reboots, you're looking at a minimum of about six or seven minutes and a good twenty percent of charge. So at least it starts up quickly.

    But that's no consolation when you've missed an important call or text, of course.
    01-12-2013 04:10 PM
  16. afrozeke's Avatar
    I disabled everything mentioned in this thread and continued to get SODs. I finally had enough and rooted/romed it. Been running SuperNexus for a week with no SODs. Battery is pretty good too.

    I'm one if those people that dislikes rooting and dealing with roms. So this was literally a last resort. My phone was completely useless at least once a day. This was my last straw with Sammy. They have great software on release day and then muck up the works supporting updates. Blame AT&T if you want the phone says Samsung and they should fight for their customers' satisfaction. They don't. After this phone finally bites it I'm going Nexus. As long as it's not a Sammy Nexus again.

    I wonder how many people think this is a hardware problem and are re-upping a 2 year contract to get a new phone. Face palm.

    Sent from my Nexus 7 using Tapatalk HD
    01-16-2013 01:19 AM
  17. canesknights's Avatar
    I disabled everything AT&T and also still receive SODs. I'm also going to go with SuperNexus, as I think it will be the closest to the Nexus 7, whose OS I really like.
    01-16-2013 11:43 AM
  18. barotropic's Avatar
    I disabled everything mentioned in this thread and continued to get SODs. I finally had enough and rooted/romed it. Been running SuperNexus for a week with no SODs. Battery is pretty good too.
    Hey, afrozeke, can you keep us posted on how well your phone is doing with SuperNexus? Like you, I don't relish rooting and ROMing my GSII, but I have no other choice, as I have no confidence that 4.0.4 will be fixed. So I want to make sure the risk and effort are worth it. Also, do you have any guidance/references (on the dummy level, please) on the process getting SuperNexus running?

    01-16-2013 12:12 PM
  19. afrozeke's Avatar
    I'll keep this thread posted.

    There is one issue that doesn't affect me at all. Netflix doesn't work on SuperNexus 2.0. I don't ever use Netflix on my phone so it was no biggie to me.

    I'll post all the steps I took later tonight. I'm no good at tutorials however so it is better to do what I did: Head over to XDA and read about all the options.

    Sent from my SGH-I777 using Tapatalk 2
    01-16-2013 02:04 PM
  20. natehoy's Avatar
    Six days after disabling the crapware, my wife's phone has just slept itself to death. Given that it was happening at least once and sometimes twice a day before disabling it, it's a significant improvement over the stock 4.0.4 with crapware enabled.

    But now it's time to choose a ROM. CyanogenMod 9/stable? 10/nighty? Or does anyone else have one they particularly like? As vanilla android as possible would be nice.

    Sent from my Nexus 7 using Android Central Forums
    01-16-2013 07:36 PM
  21. afrozeke's Avatar
    How I got rid of 4.0.4

    ***Do any of this at your own risk. Iím not an expert at rooting or installing anything.***

    Like I said Iím not good at writing tutorials. Iím going to keep it at a high level. We all know how to search forums and watch Youtube videos so please do those things for details. Iím not going to post links either. Not sure of the forum rules. Also, Iím sure I did one or two things I should not have but hey this worked for me.

    Rooting: There are many options for rooting the I777. The easiest process I found to achieve root quickly was the Exynos exploit app. Side load that bad boy and press one button. You are rooted.

    Decide on a rom and a kernel with cwm recovery. The rom will replace the initial kernel so just pick a kernel that is known to work.

    I downloaded this kernel: SiyahKernel v2.6.14

    Itís a gingerbread kernel. Be prepared for your phone not booting. More on that later.

    I chose and downloaded this rom: SuperNexus 2.0 - I777 - BUILD 1 [01-01-13]

    I picked it after reading the thread and not seeing that anyone had any major issues. Plus it had zero Sammy stuff in it.

    I also downloaded the GAPPS package compatible with this rom: Google Apps JB 12-12-12

    Now all of this is on my SD card.

    Install Kernel: I paid for and installed the mobile odin app. Yeah itís $5 but I did not want to deal with PC drivers. If you can deal with those there are free options.

    Using mobile odin I flashed SiyahKernel v2.6.14. Once this is done the phone will not get past the Samsung Galaxy S 2 splash page. You need to pull the battery and hold power/volume up/volume down at the same time to boot into cwm recovery.

    From within cwm recovery flashed SuperNexus according to the instructions and also flashed the Gapps.

    All done reboot and sign in.

    Youíll notice I didnít mention backing anything up. Iím fully in the cloud and didnít have anything important on my phone. YMMV as flashing requires a factory wipe. I also could not care less if my phone was ruined because I was hating it anyway. Now I kind of like it again. :-)

    Day 8 no SODs.
    barotropic likes this.
    01-16-2013 09:54 PM
  22. mviglesias57's Avatar
    The Exynos exploit is here: [ROOT EXPLOIT+PATCH][2012.12.19] ExynosAbuse APK v1.40 - xda-developers
    Supernexus ROM topic is here: [ROM][AOSP][JB][4.2.1][JOP40D] SuperNexus 2.0 - I777 - BUILD 1 [01-01-13] - xda-developers
    Forum for AT&T SGS2 ROMS: AT&T Samsung Galaxy S II Android Development - xda-developers
    The first posting in the Supernexus ROM topic gives you the steps to install it once you have the zip files on your phone and you have a CWM kernel installed.
    afrozeke and barotropic like this.
    01-17-2013 01:38 AM
  23. barotropic's Avatar
    Thanks, afrozeke and mviglesias57! I'm switching my SIM card to my old iphone 3GS for a few days (I'll just hold my nose), and getting for work on SuperNexus for the SGH-i777.
    01-17-2013 12:03 PM
  24. natehoy's Avatar
    Thanks for this. My wife's phone is back up to a sleep of death a day, even with the stuff disabled. Time to seriously research ROMs...

    Sent from my Nexus 7 using Android Central Forums
    01-18-2013 09:36 PM
  25. barotropic's Avatar
    For those interested, I followed afrozeke's advice, and rooted my GS2, then installed the SuperNexus ROM. It's a beautiful thing, seeing Jelly Bean 4.1.2 running on the SGH-i777.

    I'm still re-installing apps and getting things organized, but so far it's smooth and stable. Battery consumption seems a little high, but probably about the same as before the 4.0.4 ICS update. (Despite all its other flaws, 4.0.4 had impressively low battery consumption, in my experience - except when it went berserk!)

    I'll report back if I find any show stoppers.
    01-19-2013 05:26 PM
72 123

Similar Threads

  1. Got 1.6 update on Vodafone UK but not working :(
    By varunbhalla in forum T-Mobile myTouch 3G
    Replies: 1
    Last Post: 10-22-2009, 04:24 AM
  2. firmware updation
    By murali.lancer in forum T-Mobile G1
    Replies: 0
    Last Post: 10-14-2009, 06:37 AM
  3. Disabling OS update?
    By ethrbunny in forum General Help and How To
    Replies: 1
    Last Post: 09-14-2009, 09:01 PM
  4. Any way to Update ALL Apps in Android Market?
    By Casey Chan in forum General Help and How To
    Replies: 5
    Last Post: 09-01-2009, 04:56 PM
  5. Replies: 1
    Last Post: 06-09-2009, 06:26 PM