1. phoenixgreywolf's Avatar
    Ok, so yesterday morning at 3 am EST, I had a working Galaxy S2 Skyrocket with FULL data coverage under straight talk's network. Yes, this phone IS NET UNLOCKED! So before we get confused, this is not a NET LOCK issue. I am missing the NV_DATA and BAK files, and now have no service. I've tried installing 5 different ROMS using both TWRP and CWM (Both standard and Touch) to no avail.

    Is there or is there not a fix to this???? I can't afford to lose my phone, as its my business cell. Anyone who can figure this out will be my absolute hero, and will be rewarded with 100 cheeseburgers.... well ok maybe not that far, but you'll definitely be my hero... Sorry for the dry humor, been workin on this for 24 hours straight.
    04-22-2014 07:34 AM
  2. phoenixgreywolf's Avatar
    So out of 180 views, no response? Not even anyone else dealin with this issue?
    04-22-2014 11:14 AM
  3. Marc Luchejko's Avatar
    I have the same problem with an S3, no one seems to have the NV_DATA files I need
    04-22-2014 10:33 PM
  4. phoenixgreywolf's Avatar
    Does anyone have a fix for this? I've tried an EFS fix, and that did nothing. I've tried wiping to factory, installing Cyanogenmod 10.2, Dirty Unicorns, etc to no avail. I really need help with this guys, this is my only work phone and nothing I do works, but yet just a little while ago i had service for all but 15 minutes to send 2 texts, then died again... Is there something I'm missing? I'm no stranger to root or to TWRP/CWM Recoveries, or flashing new ROMS. Any help here would be greatly appreciated...
    04-23-2014 02:48 PM
  5. pthreee's Avatar
    I've been experiencing the same problem myself. Sometimes after a restart i can make calls but soon after it gives me the "not registered on network" dialog box. Been searching for a solution but they all require a backup of the efs file or the nv_data.bin file which is gone from my efs folder. I thought I could hex edit it and make it generate a generic imei thinking mine was blocked somehow(not sure I should be even talking about this here) but I can't do anything without it. Looking through my phone today I found the nv_data.bin on the internal sdcard (strange) but it's no use, it has 0 bytes.
    04-25-2014 04:14 PM
  6. phoenixgreywolf's Avatar
    Exactly!! This is the exact problem I'm having as well. I went so far as to order a new SIM card tray, and got it installed with no problem, but to no avail. I am still stuck without service. I really need to get this fixed, so I'm gonna take this thread and go over to XDA since none of y'all supposed programmers on here haven't enough brains to know how to type a response even with just a link to the fix to this problem.
    04-29-2014 08:22 AM
  7. pthreee's Avatar
    so, did you solve anything?
    05-13-2014 07:56 AM
  8. pthreee's Avatar
    Today I put my phone into GSM only mode. It seems to be working so far. When I'll need more than Edge internet i'll just switch back.
    05-15-2014 09:57 AM
  9. Dhinesh N's Avatar
    Did you find the solution? Been dealing with this for almost a week. Help much appreciated.
    01-25-2015 10:55 AM

Similar Threads

  1. I don't know what to do! HELP
    By manni1to in forum HTC One M8
    Replies: 26
    Last Post: 04-23-2014, 06:28 PM
  2. Obscure question about ringtones and notifications
    By bimmerdriver in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 04-23-2014, 01:45 PM
  3. Google Play Music Service Interruptions
    By Aredubu in forum LG G Pad 8.3
    Replies: 1
    Last Post: 04-22-2014, 10:17 PM
  4. How does chrome work so fast on EDGE?
    By AM_SOS in forum Moto G (2013)
    Replies: 0
    Last Post: 04-22-2014, 01:58 AM
LINK TO POST COPIED TO CLIPBOARD