1. revjimjr's Avatar
    AT&T SGH 1777 - Started getting this today when I tried to download some pictures to my laptop, which I've done successfully many times: "The last USB device you connected to this computer malfunctioned, and Windows did not recognize it." Tried all of the typical Windows fixes - battery-out shut down of both laptop and phone. All of the Device Manager stuff, downloaded and ran DeviceWin8... nada. I get the same message on my wife's Windows 7 machine. All of the features on the phone work fine.My wife's identical S2 works fine on both laptops. Any help will be most appreciated.
    06-14-2014 05:04 PM

Similar Threads

  1. Receiving happy face popup annoying window on android kitkat
    By AC Question in forum Ask a Question
    Replies: 17
    Last Post: 01-21-2017, 11:56 AM
  2. What's the news on 4.4.3 KitKat?
    By DebbieHeaney in forum Android 4.4 KitKat
    Replies: 4
    Last Post: 06-15-2014, 12:32 PM
  3. Can't access locations on google maps
    By ColinBH in forum Samsung Galaxy Note 10.1
    Replies: 1
    Last Post: 06-15-2014, 12:51 AM
  4. ok google on galaxy s5
    By Unregistered in forum Ask a Question
    Replies: 1
    Last Post: 06-14-2014, 02:41 PM
LINK TO POST COPIED TO CLIPBOARD