1. mckain87's Avatar
    When I connect my phone to computer it gives me some Alert that my computer can't recognize my device. It says I need service pack 3 for XP but I do not even have XP I have windows 7. What do I need to do in order for my computer to recognize my phone? Any information will be helpful!
    07-06-2012 01:16 PM
  2. anon(153966)'s Avatar
    ...rather odd. If you connect to a Windows 7 computer, it should simply install the drivers. Failing that, download Kies from Samsung, and then connect the device. See if it works then.

    Also, do you at least have Service Pack 1, on your Windows 7 computer?

    07-06-2012 01:42 PM
  3. beh's Avatar
    Did you upgrade that machine to Win7 from originally having XP. Sometimes I have found that upgrading the OS leaves artifacts behind that can trigger this kind of behavior.

    naviwilliams makes a good point my son for some reason didn't upgrade to Win7 service pack 1 right away and now he is having similar problems.
    07-06-2012 01:53 PM
  4. dlindo21's Avatar
    Had the same issue, downloaded kies directly from the samsung site and problem solved.
    07-08-2012 02:46 AM
  5. jeffreii's Avatar
    I get this too - don't have Kies installed (yet). It pops up on the phone after about a minute of being plugged into the computer. It does not seem to matter though...as the file transfers work fine. It might be just referring to the fact that there is no software on the computer to interface with the phone (Kies).

    Uploaded with ImageShack.us
    07-08-2012 11:11 AM
  6. BadBro134's Avatar
    i Have The Same Problem But My windows is Virtual. it just wmvare fusion on my mac i downloaded kies but i doesnt work!! who can help me?
    10-28-2012 10:21 AM
  7. Targon's Avatar
    The problem is primarily that the device drivers are a bit buggy, and that is being kind. What I do is run Kies, and tell it to diagnose problems, and it will then reinstall the drivers. Now, here is the trick, once you connect your phone, and Windows installs the drivers(nice and fresh as if you never tried it before), it WILL work. The problem is that once you unplug your phone, on SOME systems, the problem comes right back, and requires using Kies to diagnose connection problems.

    Now, I have tested this on a couple of systems, one is a laptop with a NVIDIA chipset and that one ALWAYS has the problem. My other machine has an AMD chipset on the motherboard, and it does NOT have the problem. This implies that there is something about the USB controller that isn't working well with the Samsung drivers. There is a good reason NVIDIA got out of the chipset business, and that is just one part of it.
    10-28-2012 07:07 PM
  8. smooth4lyfe's Avatar
    Did you try running a Windows Update to make sure all your computer drivers are updated?

    Also I would install Kies (if you havent), I remember on my work computer, my Galaxy S3 was not being recognized until I installed Kies, which I am guessing installed the drivers to recognize the phone
    10-28-2012 07:20 PM
  9. Targon's Avatar
    There is clearly some interaction between the Samsung drivers and USB drivers. If your USB drivers are bad, you get some annoying issues.

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    11-01-2012 01:37 PM
  10. stormy61's Avatar
    I just got my Samsung Galaxy S3 today, and it is not recognized by Kies, it says not compatible with my device, i have re installed drivers several times with no luck, any ideas thanks. I also have a hardware id missing error since upgrading to Jellybean this evening.
    12-29-2012 07:44 PM
  11. excelthoughts's Avatar
    01-01-2013 06:13 AM