1. sqa4life's Avatar
    READ FIRST: http://forums.androidcentral.com/t-g...urn-stock.html

    PREP works:
    -Download/save the file to your desk top or any location on your pc.
    4.1.1 (Hint: this file will be your replacement file on step number 4 in the instruction you read above)
    Firmware archive | Samsung Updates

    -EXTRACT OR UNZIP THE JB 4.1.1 FILE YOU JUST DOWNLOADED. After unzipped, you should have a file named: "I747UCDLK3_I747ATTDLK3_I747UCDLK3_HOME.tar.md5". You'll use this file in step number 4

    -Download Odin 3.07 if you don't have it installed on your pc. Download link was provided in the "PREPARING YOUR COMPUTER" section...if you read it :-)


    Follow the steps 1-3 from "USING ODIN" instruction here:

    Step 4: browse to the jb4.1.1 file you downloaded/extracted in the prep section, filename should be: "I747UCDLK3_I747ATTDLK3_I747UCDLK3_HOME.tar.md5" select/choose that file

    Keep following the rest of the steps


    I was having trouble updating the firmware. Kies said 100% completed, but the phone never passed the "downloading..." screen. I uninstalled the reinstalled Kies a few times. No luck. I copied the file to the SD card and install it via the recovery mode, no luck.

    The steps above works fine for me and it should work for you too.

    Good luck.

    PS: Let me know if you need step-by-step instruction.
    12-04-2012 01:53 AM
  2. scottus2hottus's Avatar
    does this work for non rooted devices I am having the same problem where kies will recognize my device start the download but won't go further than the download portion?
    12-04-2012 08:48 PM
  3. Brandon S#AC's Avatar
    man........ thank you!
    12-08-2012 12:47 AM
  4. TeritaM's Avatar
    I can't get my device to connect to Kies for mac or windows.
    When I try to go into download mode (volume down+home+power), the phone just reboots.
    Anyone else having these problems?
    12-08-2012 08:38 AM
  5. RobbyRob's Avatar
    You're holding it too long. When you press vol dwn+home+power when you see the screen turn on let go of the power button while continuing to hold vol dwn+home. That should do the trick.
    12-08-2012 09:05 AM
  6. insanesteve's Avatar
    Downloading the file and odin now since Kies SUCKS! I hope this works

    12-08-2012 12:46 PM
  7. gohangel's Avatar
    Downloading the file and odin now since Kies SUCKS! I hope this works

    Hey if it works can tou let me know? My only problem with samsung is the kies smh

    Sent from my SAMSUNG-SGH-I747 using Android Central Forums
    12-08-2012 03:06 PM
  8. k.jennings1's Avatar
    Is this a stock JB or rooted? Sorry if the question has been asked before... noob
    12-10-2012 10:55 AM
  9. k.jennings1's Avatar
    just finished this update...way easier than Kies. Worked great
    12-10-2012 11:00 AM
  10. bear_lx's Avatar
    kies worked fine for me... was updated in less the 15 min.
    i posted a thread with step by step instructions, and one thing to note was making sure you had at least 50% battery life.
    been on JB every since and loving it!
    12-10-2012 12:13 PM
  11. Ghostnyc's Avatar
    Had a few minor issues upgrading to JB on non-rooted S3. Short list of things to be sure you got before attempting update from Windows PC

    - Be sure to update KIES, there is an update available
    - Disable Microsoft Security Essentials
    - Be sure device battery is charged up above 75%
    - Disable lock screen on device
    - If possible use wired connection not WiFi

    GS3 is my first android device, just got it 2 weeks ago. Not the smoothest update, but like I said the issues were minor albeit annoying.
    12-10-2012 12:24 PM
  12. krayzie260's Avatar
    I can't seem to get the firmware to download from the provided link. Is there a certain way it has to be done? Sorry, Im a beginner with Android.
    12-10-2012 03:14 PM
  13. pre4lifeforce's Avatar
    Kies is a nightmare. I spent half of the day trying to get that stupid program to work. This is a much easier work-around and had my phone running the latest firmware in under an hour. I really wish I had found this tutorial before I re-installed kies 3 times to no avail.
    12-11-2012 03:52 AM
  14. Frankieitalian69's Avatar
    My problem was my firewall and virus protections kept it from completing...I had same issue with you until I disabled it.
    01-15-2013 04:07 PM

Similar Threads

  1. Replies: 11
    Last Post: 11-13-2012, 01:29 PM
  2. Cool way to see if you can live without LTE
    By Mac58 in forum Google Nexus 4
    Replies: 14
    Last Post: 11-03-2012, 09:52 PM
  3. (Tip) If you can't get Google Voice to work..
    By gk1984 in forum LG Optimus S
    Replies: 0
    Last Post: 04-06-2011, 01:15 AM
  4. If you can get swype get it, its amazing!
    By owensch1 in forum Android Apps
    Replies: 27
    Last Post: 05-07-2010, 10:16 AM
  5. Try ShapeWriter if you can't get Swype
    By Zooks64 in forum Android Apps
    Replies: 1
    Last Post: 05-05-2010, 07:27 PM