Sign up now for Disney+
  1. crazysaguaro's Avatar
    Hello,

    Can anyone tell me why my Voice Input setting is grayed out? This is the same way on both my Samsung Keyboard settings (pictured; in screenshot) and in my Swiftkey 3rd party keyboard settings. I used to be able to dictate texts with both keyboards and an update probably happened somewhere along the line and now the voice settings in each app are grayed out. Other voice functions work on the phone, including the S Voice app and the camera voice commands (say "cheese" or "shoot" to take a photo).

    Google is the TTS engine I have selected in the LANGUAGE AND INPUT > SPEECH > TEXT-TO-SPEECH OUTPUT area if that setting matters. The phone talks to me just fine - I just can't talk to it.

    Please help - I'm very frustrated! I'm running Android 4.1.1 on my Samsung Galaxy S3 (AT&T).

    Thanks,
    Gina
    Attached Thumbnails Voice Input disabled (grayed out) in keyboard settings-screenshot_2013-06-18-11-41-18.png  
    06-18-2013 02:50 PM
  2. GTWalling's Avatar
    Do you have Google voice typing selected. Settings>Language and input.
    06-19-2013 06:47 PM
  3. crazysaguaro's Avatar
    As I said in my original post, I have this option:
    Google is the TTS engine I have selected in the LANGUAGE AND INPUT > SPEECH > TEXT-TO-SPEECH OUTPUT

    Is that what you're referring to? I don't see an option titled "GOOGLE VOICE TYPING".

    Thanks
    Gina
    06-19-2013 07:07 PM
  4. GTWalling's Avatar
    It may be different on my T-Mobile S3.
    Attached Thumbnails Voice Input disabled (grayed out) in keyboard settings-screenshot_2013-06-20-19-48-27.png  
    06-20-2013 09:01 PM
  5. crazysaguaro's Avatar
    Oh yes, it is - I do not have that direct option.
    06-20-2013 09:13 PM
  6. estubbs33's Avatar
    The Google Voice Search is what's grayed out on my Evo 4g LTE. But it didn't use to be. And now when I try voice texting, it says it can't open the microphone.
    I don't understand how that could happen all by itself? How do I fix this?
    07-05-2013 01:58 AM
  7. studmule's Avatar
    The Google Voice Search is what's grayed out on my Evo 4g LTE. But it didn't use to be. And now when I try voice texting, it says it can't open the microphone.
    I don't understand how that could happen all by itself? How do I fix this?
    See if there is an update for google search on the play store. That fixed it for me.
    07-08-2013 09:40 AM
  8. rootmeup's Avatar
    I had had the same problem. You need to install google voice search.
    imstillhere0126 likes this.
    09-19-2013 01:36 AM
  9. Isma El's Avatar
    got same issue, i fixed pretty simple!!!!

    Multi-Window, Voice Command for Camera and lock screen message (i.e Lock Screen Widget) works. However, you need to change the Home Screen Mode from Easy to Standard. These does not work on Easy Mode.
    GSDer likes this.
    12-03-2013 10:28 PM
  10. Cristian Ilie's Avatar
    long press the "abc" key (on my LG is in left, bottom corner).....just uncheck voice key. Tadaaaaaa!!!!
    12-10-2013 02:02 PM
  11. Jason Wojtyna's Avatar
    Thank you very much - I had the same problem (different phone), and it was driving me nuts! MUCH appreciated!

    Jason
    09-12-2014 11:42 AM
  12. warriorfox's Avatar
    How did you solve ... If you did? (Holding down the abc button did not work for me on my LG D415.)
    01-10-2015 09:21 PM
  13. donramm's Avatar
    Warriorfox, this is a case of the blind leading the blind (I have had this Android phone for a week) but I'll give it a shot anyway.

    My phone has very little memory so I have been uninstalling and disabling apps that I don't need. I apparently disabled "Google Search" and then disabled my ability to dictate texts, emails, etc.

    Enabled "Google Search" made "Google voice typing" reappear under "KEYBOARD & INPUT METHODS" under "Language & input" under "Settings".

    But when I bring up the keyboard I don't see the little microphone to the left of the space bar like I used to. Instead I see a gear symbol...until I looked very closely at the key and saw a tiny microphone in the upper left corner of that key. Pressing and holding the key (the "long press") showed three different options for the key: microphone, the gear (whatever that is for), and a cut/paste symbol. I chose the microphone and now whenever I bring up the keyboard I see the microphone on the key next to the space bar.
    01-13-2015 03:59 PM
  14. Roger Paparazzo's Avatar
    THANKS SO VERRRRYYYY Much!!! The manual on subjects like this are something to be desired
    01-24-2015 03:40 AM
  15. jl1959's Avatar
    I don't know if this will help. But I had the same problem on my LG l90 and I downloaded perfect keyboard and it works great. Though it asks for some permissions.I hope that helps if you haven't already rectified the problem.
    01-27-2015 05:15 PM
  16. Stephen Roberts 407's Avatar
    donramm
    Thank you. Thank you. The settings icon on the keyboard was 'hiding' the microphone icon exactly as you described. My LG phone is now completely set up (dropped the old one in water, oops). The blind leading the blind, in this case, was true enough for me. lol. The icons on the key itself were so small, I would never have deciphered them without your post. Have a wonderfully successful day
    04-03-2015 10:41 AM
  17. Spamless Flipster's Avatar
    Thank you so much for your insight - another undocumented "feature"

    the long press to get the mic worked...


    peace
    flipster

    04-08-2015 12:03 PM
  18. CindyStooks's Avatar
    thanks so much for the information! That works on my LGD415 phone..by hard pressing that button on the left side of the space bar and gives me 3 choices and one is the microphone and just clicking that and wala! There is the microphone..so much easier! thanks soooooooooooo much!
    04-27-2015 02:10 PM
  19. smartsoutherngrl's Avatar
    This feature is for all phones. Anytime you have issues with features such as this, always back track to the settings in your phone and look for (languge and input), you have to choose Google voice typing as a default. Think of it this way, even when you use your voice for text, it's an input feature. Just as if your were typing , or typing on a certain type of keyboard.
    06-18-2015 02:33 PM
  20. hello hello's Avatar
    Try eneble Google search..i disabled Google search so voice typing option gone..but when i enable google search it automatically comes..so try enable google search from apps..disable apps..Google search... Enable it
    09-22-2015 01:20 PM
  21. Troy I's Avatar
    Try eneble Google search..i disabled Google search so voice typing option gone..but when i enable google search it automatically comes..so try enable google search from apps..disable apps..Google search... Enable it
    Awesome that worked, thanks!
    10-28-2015 09:20 PM
  22. imstillhere0126's Avatar
    I had had the same problem. You need to install google voice search.
    Thanks for your simple, helpful answer. I've been having the same problem for months and just tried this- worked like a charm!
    03-11-2016 11:58 PM

Similar Threads

  1. Voice Input settings - Missing in KBD setup
    By foamfollower in forum Misc. Android Phones
    Replies: 0
    Last Post: 02-04-2011, 07:19 AM
  2. HTC IME Keyboard with voice input
    By DoubleA319 in forum HTC Hero
    Replies: 9
    Last Post: 11-21-2010, 07:34 PM
  3. Replies: 8
    Last Post: 10-29-2010, 11:06 AM
  4. Data Sync Settings Grayed Out / Gmail
    By XavierX in forum Motorola Droid X
    Replies: 2
    Last Post: 10-04-2010, 01:55 PM
  5. Slide for voice input working poorly in Froyo
    By tonytoon in forum Google / HTC Nexus One
    Replies: 0
    Last Post: 05-23-2010, 04:59 PM
LINK TO POST COPIED TO CLIPBOARD