1. mjv0003's Avatar
    My wife and I both have Samsung Galaxy S3's on AT&T. In the last 3 weeks or so, my wife noticed her mobile data usage was really high and increasing every day. We noticed that her phone was connected to the mobile network and using it instead of using the Wifi in the house or office. The Wifi is connected in both instances but so is the 4G. When we look at the System Status, it shows the "mobile network status" is Connected and the IP address looks to be an external number. If it was using the Wifi, it should be a 192.168.x.x number, but it's not. I have tried comparing settings on both of our phones and can't find any differences. I'm not sure how to fix it and get it to use the Wifi when it's enabled instead of the mobile network continuing to be connected. Our phones are not rooted and are using the latest version of Android made available by AT&T.

    Thanks guys!

    Mike
    10-26-2013 06:41 PM
  2. grenefroggie's Avatar
    In those instances have you tried forgetting the wireless networks or disabling and enabling the wireless on the phone? Have you tried a reboot?
    10-26-2013 09:46 PM
  3. mjv0003's Avatar
    Yes. We have rebooted multiple times. I just tried to forget the network and reconnect to it, but it didn't help. We get the same effect connecting it to different wireless networks. So this problem happens regardless of what network we connect to.
    10-27-2013 09:49 PM
  4. Chris8414's Avatar
    mines was doing the same thing what I did was pull the battery out and let it sit for 5 minutes, restarted it, then did a factory reset. Havent had a problem since. Make sure to back up to samsung kies before you reset. Otherwise all of your pictures and everything else will be gone for good. Hope this helps!
    10-28-2013 03:35 PM
  5. RVdave's Avatar
    Mike - We began having this exact problem with ONE of our two ATT S3 phones after updating to version 4.3. Like you, I keep my data plan enabled so that when I leave my WiFi area it automatically switches to my 4g data plan. When I re-enter a WiFi area it automatically switches back to WiFi. My wife's s3 was also updated to version 4.3 and before the update worked the same as mine, but since the update it will always use the data plan regardless of strong WiFi availability. The ONLY way her phone will connect to WiFi is if the data plan is disabled. If she's connected to a strong WiFi signal and we enable her data plan the phone immediately switches to data, even though WiFi is still enabled. Two identical s3's running the same build of 4.3 with identical settings. One defaults to WiFi and the other defaults to Data. Yep, there is definitely a bug! Good luck - Dave
    12-05-2013 02:23 PM
  6. KreepyKen's Avatar
    Try this:

    1. Open Settings and tap WiFi. A list of wifi networks appears.
    2. Tap the menu button on the phone (to the left of the Home button). Select Advanced from the resulting menu.
    3. Scroll down until you see the Auto Switch Networks option. Make sure it's unchecked.

    See if that works.
    revansCAAD8 likes this.
    12-07-2013 10:51 AM
  7. RVdave's Avatar
    Thanks for your response. Unfortunately, the "Auto network switch" box is unchecked and the ONLY way it will connect to WiFi is if the "Mobile data" box on the"Data usage" page is unchecked. Once this box is unchecked the phone immediately connects to WiFi. If the box is checked the phone immediately drops the strong WiFi connection and connects to Mobile data. It always defaults to Mobile data unless mobile data is disabled. This appears to be the same problem that Mike is having. - Dave
    12-07-2013 11:54 AM
  8. Yabazooee's Avatar
    The only thing that works is to backup your phone and then do a factory reset.. I've had to do this to my wife's phone 3 times over the past 4 months.
    12-09-2013 07:22 PM
  9. RVdave's Avatar
    Hopefully, this bug will be fixed soon. Until then I've found a pretty good workaround that manually solves the problem. If you go to the Google Play Store and search for the developer CNEVINC you'll find two apps that will instantly toggle between WiFi and Data, or WiFi and Data and No network. They're free, don't have ads, or require a lot of permissions. I installed the one that just toggles WiFi and Data on my wife's Home screen and she only has to touch the button to get WiFi or switch back to Data. Automatic would be better, but until this is fixed this is an easy workaround. Good luck - Dave
    12-10-2013 01:17 PM
  10. Erica Jewell's Avatar
    Try this:

    1. Open Settings and tap WiFi. A list of wifi networks appears.
    2. Tap the menu button on the phone (to the left of the Home button). Select Advanced from the resulting menu.
    3. Scroll down until you see the Auto Switch Networks option. Make sure it's unchecked.

    See if that works.
    Brillant! Thank you!
    01-29-2014 04:11 PM
  11. crazzy frog's Avatar
    My wife and I both have Samsung Galaxy S3's on AT&T. In the last 3 weeks or so, my wife noticed her mobile data usage was really high and increasing every day. We noticed that her phone was connected to the mobile network and using it instead of using the Wifi in the house or office. The Wifi is connected in both instances but so is the 4G. When we look at the System Status, it shows the "mobile network status" is Connected and the IP address looks to be an external number. If it was using the Wifi, it should be a 192.168.x.x number, but it's not. I have tried comparing settings on both of our phones and can't find any differences. I'm not sure how to fix it and get it to use the Wifi when it's enabled instead of the mobile network continuing to be connected. Our phones are not rooted and are using the latest version of Android made available by AT&T.

    Thanks guys!

    Mike
    My MotoG with lollipop is having the same problem...dont know whether the problem is with the phone or with google play services.
    03-17-2015 12:15 PM
  12. Alex Khan1's Avatar
    Try to give it a full refresh or reset hope it helps
    03-25-2015 07:57 AM
  13. Madhurima84's Avatar
    I am facing the same issue but I am using Moto G with AT&T mobile network. I have followed the steps - wifi --> settings menu--> advanced > but there isn't any Auto Switch Networks option. So what do I do now?
    01-17-2016 01:04 AM

Similar Threads

  1. HTC weather app/widget with sound on my samsung galaxy s4
    By Matt Mullen in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 02-13-2017, 05:08 PM
  2. virgin mobile htc one v. need,to make this gsm
    By Marcus Gopaul in forum HTC One M7
    Replies: 6
    Last Post: 01-15-2014, 02:04 PM
  3. Problems with reception using Incipio case
    By va_connoisseur in forum Samsung Galaxy Note 3
    Replies: 7
    Last Post: 10-28-2013, 10:26 AM
  4. Take a look at my S3 I9300 SD Card...what is going on?????
    By kabuchi in forum Samsung Galaxy SIII I9300
    Replies: 2
    Last Post: 10-27-2013, 05:07 PM
  5. Samsung s3 keeps dicharging after wiping cache
    By Anuskha Mohan in forum Samsung Galaxy S3 Mini
    Replies: 4
    Last Post: 10-27-2013, 08:03 AM
LINK TO POST COPIED TO CLIPBOARD