1. Ruslan61's Avatar
    The other day my phone power button just stopped having any resistance what so ever. There is no button now, it is just like it is there, you cannot push it. So i say a video and took the power button out and noticed the little white button inside did not push in, is it supposed to?. If anyone can help me fix this if it is easy then please help!. Thank you

    Also, just so everyone knows. if i put the battery in, it starts without me doing anything, Then it hard shuts down. It is constantly powered
    03-13-2014 08:07 PM
  2. Kevin OQuinn's Avatar
    Sounds like that little white button is staying pushed down instead of popping back out. I'm not sure how to fix that....
    03-13-2014 11:54 PM
  3. GSDer's Avatar
    http://mobiletechvideos.mybigcommerc...button-repair/ is one source for replacing the actual Power switch (the white button that you referred to).

    You could certainly do it yourself if you're familiar with soldering; the part is available on eBay.

    It may even be that the switch just needs to be cleaned - with the battery out, you could spray electronic contact cleaner on the switch and try exercising it to see if it'll unstick. Just be careful to have it positioned so that it drips out directly - you don't want it to pool in the display. The best bet would be to follow one of those iFixit videos and take it apart so that the unnecessary components are disconnected.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    03-16-2014 02:43 PM
  4. bluecollarbob's Avatar
    I fixed my sticky button with a tiny dab of WD-40 lubricant. Follow the video on how to remove the logic board, use a screwdriver tip to dab the lube. I had to operate the button about 50-100 times before the lube worked its way inside the switch. I don't know how long this repair will last, but a used board is only $75 on ebay. I don't think anyone should try to soldier onto a cell phone logic board. You would have to be VERY talented at soldiering and have a micro soldier station.
    10-29-2014 10:59 AM
  5. turbo2ltr's Avatar
    So I just had this happen to me as well. No warning. I found it odd the button still clicked and moved fine, but it was clearly electrically "stuck" on.
    I took it apart and didn't see anything obvious. In the end I removed the switch so I could use the phone again. I'll just have to set my screen timeout really short. lol.

    But I did a postmortem on the switch. I carefully took the switch apart. Turns out there are two tiny slightly curved contacts that form the "click" part, that short out to the "back" of the button when pressed. These contacts appear to be silver coated spring steel. What happened is a microscopic (yes I was using a 40x stereo microscope) flake of silver came off the contacts and bridged between the contact and the back of the switch. Seems like it is essentially a manufacturing flaw in the switch.

    Stuck/broken power button on Galaxy s3?-s3-switch.jpg
    GSDer likes this.
    11-07-2014 01:39 AM
  6. Dane Argan's Avatar
    What worked for me was a splash of lacquer thinner on the power button and giving it a bunch of flicks, followed by turning it on and off numerous times. It freed up the the button and has not gotten stuck since. Did not have to take the phone apart. Seemed weird pouring thinner into the phone but I've used it on a few electronics and works to clean up contacts and free up buttons.
    08-08-2015 01:59 PM
  7. iemalnoori2012's Avatar
    I would try this, this worked for me

    08-21-2016 11:03 AM

Similar Threads

  1. Floppy Bird - My creation on Android
    By juanmontes in forum Android Games
    Replies: 1
    Last Post: 04-08-2015, 08:32 PM
  2. music player auto starts on my Gal S4 - please help.
    By coastalcarlson in forum Android 4.4 KitKat
    Replies: 3
    Last Post: 03-26-2014, 11:35 AM
  3. Create a wifi hotspot using Moto X on AT&T?
    By teffects in forum Moto X (2013)
    Replies: 4
    Last Post: 03-13-2014, 06:34 PM
  4. Nexus 4 won't turn on or charge
    By JakeSonYu in forum Google Nexus 4
    Replies: 2
    Last Post: 03-13-2014, 05:45 PM
  5. view GPS from S4 mini to Galaxy Tab 2.7
    By B45 in forum Samsung Galaxy S4 Mini
    Replies: 0
    Last Post: 03-13-2014, 04:20 PM