1. ajdrivesayota's Avatar
    Hopefully I posted in the correct area, If not admin please move to correct area. So I just bought an S3 used in good condition, everything worked except the cameras, water tab RED. I got it home pulled it apart, cleaned the motherboard with isophoric alcohol to clean any corrosion from the water damage (no damage I can see, runs flawlessly), reinstalled original front and rear cameras no luck camera still failed. Then I replaced both front and rear camera out of another i747 I had both cameras worked in that unit but no luck in the unit Im trying to repair. Although later in snapchat I realized the front camera did work. I also tried to update the camera firmware through dail pad on stock 4.1.2 rom but it always crashes before I get to the menu to check firmware and update if available. I tried deleting cache and data on both gallery and camera app, removed all other applications relating to camera or torch (flashlight) also turned off google location, have tried other roms of course after clearing dalvik, cache partition and factory reset. I also have tried other 3rd party camera apps, Ive also tried removing sd card and sim card and battery pull. I'm stumped honestly never had such an issue before, any help or thoughts would be greatly appreciated. Also not under warranty anymore. Also on a side note huge fan of the site been coming here for years.
    10-31-2014 09:03 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! The key here is that there has been internal water exposure at some point. My guess is that it damaged some internal circuits that were crucial for the proper functioning of the cameras. Water damage isn't necessarily visible to the naked eye, so just because you don't see any corrosion doesn't mean that there's no damage. My guess is that you won't be able to fix it unless you do something drastic, like replace the whole motherboard. Sorry!
    10-31-2014 01:22 PM
  3. GSDer's Avatar
    You may need to reload the camera firmware - I had a problem like this when Verizon released a version of 4.1.2 which updated the camera firmware but crashed most everything else: when I rolled back to the earlier firmware the cameras no longer worked. I had to wait until Verizon released an updated 4.1.2 firmware and installed that before the cameras started working.
    11-06-2014 02:58 AM

Similar Threads

  1. Replies: 2
    Last Post: 11-03-2014, 11:59 PM
  2. Replies: 2
    Last Post: 10-31-2014, 04:48 PM
  3. Can I transfer my Sim card from my OG Moto X to my OPO?
    By megatomic in forum Android 4.4 KitKat
    Replies: 4
    Last Post: 10-31-2014, 02:58 PM
  4. Why won't my Google Nexus7 charge?
    By Isabelle WATKINS in forum General Help and How To
    Replies: 2
    Last Post: 10-31-2014, 02:36 PM
  5. Verizon Motorola Droid Turbo Help with battery/sync
    By datagrrl in forum Motorola Droid Turbo
    Replies: 3
    Last Post: 10-31-2014, 10:11 AM
LINK TO POST COPIED TO CLIPBOARD