1. OtakuN3rd's Avatar
    Hello, new member here with an extremely aggravating problem.

    My AT&T Galaxy S3 is stuck in Safe mode. It is an unlocked phone and I have been using it with Straight Talk since I got it back in February. I upgraded to KitKat 4.4.2 when AT&T released the update. Due to an unrelated issue in the beginning of October I reset it to factory settings and after doing that it kept telling me it was down loading an update in the top status bar, but it apparently never actually downloaded anything, I left it alone since it never seemed to interfere with the general operation of the phone. Around that time I discovered TowelRoot and used it to allow more features in Comodo Mobile Security (I kept the AT&T Stock KitKat ROM).

    Fast Foward to this past week my phone was running really sluggish so I restarted it and it restarted in safe mode. I have since tried everything that I could think to do in that I have restarted the phone, pulled the battery for a couple days and tried it, as well as restoring it to factory settings to no avail. I saw another thread online where someone mentioned the same problem and said that they noticed their volume down key quit working but somehow came to the conclusion that was unrelated to the ribbon cable. Mine seems to be having the exact same problem. I am not sure if I should attempt to replace the ribbon cable, or perhaps the motherboard, or perhaps there is some other problem I am experiencing that I am not aware of causing the phone to be stuck in Safe Mode.

    Can someone advise on what I should do?

    Thanks in advance!!
    11-10-2014 12:18 PM
  2. BlackDragon22's Avatar
    Hello, new member here with an extremely aggravating problem.

    My AT&T Galaxy S3 is stuck in Safe mode. It is an unlocked phone and I have been using it with Straight Talk since I got it back in February. I upgraded to KitKat 4.4.2 when AT&T released the update. Due to an unrelated issue in the beginning of October I reset it to factory settings and after doing that it kept telling me it was down loading an update in the top status bar, but it apparently never actually downloaded anything, I left it alone since it never seemed to interfere with the general operation of the phone. Around that time I discovered TowelRoot and used it to allow more features in Comodo Mobile Security (I kept the AT&T Stock KitKat ROM).

    Fast Foward to this past week my phone was running really sluggish so I restarted it and it restarted in safe mode. I have since tried everything that I could think to do in that I have restarted the phone, pulled the battery for a couple days and tried it, as well as restoring it to factory settings to no avail. I saw another thread online where someone mentioned the same problem and said that they noticed their volume down key quit working but somehow came to the conclusion that was unrelated to the ribbon cable. Mine seems to be having the exact same problem. I am not sure if I should attempt to replace the ribbon cable, or perhaps the motherboard, or perhaps there is some other problem I am experiencing that I am not aware of causing the phone to be stuck in Safe Mode.

    Can someone advise on what I should do?

    Thanks in advance!!
    Did you download any app prior to the sluggish behavior and then the safe mode reboot? Sometimes an app can cause the phone to enter safe mode. If so, uninstall the app and then reboot. I've had this happen many times on my old S3 and it was usually caused by an app.


    Posted via the Android Central App
    12-25-2014 09:43 PM

Similar Threads

  1. How do I unhide albums in my gallery on my HTC One?
    By Adam Picard in forum Ask a Question
    Replies: 3
    Last Post: 11-19-2015, 05:45 AM
  2. Hello All, New Member To Team Galaxy
    By TheWood100 in forum New to the Forums? Introduce Yourself Here!
    Replies: 7
    Last Post: 11-14-2014, 10:43 PM
  3. How can I reinstall my stuck tablet?
    By Luis Humberto2 in forum Ask a Question
    Replies: 1
    Last Post: 11-10-2014, 04:41 PM
  4. One week in and loving my Nexus 9 more and more!
    By Vance14 in forum Google Nexus 9
    Replies: 3
    Last Post: 11-10-2014, 03:40 PM
  5. Why am I not able to type in the search bar while using internet?
    By stephbush in forum General Help and How To
    Replies: 1
    Last Post: 11-10-2014, 12:03 PM
LINK TO POST COPIED TO CLIPBOARD