1. TheCougfan97's Avatar
    So I just bought this HTC one yesterday at the AT&T store. When I attempt to text certain people (not all) the phone auto corrects to whatever the second option is, typically in a foreign language. It also underlines all the english words I type. The language settings are all set to English as far as I can tell, does anyone have any ideas? I know when I first opened chrome it took me to google.com/ (a foreign character based language I do not recognize) and most of the text corrects appear to be similar to what little spanish I know.
    06-20-2013 09:53 PM
  2. Scott Kenyon's Avatar
    Which keyboard are you using?

    If stock, go to settings/apps scroll over to all and find HTC Sense Input. Go down to clear data and tap it, restart the phone. See if it's fixed and report back, I'll subscribe to this topic.
    06-20-2013 11:17 PM
  3. Shaun Blackman's Avatar
    I had a similar problem with the Sense keyboard. Was correcting words that were spelled correctly. I downloaded the Google keyboard and it is 10 times better than the HTC keyboard. Try it out, I guarantee you will like it better.
    06-21-2013 03:51 AM
  4. andresgalvan98's Avatar
    I had a similar problem with the Sense keyboard. Was correcting words that were spelled correctly. I downloaded the Google keyboard and it is 10 times better than the HTC keyboard. Try it out, I guarantee you will like it better.
    In my opinion, the Sense keyboard is awesome. Autocorrect on Sense is the best on all the devices I've used extensively (iPhone 4/5, GS3, GS4, Nexus 4, ) recently. It's something he's doing wrong with the keyboard settings, because 98% of the time, it gets all my words correct in English, even if they're not even close.

    Posted via Android Central App
    06-21-2013 12:38 PM
  5. Jexex's Avatar
    I've been driven batty by the Sense autocorrect (had to manually add "autocorrect" to get it to recognize and therefore 'allow' the word to be typed out. Otherwise it gets corrected to the third word in a list of words it's trying to guess is the correct one. In this case that word is "shtick" (???))

    Abbrivations are particularly a pain in the backside. "lol" gets autocorrected to "geyser". And this happens as you type.

    So you can type in "lol" and the sequence will go like this:
    l..o..geyser..backspace (trying to manually correct)..geyser-o..l-geyser...backspace...geyser-o..m..a..o-Kmart..backspace..Kmart-o..p (purposefully misspelled so as not to autocorrect to geyser or Kmart). So lol gets forced to lmao then lmap just to get past the word (for those not following along).


    Clearing the Sense keyboard cache only makes things worse. Instead of getting every, say, tenth word autocorrected, you get every other word auto corrected. And the guessed words make even less sense!
    06-24-2013 04:56 AM
  6. Jexex's Avatar
    I had a similar problem with the Sense keyboard. Was correcting words that were spelled correctly. I downloaded the Google keyboard and it is 10 times better than the HTC keyboard. Try it out, I guarantee you will like it better.
    Thanks for that.
    Shaun Blackman likes this.
    06-24-2013 05:01 AM
  7. Shaun Blackman's Avatar
    I like the keyboard itself, its just the auto correct that sucks. For example, I would type the letter "I" and it would change it to "U". That makes no sense but it did this type of thing all the time. Again, the Google keyboard is about equal with the Sense keyboard but the auto correct function is far superior. Also has more customization options.... :-)
    06-25-2013 05:04 AM
  8. GiddyNinja's Avatar
    This ONLY occurs when you accidentally change the language. There is a quick button for EN (english), SP (spanish), and FR (french). I noticed the same thing and then realized I was typing english while using a diff language keyboard. Just tap the button to change back, then tap out of the keyboard and tap back in. It will no longer auto correct everything.
    07-15-2013 06:10 PM
  9. The Corrector's Avatar
    You need to follow the following on your HTC: Settings, Input and Language, HTC Sense, ,Select Language. There select English. Be careful to ensure only one language box is ticked as it can allow more to be ticked. Once done you are home and dry.
    10-20-2014 12:01 PM
  10. TWC42's Avatar
    You need to follow the following on your HTC: Settings, Input and Language, HTC Sense, ,Select Language. There select English. Be careful to ensure only one language box is ticked as it can allow more to be ticked. Once done you are home and dry.
    That's exactly the problem I had; somehow a second language got selected and I couldn't swype anything correctly. Went to SwiftKey; it was nice but I had to be more precise in swyping or I'd get the wrong words. When I realized it was the second language that was messing up the native keyboard, went back, made sure only English was selected, and started using it again. So much nicer. I can be sloppy when swyping and it still seems to get the correct word most of the time.
    10-23-2014 07:11 AM
  11. Zi Newton's Avatar
    I type the right words and they are not uncommon words. For example I typed "tech support". HTC kept changing them to "technology right support" numerous times. I typed an address it changed the street name from Waban to wanamaker. I typed "10 times" It changed to "10 Rene's". I thought it should stop doing that after I repeatedly changing them back. But no. It has a iron will power. It it extremely infuriating.
    04-10-2015 11:06 AM
  12. Zi Newton's Avatar
    I did not select a second language. HTC Sense just thinks it is so smart that what I type must be changed to his liking. It socks. It makes my message meaningless. The worst part is no matter how many times I change it back HTC will degate it.
    04-10-2015 12:36 PM
  13. Caroline Maxwell's Avatar
    Hi my new htc has also been so frustrating to text on after years of reliable usage of a much simpler Samsung.

    Only English is selected but it has been doing its own thing regardless of what I type. It has slowed up texting and made it a task having to constantly revise and change. But some mistakes slip by - embarrassing as my work includes proofreading!

    Hoping the prob is solved now though, I've tried: Settings - turn off spellchecker - HTC Sense Input keyboard options - turn off all except Arrow keys ( the Personal Dictionary is sooo slow and cumbersome) - Advanced - turn off all except Word prediction.

    Fingers crossed this helps, and hope it helps others too.
    05-11-2015 03:24 PM
  14. Caroline Maxwell's Avatar
    There are two places where language is selected. First is Language & keyboard ( hit English), second is HTC Sense Input - Keyboard selection (top of the list) - only tick English. Hope that helps.
    05-11-2015 03:40 PM
  15. Caroline Maxwell's Avatar
    I did not select a second language. HTC Sense just thinks it is so smart that what I type must be changed to his liking. It socks. It makes my message meaningless. The worst part is no matter how many times I change it back HTC will degate it.
    There are two places where language is selected. First is Language & keyboard ( hit English), second is HTC Sense Input - Keyboard selection (top of the list) - only tick English. Hope that helps.
    05-11-2015 03:50 PM
  16. Jeff H2's Avatar
    QUOTE:
    So I just bought this HTC one yesterday at the AT&T store. When I attempt to text certain people (not all) the phone auto corrects to whatever the second option is, typically in a foreign language. It also underlines all the english words I type. The language settings are all set to English as far as I can tell, does anyone have any ideas? I know when I first opened chrome it took me to google.com/ (a foreign character based language I do not recognize) and most of the text corrects appear to be similar to what little spanish I know.
    UnQuote ---------------------------------------

    Thanks to some of the comments here.
    I fought similar autocorrection PIAs too. I was trying to include an email address combination letters and numbers. Midway thru the input, the autocorrection totally changed my email addy input to a word it knew. After reviewing some reply comments, I came up with a successful answer on my HTC One M9.

    Settings
    Language & keyboard
    Spellchecker change from ON to Off


    Probably this second act would be the culprit:
    Settings
    Language & keyboard
    Advanced
    Word Prediction Uncheck bo
    x
    09-13-2015 12:44 PM

Similar Threads

  1. Text Messaging Auto-Signature/Time Stamp
    By philly in forum General Help and How To
    Replies: 3
    Last Post: 10-31-2011, 11:43 AM
  2. Auto-delete text messages (without confirmation)
    By kingzee in forum Motorola Droid X
    Replies: 2
    Last Post: 01-26-2011, 05:53 AM
  3. Auto Correct (Auto text) in HandCent
    By pastorich1 in forum Sprint Epic 4G
    Replies: 6
    Last Post: 09-10-2010, 01:10 PM
  4. Replies: 1
    Last Post: 09-01-2010, 08:53 PM
  5. How to skip the Predictive Text auto-correct?
    By bsmith1051 in forum HTC Hero
    Replies: 2
    Last Post: 05-24-2010, 11:21 AM
LINK TO POST COPIED TO CLIPBOARD