1. hippohelper's Avatar
    Hi there,
    I've just entered the world of Android with a new tab and an unlocked LG P506 Thrive phone (2.2.1)

    I'm totally out of my depth here and am hoping for some very simply explained info.

    I rooted the P506 (I barely know what that means) in the hope of getting rid of some of the ATT bloatware - as a new phone I only had around 35MB of space left - using GingerBreak v1.20.

    Worked fine, then I found out that Titanium Backup was needed to get rid of these programs so I installed that, got rid of the ATT apps and in doing so, thinking it was just a link to the LG home page, deleted LGhome.apk

    Now of course I can't access any features of my phone - it hangs at the ATT Logo.

    After a hard reset I'm able to link my Google accounts and get to a blackened home screen but can't access any functions other than the notification bar.

    I found the LGhome.apk file, emailed it to myself via Gmail which I can access only when a new email arrives, so at least I can access it on my phone. The problem I now have, is that when I click on that file to install it, I get the 'Install Blocked...' message. It sends me to the Application Settings screen which ordinarily would allow me to change the 'Unknown Sources' setting, but I'm not seeing that...all I see on that menu is 'Manage Applications', 'Running Services' and 'Development'. EDIT: I since found out this is an ATT thing - so how can I restore this access to third party apps?

    I feel like I'm close to fixing it but don't know what to do next. Every search I do brings a whole lot of acronyms I don't understand - as I said, I'm way out of my depth.
    Hoping I've made sense and that somebody out there can help.

    01-09-2013 11:28 PM
  2. hippohelper's Avatar
    I found out that I can get the access to Unknown Sources back by dialing a code 3845#*506*, managed to get the dialpad up and got a check mark in Unknown Sources

    Navigated to the installer for LG Home in my email, clicked install, then running...running...looking good..."Application not installed" Grrrr.....Feeling very miserable. am I getting close or going around in circles?
    01-10-2013 06:47 AM
  3. hippohelper's Avatar
    I'm replying to myself to keep track of my steps and in the hope that someone picks up on this soon.

    Latest is, in an attempt to get any kind of launcher happening, emailed myself a copy of ADWLauncher.apk, tried to install launcher...but got 'There is a problem parsing the package' error. ARRGH, one step forward, two steps back

    I can't access the Google Play app on my phone so I can't register my device with Google Play...which would be handy in this case as I could download / install the apk directly.

    I don't really get what I'm reading about ADB and 'pushing' the home file to my phone, but it seems that is my next step. A little help here would be appreciated!

    Please tell me my phone isn't screwed...
    01-10-2013 12:58 PM
  4. LifesGoodPhoenix's Avatar
    it sucks that installing it thru email isnt working. prob something to do with the fact it doesnt have a home launcher. ??
    ADB is going to be your best bet, if you want to keep stock rom, not necessarily the easiest.

    other option is, still need adb functional on pc, use bills recovery tool to flash a custom recovery and flash diff rom from there. you can get back to stock, that is a diff discussion.

    here to help the best i can.
    01-10-2013 06:17 PM
  5. hippohelper's Avatar
    Hey, thanks for you help!

    I've pretty much solved it, not completely but good enough. - phew!

    Basically after lots of trial and error, I emailed myself a bunch of different loaders, and one specifically for 2.1.1 seemed to do the trick.
    From there I could get into the Play store and install a decent loader.

    Haven't worked out how to get the stock loader back yet but right now I'm not too fussed. I'm just happy to have my phone back.

    And I promise, I'll never, never do it again
    01-11-2013 06:43 AM
  6. distraktoro's Avatar
    I'm pretty sure I am having this same issue with my LG myTouch Q. I am very new to the rooting thing and accidently deleted something important (what I believe is lghome.apk) and am having the same issues. In order for my phone not to get stuck at the startup screen, I need to do a factory reset. Once this is done, I get into the phone but everything is missing (apps, launch bar, cannot swipe to difference pages, etc).

    Could you give me a step-by-step process to what you did to get your phone working? Note that I also factory reset my phone, so I have no email/account linked to the phone.

    Your help would be greatly appreciated!

    03-15-2013 08:59 AM
  7. LifesGoodPhoenix's Avatar
    try here
    as your phone is way different than the ones in this forum, but you may want to see if your retailer can reflash or see what LG can do for you.
    03-17-2013 01:33 PM
  8. Paul Ryan's Avatar
    If you need to ADB push an app to your phone then try this tool "Android Sideload Wonder Machine". It's very easy and it includes a function to detect whether or not your computer can see the phone via usb.


    Sent from my ADR6300 using Tapatalk 2
    05-11-2013 05:35 AM
  9. Eugenio Arosteguy's Avatar
    I remove lghome.apk and the system breaks. Then I download another launcher (goLauncher: descargar go launcher ex gratis (android)) and atach to my mail. then my android gmail client detects this file is apk and give the "install" button. Solved for me
    06-15-2013 01:31 PM
  10. srkmagnus's Avatar
    I remove lghome.apk and the system breaks. Then I download another launcher (goLauncher: descargar go launcher ex gratis (android)) and atach to my mail. then my android gmail client detects this file is apk and give the "install" button. Solved for me
    Remember that you won't have access to the stock widgets since those are often tied to the stock launcher. If you don't mind, this is a great solution and you'll be able to find better widget replacements in the Play Store.

    Sent from my SPH-D710 using Tapatalk 2
    06-17-2013 02:21 PM
  11. Jonatan Alonzo's Avatar
    I remove lghome.apk and the system breaks. Then I download another launcher (goLauncher: descargar go launcher ex gratis (android)) and atach to my mail. then my android gmail client detects this file is apk and give the "install" button. Solved for me
    03-22-2014 08:48 AM

Similar Threads

  1. Need to delete AOL email account, please help!
    By anniethepanini in forum Huawei
    Replies: 3
    Last Post: 02-24-2014, 07:41 AM
  2. LG ally bricked :[ please help
    By legitsniper95 in forum LG Ally
    Replies: 1
    Last Post: 04-30-2012, 03:07 AM
  3. Im a noob and broke my phone. Please help.
    By ompapamowmow in forum Thunderbolt Rooting, ROMs, and Hacks
    Replies: 46
    Last Post: 11-21-2011, 08:29 AM
  4. Noob question about rooting-- please help!
    By sardine314 in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 9
    Last Post: 06-04-2010, 08:52 PM
  5. Setting up VPN to connect to home computer? Please help.
    By spierce7 in forum Motorola Droid
    Replies: 5
    Last Post: 01-11-2010, 02:28 AM