1. afends420's Avatar
    when I try to download SnapChat it says my device is incompatible, is there a way to skip this and download it?
    05-18-2013 02:51 AM
  2. charlee08's Avatar
    Snapchat only supports Android 2.3+.

    I'm pretty sure that the latest android version for your device is 2.2.

    Sent from my HTC One
    afends420 likes this.
    05-18-2013 03:10 AM

Similar Threads

  1. Snapchat help!
    By ThisIsVictoriaM in forum Samsung Galaxy S3 Mini
    Replies: 4
    Last Post: 06-11-2013, 04:59 PM
  2. HELP! Need to get G1 Working or Dieter Will Kill Me!
    By Rene Ritchie in forum The Android Central Lounge
    Replies: 157
    Last Post: 06-02-2013, 03:17 PM
  3. My Turn - Help Dieter with the G1
    By Dieter Bohn in forum The Android Central Lounge
    Replies: 14
    Last Post: 04-26-2013, 07:08 AM
  4. Round Robin: Help Jennifer with the G1!
    By Jennifer Chappell#CB in forum The Android Central Lounge
    Replies: 54
    Last Post: 12-14-2009, 08:59 PM
  5. SOS: Please Help: IMport SMS from XML file to G1
    By android007 in forum General Help and How To
    Replies: 0
    Last Post: 02-06-2009, 11:15 AM
LINK TO POST COPIED TO CLIPBOARD