1. millerd79's Avatar
    My friend gave me his old G1. The problem is every time you boot it up the triangle with an exclamation point comes up. I am not holding home + end key to make this happen. When It does come up I have tried home + back, alt + w, and camera + end. I have also tried 20+ battery pulls. The phone just will not respond. Any suggestions?
    12-20-2009 06:20 PM
  2. millerd79's Avatar
    12-21-2009 09:36 AM
  3. millerd79's Avatar
    12-22-2009 04:24 PM
  4. millerd79's Avatar
    going once, twice, .....hello android world.....someone anyone have an answer just anything so I don't think i'm talking to my self? hello?
    12-27-2009 08:35 AM
  5. redman213's Avatar
    Umm take it to T-Mobile see if they can fix it. I think its bricked but idk if it is google how to unbrick. Also you can try a hard reset with the button combos but if its bricked i dont think itll work.
    12-30-2009 05:06 AM
  6. pbrennan42's Avatar
    Doing a bit of hunting for you.

    [Recovery] [13-Dec-2009] RA-dream-v1.5.2 - xda-developers - the RA-dream-v1.5.2 boot recovery software.

    http://forum.xda-developers.com/showthread.php?t=538456 - a ROM for the G1 that installs Android 1.6 Donut pretty close to factory settings but with a few extras.

    I cannot find the current Firmware on the T-Mobile websites so cannot help you there.

    01-04-2010 01:56 PM
  7. starsprout's Avatar
    ROOT IT. Take control of your device
    01-12-2010 06:53 PM
  8. msnoodles's Avatar
    I'm experiencing the same probem with my G1, when I turn it on there is a triangle with a exclamation point. What could be causing this and is there an fix?
    01-17-2010 10:36 AM
  9. land of the trill's Avatar
    Well your finding out why he gave it to you and you can't unbrink the G1 yet. Try alt+L and wipe the device and reboot and if that doesn't work then the ROM might be corrupted and you should grab the 1.6 update from a site and load it on your SD and flash it to see if that resolves the issue.
    01-17-2010 11:36 PM
  10. CarrierUnlock's Avatar
    I would agree with some of the above posts. Sounds like a bad ROM. Just load a new one and that should resolve your issues.
    01-25-2010 01:53 PM
  11. ODamian's Avatar
    Talk to tmobile
    01-30-2010 09:03 PM
  12. 908sharonj's Avatar
    did any of this work for you?
    02-22-2010 06:42 PM
  13. tribalartgod's Avatar
    What you need to do if you are stuck on this screen is to install the DREAIMG.nbh file. this will put you back to 1.0 STOCK FIRMWARE... From here, you can then manually update to CUPCAKE, then wait for the OTA to bring you back to DONUT.

    If anyone would like these files, I have everything separated by folders, and step by step instructions for rooting and unrooting your G1 phone. THESE INSTRUCTIONS ARE FAR FAR FAR more detailed than what you will find online. It is literally click by click, button by button.

    Just shoot me a message. I will send the link to individuals. If there is enough demand, I will post for everyone.
    05-26-2010 10:38 AM
  14. ilongbored's Avatar
    I had this same exact issue. Every once in awhile I was able to boot up, but then the home button would act like it was being held down.

    I was able to flash the recovery image, flash a new recovery, install Cyanogenmod (all with much difficulty) and I still have the same issue.

    I would definitely try some of the other suggestions, they might work.

    I was wondering is the issue is due to the ribbon cable between the main board and the screen. I'll be taking mine a part to see if anything looks odd, boot it back up. I'll get around to doing that in the next few days. If I find anything out, I'll get back to you.
    06-24-2010 07:22 PM
  15. AmarilysLopez20's Avatar
    hey can you send me the links so i can try and fix my G1
    03-21-2013 08:10 PM
  16. yoryimarte's Avatar
    Hi, can I have those files so I can fix my G1 too?
    12-29-2013 12:14 PM