1. lunchBB's Avatar
    I noticed this happen for the past few days. At 100% full charge, the phone will tell you to disconnect the AC charger. Then, until many hours or many usage later, the phone still report 100% battery. Then if I reboot the phone, it will show the actual remaining power.. which was like 60%, 45%... .

    It happened again this morning. I saw the phone still show 100% full. Then I reboot the phone and it is actually 20% left.

    I reset the phone today. If it happens again, I will bring it back to tmo store for a replacement.
    10-17-2011 06:43 PM
  2. dustyd's Avatar
    i am having the same problem i think its a software bug im also noticing other small bugs nothing major if your in an area where there's no signal for a log period of time you don't get it back when you do have a signal fix turn flight mode on then off that will fix it if all else fails reboot your phone
    10-18-2011 03:46 PM
  3. lunchBB's Avatar
    I think I know what's wrong. I use a MicroUSB AC adapter from my Nexus One phone to charge the phone. Once it's at full charge, it won't charge again and it will always show 100% full charge even though it is not. Now I switch back to computer MicroUSB cable. it is working fine now.

    I still think it's a bug... it's also an annoying feature for Samsung to think they need to tell us when the phone is 100%. For people using the phone all day, plug it in before going to bed.. then they will wake up with the notification sound. annoying!
    10-18-2011 04:17 PM
  4. lunchBB's Avatar
    Have the phone exchanged. It behaves the same way. The battery level indicator only works correctly using USB cable to charge. If I use any AC adapter or external battery charger, after 100% full charge, it will report 100% even though it is not. And it won't charge anymore The only way to get it back to work is to reboot the phone.
    10-23-2011 01:55 PM
  5. lmc05's Avatar
    It's strange, mine seems to have done this for the first time tonight. I've had the phone since the day after it launched and with the exception of one time, I've always used a blackberry wall charger to charge my phone at night and haven't had a problem with showing an accurate battery level.

    Tonight though, I plugged it in and it said "100%, battery fully charged, please unplug". So I unplugged it and it immediately told me that my battery was critically low at 8%. Very strange that it's just now deciding to do this.

    Haven't noticed anything else out of order with the phone.
    10-25-2011 01:34 AM
  6. Mansquared's Avatar
    my situation is that i use 4 different chargers.
    1- usb data cable from blackberry connected to PC - which works fine for charging and data transfers
    2- Wall charger that came with the Phone (USB + AC adapter) - this also works fine
    3- Blackberry Wall charger - this is fine and charges well.
    4- After market wall Charger which i plug into and the phone suddenly gets really laggy. so much so that it seems like it is frozen. when i try to scroll through it it just opens the first icon i touch and it is still super laggy, pretty much frozen.
    but when i unplug it. it immediately works fine....weird...

    anyone else with a similar problem?
    11-03-2011 09:22 AM