1. Jeremytallman's Avatar
    Just picked up a White GSII over the weekend. Tried multiple times to get the update over the air and no go. I successfully applied the update via Kies today in less than 20 minutes.

    Now About Phone says:

    Android Version: 2.3.6

    Baseband Version: T989UVKL1

    Kernel Version:

    Build Number: GINGERBREAD.UVKL1

    Now my BT is not working right. I pair with an Moto HX1. Gives a beep every 30 secs or so through the headset and the connection light on the headset blinks red every 6 sec or so. I can still use BT with the phone; but the beep is super annoying. It worked just fine prior to the update.

    Will have to wait and see if the battery lasts longer. I had mixed results battery wise in the last few days of using it quite a bit and downloading new apps, etc. over wifi and 4G.

    Anyone experience similar BT issues? Thanks!
    12-20-2011 05:21 PM
  2. Jeremytallman's Avatar
    Follow up:

    I have also removed the pairing, reset the headset to factory multiple time and re-paired, etc., with no effect.
    12-20-2011 05:33 PM
  3. Jeremytallman's Avatar
    Just finished IM chatting with Samsung customer service who had me do a soft and master/factory reset, which I told them would not work, as the UPDATE was a factory reset. Did what they asked and my Bluetooth problem is still there. Told me to call in now. Great!
    12-20-2011 06:16 PM
  4. Jeremytallman's Avatar
    Ok, feel like I am talking to myself; but figured out the problem on my own. Thanks worthless Samsung Support.

    Here is what is happening, and you may/may not experience this yourself with your Bluetooth headsets after the update:

    The NEW/Fixed Wi-Fi calling feature, when activated (which it is by default, if memory serves; but can be turned off), interferes with a strong BT connection. That causes the poorer connection and intermittent beeping in the headset and flashing red light (at least for my Moto HX1). Talking to people they said that I was cutting out a bunch.

    Turn off Wi-Fi and the problem goes away.

    Also, if you want to keep Wi-Fi active and fix the above - disable the Wi-Fi Calling feature and BT functions normally.

    This is a bug that they obviously did not catch.

    Another glitch I noticed with the Wi-Fi calling activated is that it interferes with picture-msging (you can still basic txt). Turn it off and go back to 4G/3G and picture-msging works again.

    Samsung needs to fix this as I know the Wi-Fi feature will be sorely needed for some of you.

    Hope my helping myself helps you all.
    12-20-2011 11:25 PM
  5. vr002sh's Avatar

    Thanks this will be helpful to the rest of us as we get our updates

    12-20-2011 11:30 PM
  6. roberts68's Avatar
    thanks for the update.

    cant believe samsung missed this basic interference flaw.
    tahts poor troubleshooting.

    luckily wifi calling is not an immediate need so i can disable it until they fix this BT interference problem.
    12-21-2011 12:48 PM
  7. dobiegillis's Avatar
    Just got my white GSII yesterday but no update available. How did you get it via Kies?

    Sent from my Samsung Galaxy S II
    12-21-2011 07:59 PM
  8. Jeremytallman's Avatar
    go to Samsung's website. This is the link I followed from a google search: Kies 2.0 (there is a windows and a mac link)

    have your USB cord that came with the wall charger handy

    install Kies 2.0 and follow the directions.

    Once you have your GSII attached via USB it should auto detect and notify you that there is an update available for your handset.

    I personally did not sync anything other than music/pics/vids and maybe contacts (although I use google/gmail for my contacts); but I did back up my photos/music, etc. before applying the update.

    hope that works for ya. :-)
    12-23-2011 04:40 PM
  9. roberts68's Avatar
    the OTA update for my phone came last week.
    my wife's phone update OTA just came this am
    so they are still rolling out the OTA updates.

    my only BT issue is when my headset gets turned off, when i turn it back on, my s2 wont see it.
    12-29-2011 12:31 AM
  10. afhanson72's Avatar
    Thanks, that helped me as I'm having problems with the picture messaging. Can we go back to the old software version until 4.0 comes out?

    Sent from my GS2 via Tapatalk.
    12-29-2011 06:20 PM
  11. roberts68's Avatar
    now my bluetooth is jacked up.
    it seems to shut off every night on the phone.

    the only reason how i know is when i get into my car every morning and turn on my bluetooth headset, it says "go to your phone to pair"
    so i look on the phone and bluetooth is off.

    then it takes about 3 minutes, and checking the checkbox twice to get it to turn back on.
    once its on, it pairs fine.

    01-01-2012 01:25 PM
  12. 303kush's Avatar
    I don't use anything with Bluetooth so idk about the problem. but what's up with the new music app with the headphones?? When I use the original music app the new one with the headphones runs in the background it pisses me off is it new bloatware??
    01-01-2012 10:00 PM
  13. nitin.jiit's Avatar
    I have the same problem...Since the OTA update to 2.3.6 on my white galaxy S2, My BT is not working.
    I disabled the WI-FI Calling and tried -- Did not work
    I disabled the WI-FI and tried -- Did not work.

    Please help.
    01-02-2012 02:26 AM
  14. roberts68's Avatar
    i disabled the wifi calling thinking it would help with my bluetooth issues since thats what i've read on some posts, but it hasnt helped.

    Just this morning I was listening to a podcast on my bt headphones and the bt just shut off.
    my phone was 80% battery, the headphones had just been fully charged.
    so i looked at my phone, and sure enough, bt was off.
    so i clicked to turn on bt, nothing happened after a minute.
    then i click on it again, and it turns on. but doesnt pair automatically.
    so i click scan, it scans and doesnt pair.
    then i click on my headphones that are in the list, and it pairs.
    what a frickin' joke!

    this update is a mess with bluetooth. and it has nothing to do with the wifi calling feature.
    HELP! someone!
    thats the only problem, is who do you call?! for help?!
    01-02-2012 12:51 PM
  15. Jeremytallman's Avatar
    That is not cool. Once I figured out that the WiFi Calling feature was messing my BT, my problems went away once I turned it off when my WiFi is on. I hope someone can help you guys.

    The one thing you might try regarding BT issues is to make sure your WiFi is off completely? If you are on the go and not connected to WiFi there is no need to have it on anyway. See if that helps.

    GRRR - "Updates"

    @ 303kush that headphone app/icon is the Google Music that finally rolled out to our SGSII's. I have yet to use it a whole lot; but the killer feature is supposed to be that you can now upload 20,000 songs to your google account for free and stream them or download to your phone/tablet, etc. from the "cloud" using the Google Music player. That is the way I understand it anyway from what I read. :-)
    01-03-2012 04:40 PM
  16. roberts68's Avatar
    I've used Google Music, it is pretty cool. You download a program to your desktop and it automatically syncs with the google cloud all your music.
    Then you can access them streaming from your phone with the headphones.
    you can also choose which ones to download to keep on your phone, so you can listen offline too.

    i used that until i found doubletwist w/airsync. it syncs with itunes and keeps all my playlists the same. and it seems to have the songs on my phone somehow so even when i'm not online it can play all my songs.

    so now i dont even use google music anymore, even though i still keep it synced, just in case i guess.
    01-04-2012 10:50 AM
  17. roberts68's Avatar
    so i'll try turning the wifi off completely to see if that helps with my bluetooth issues.

    for the past 2 mornings i take my dog for a walk and listen to podcasts on my Arriva Leo's bt headphones (LOVE THEM). About 30 mins into my walk each morning, the bluetotth just shuts off!


    So then i have to try and turn it on, which takes two clicks of the checkbox and about 2 minutes in between checks. AUGH!

    ok, so all wifi is now disabled (even though i used it at home all the time)
    i'll update tomorrow after my next go around with it.
    01-04-2012 10:53 AM
  18. pobs123's Avatar
    I have a similar problem to "roberts68" in post #11 - except than I must powered off (and power on) the phone, in order to see the paired BT devices.

    Wi-Fi calling has been disabled since day 1 (when I bought the phone, it already had 2.3.6 on it).

    roberts68 - did completely disabling Wi-Fi resolve the BT problems ?

    Any "sure fire" solutions to this problem ?

    02-08-2012 02:35 PM
  19. dobiegillis's Avatar
    I've never received the ota update so I'm still running 2.3.5. However I have trouble with by BT frequently not connecting with my car. The only solution is a power cycle. Do you guys think I should manually update? Sounds like BT is worse in those cases...

    Sent from my Samsung Galaxy S II
    02-11-2012 06:23 AM
  20. pobs123's Avatar
    Based on what I've seen - if the only reason to upgrade to 2.3.6 is to fix the BT problem, I personally would not upgrade it. Because it does not seem to fix it.

    I have gotten to the point that I cycle power on phone, and turn BT on again - before I leave work - because BT will not stay on for the 8 hours or so that I am at work (with 2.3.6).
    02-11-2012 07:59 PM
  21. dobiegillis's Avatar
    Yeah I've decided to wait and deal with it. Ugh.

    Sent from my Samsung Galaxy S II
    02-11-2012 08:12 PM
  22. dobiegillis's Avatar
    Got tired of waiting so I downloaded Kies and updated last night. Everything went fine. I forgot all about the update and today I used the phone in my car with no problems, so I'm hoping I don't have the issues others reported.

    Sent from my iPad using Tapatalk
    03-04-2012 06:50 PM
  23. Jeremytallman's Avatar
    From what I found in my own digging and settings tweaking, if you don't need wifi calling, keep it turned off (you can still use wifi, just keep the wifi calling off) and your BT should be fine. :-)
    03-08-2012 04:07 PM
  24. dobiegillis's Avatar
    From what I found in my own digging and settings tweaking, if you don't need wifi calling, keep it turned off (you can still use wifi, just keep the wifi calling off) and your BT should be fine. :-)
    Good point. I turned wifi calling off after update because my sim is incompatible. I've ordered a new sim so once I get it I'll turn wifi calling on and test it.
    03-08-2012 08:18 PM
  25. dobiegillis's Avatar
    Mine works fine. Although I've found wifi calling unreliable and I can't send sms when it's on so I've disabled it for now.

    Sent from my Samsung Galaxy S II
    03-25-2012 03:43 PM