1. Horr1bleK1tten's Avatar
    My 4G works fine but as soon as a try and switch to 3g it only gives me the e, which I'm guessing is the edge network and it is really slow. Any ideas on how to get 3g Working? Any help please.

    Sent from my SGSII using Tapatalk
    01-15-2012 11:35 PM
  2. anon(585474)'s Avatar
    As far as I know, there is no option or way to use 3G instead of 4G. There is only the option to use the GSM network, aka EDGE, instead of the faster WCDMA T-Mobile network, aka 4G.
    01-17-2012 06:26 PM
  3. Horr1bleK1tten's Avatar
    That's what I read dammit I hate edge its ridiculously slow. Slower then crickets data btw. Looks like I'm gonna have to raise my 4G data

    Sent from my SGSII using Tapatalk
    01-17-2012 06:29 PM
  4. mikey3450's Avatar
    There is no option on this device to only select 3G data. your data indicator on the notification bar will only show 4G whether you have 4G or 3G.
    01-18-2012 11:26 PM
  5. Horr1bleK1tten's Avatar
    I've never been on 3g

    Sent from my SGSII using Tapatalk
    01-18-2012 11:41 PM
  6. mikey3450's Avatar
    the only way to even know if you are on 3G is to go in to the settings, about phone, network and that will show you whether you are on HSPA or UMTS
    01-18-2012 11:44 PM
  7. Horr1bleK1tten's Avatar
    The hsps is 4G I've never seen that other option

    Sent from my SGSII using Tapatalk
    01-19-2012 12:40 AM
  8. bipoler#AC's Avatar
    I notice umts is active but the moment data starts it turns to hspa so thats cool

    Sent from my SGH-T989 using Tapatalk
    02-08-2012 10:03 PM
LINK TO POST COPIED TO CLIPBOARD