1. Fugaz-Star's Avatar
    So, I ordered this version of the GS2 from Canada, since I don't like to have carrier logos all over my phones (previous phone was HTC Nexus One) and since they were basically the same, I thought there would be no problems. But, I'm having this issue where my phone won't connect to the hspa+ network (4G) in an area where there is strong coverage.
    I'm not sure if this is a hardware issue, they both work on the same frequency, 1700/2100. Or maybe a software issue (I'm not an expert in these type of things)
    I don't want to contact T-Mobile as most of them have no idea what they are doing, I know them pretty well. All they will tell me is to get their US version.
    So, if anyone know something about this problem, please let me know.
    Also, would I be able to receive the ICS update?
    Thanks
    04-11-2012 05:18 PM
  2. Bbobarino's Avatar
    I am no expert either but I would root it and try a t-Mobile radio/baseband. In my experiences the kl1 modem gives me the best 4G/data. I myself have the us version but this is the first thing I do when data is ty. Go to xda developers forums search Mr.x check his posts he has all the modems including the Telus modems and t-Mobile

    Sent from my SGH-T989 using Tapatalk
    04-18-2012 06:37 AM
  3. Bbobarino's Avatar


    Sent from my SGH-T989 using Tapatalk
    04-18-2012 06:38 AM
  4. Sean Boucher's Avatar
    ur true telus so am i so that means iam a sgs t989:o)
    03-22-2013 07:30 PM
LINK TO POST COPIED TO CLIPBOARD