1. febzz's Avatar
    Hi,

    I bought a T-mobile Galaxy S3 LTE (SGH-T999L) from a Seller from Craigslist. He did tell me he installed a Custom ROM and right before selling it to me, he reinstalled the Stock Firmware.

    What I hadn't realized until after I bought the Phone was apparently the Device Status under About Phone is now "Modified" instead of "Normal" or "Official". Now I can't receive OTA updates anymore (and I guess, not even via Kies).

    I downloaded the Root Checker app from Play Store, and what the App says can be seen in the attached images:
    https://www.dropbox.com/sh/cfht8arg16hlgdb/suNSnwF1Z8

    I believe the Device is not rooted.

    But when I went into the Download Mode, the Custom Binary Download says Yes (1 count), and both Current Binary and System Status shows Custom.

    I am just a regular android user and have no experience in rooting whatsoever, and it seems that I may need to do something like this to get this fixed.

    Can someone please guide me as to what I should do in order to restore everything to the Stock Firmware and put everything into "Official" or "Normal".

    I tried looking for the answers but I ended up getting confused. I know I may need to do Triangle Away, then flash Stock Firmware again, then do Recovery, etc. But at this point, based on my phone's circumstances, where I should start? Since according to the App, it is not rooted anymore, but as far as I know, in order to use Triangle Away, the Phone must be rooted? Or, given my phone's current state, is there a way or shortcut to getting all this fixed (maybe I can skip a few steps)?

    I really really appreciate the kindness and help from all Android Central members!
    07-24-2013 02:59 PM
  2. Golfdriver97's Avatar
    Hi,

    I bought a T-mobile Galaxy S3 LTE (SGH-T999L) from a Seller from Craigslist. He did tell me he installed a Custom ROM and right before selling it to me, he reinstalled the Stock Firmware.

    What I hadn't realized until after I bought the Phone was apparently the Device Status under About Phone is now "Modified" instead of "Normal" or "Official". Now I can't receive OTA updates anymore (and I guess, not even via Kies).

    I downloaded the Root Checker app from Play Store, and what the App says can be seen in the attached images:
    https://www.dropbox.com/sh/cfht8arg16hlgdb/suNSnwF1Z8

    I believe the Device is not rooted.

    But when I went into the Download Mode, the Custom Binary Download says Yes (1 count), and both Current Binary and System Status shows Custom.

    I am just a regular android user and have no experience in rooting whatsoever, and it seems that I may need to do something like this to get this fixed.

    Can someone please guide me as to what I should do in order to restore everything to the Stock Firmware and put everything into "Official" or "Normal".

    I tried looking for the answers but I ended up getting confused. I know I may need to do Triangle Away, then flash Stock Firmware again, then do Recovery, etc. But at this point, based on my phone's circumstances, where I should start? Since according to the App, it is not rooted anymore, but as far as I know, in order to use Triangle Away, the Phone must be rooted? Or, given my phone's current state, is there a way or shortcut to getting all this fixed (maybe I can skip a few steps)?

    I really really appreciate the kindness and help from all Android Central members!
    Welcome to the forums!
    Triangle Away....I know of it, and have heard of many forums saying to be careful because you are messing with lines of code in the bootloader. That is the only way to restore your phone to Normal status. A different way would be to flash the most updated stock ROM yourself.
    07-24-2013 10:31 PM
  3. febzz's Avatar
    Welcome to the forums!
    Triangle Away....I know of it, and have heard of many forums saying to be careful because you are messing with lines of code in the bootloader. That is the only way to restore your phone to Normal status. A different way would be to flash the most updated stock ROM yourself.
    Hi,

    Thanks for the warm welcome.

    I did the following process three times, but to no avail

    I am not really sure what the problem is.

    Here's what I did:
    1. Rerooted using Motochopper method (successful)
    2. Installed CWM Recovery using Odin v 3.07 (successful)

    From Steps 3 onwards, I followed the Guide made by DocHoliday77 from XDA Forum (http://forum.xda-developers.com/show...hp?t=2308514):
    3. Flashed PureStock ROM (successful)
    4. Flashed the unmodified, Secure UVAMB7 Kernel (successful)
    5. Flashed Stock UVAMB7 Recovery (successful)
    * I flashed these using CWM Recovery, not Odin. I wasn't sure how to do it using Odin as I couldn't find any ".tar.md5" files. So I flashed the .zip files using CWM Recovery.
    6. From Recovery Mode, I did Factory Reset and Wiped my Cache. (successful)
    7. Rebooted Phone, used Triangle Away to reset the Counter. (successful)

    Then I powered the phone off, entered the Download Mode and everything was still showing official and the Custom Binary Download showed NO at this point. I then booted the phone up again, uninstalled Triangle Away and then from the SuperUser App, I fully unrooted the phone.

    Once all this was done, I powered the phone off again and went to the Download Mode and now the Counter showed YES (1 count), Current Binary = Custom, System Status = Official. So now the Device Status under About Phone is back to Modified again.

    I have done this 3 times, if anyone can help me figure out what went wrong, I'd really appreciate it! So frustrated
    07-25-2013 10:30 AM
  4. Golfdriver97's Avatar
    Hi,

    Thanks for the warm welcome.

    I did the following process three times, but to no avail

    I am not really sure what the problem is.

    Here's what I did:
    1. Rerooted using Motochopper method (successful)
    2. Installed CWM Recovery using Odin v 3.07 (successful)

    From Steps 3 onwards, I followed the Guide made by DocHoliday77 from XDA Forum (http://forum.xda-developers.com/show...hp?t=2308514):
    3. Flashed PureStock ROM (successful)
    4. Flashed the unmodified, Secure UVAMB7 Kernel (successful)
    5. Flashed Stock UVAMB7 Recovery (successful)
    * I flashed these using CWM Recovery, not Odin. I wasn't sure how to do it using Odin as I couldn't find any ".tar.md5" files. So I flashed the .zip files using CWM Recovery.
    6. From Recovery Mode, I did Factory Reset and Wiped my Cache. (successful)
    7. Rebooted Phone, used Triangle Away to reset the Counter. (successful)

    Then I powered the phone off, entered the Download Mode and everything was still showing official and the Custom Binary Download showed NO at this point. I then booted the phone up again, uninstalled Triangle Away and then from the SuperUser App, I fully unrooted the phone.

    Once all this was done, I powered the phone off again and went to the Download Mode and now the Counter showed YES (1 count), Current Binary = Custom, System Status = Official. So now the Device Status under About Phone is back to Modified again.

    I have done this 3 times, if anyone can help me figure out what went wrong, I'd really appreciate it! So frustrated
    Most of the time flashing through CWM is not successful. Give me some time to think about it, and I will get back to you.

    Sent from a SlimROM S3.
    07-25-2013 12:01 PM
  5. UnRealistic1's Avatar
    Hello. I have fully unrooted to stock before. Keep in mind that unless you are 100% official, every time you boot your phone, the flash counter will change to 1. I had a ROM and even though the counter was set to "0" when I used Triangle Away, I restarted the phone and it was back to "1". What you should do is repeat everything like you had, but instead of restarting the phone after using Triangle Away, try unrooting from your SU app, then restart.In other words, repeat 1-6. Then use Triangle Away without restarting, then unroot from your SuperUser app, and then restart. Hope this helps!
    07-30-2013 07:31 PM
  6. Ben Leverett's Avatar
    I have a problem with my phone, nonlinearly similar to the one described in the first post. The only difference being I can't actually boot <I>into<I\> android. I can still boot into CWM recovery (originally flashed with Odin), and Download mode. It'll boot up normally just fine___________________ until I get to the screen that has the little flag flashing in and out of focus saying "T999L", with a super imposed "T-Mobile". Then it just seems to stay frozen in a make-shift boot loop (it does that over and over until I decide to yank out the battery). The two attached files are my nandroid backups, both from after I installed CWM and before this whole problem started, and after. Hope that helps.:-)
    02-05-2014 08:10 AM
  7. Ben Leverett's Avatar
    The two attached files are my nandroid backups, both from after I installed CWM and before this whole problem started, and after. Hope that helps.:-)
    It wouldn't let me attach files for one reason, or another. Is there an email I can send them, or something?
    02-05-2014 08:14 AM
  8. Gordo L's Avatar
    Did you try to flash stock rom from Odin
    Doniel Erickson likes this.
    03-25-2014 03:54 PM

Similar Threads

  1. Replies: 3
    Last Post: 02-15-2016, 11:45 AM
  2. Anyway to stream videos on my S4 Galaxy to my iPad
    By DWdrummer83 in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 02-16-2014, 09:34 PM
  3. Does this work with other AV equipment?
    By ottscay in forum Google Chromecast
    Replies: 15
    Last Post: 02-07-2014, 12:55 PM
  4. Replies: 2
    Last Post: 08-09-2013, 01:24 PM
  5. Wireless Sync Transformer to PC and Galaxy S2 phone
    By Dixcee in forum Android Apps
    Replies: 0
    Last Post: 07-24-2013, 02:14 PM
LINK TO POST COPIED TO CLIPBOARD