1. eric0668's Avatar
    At the O's game last night, I attempted to take pics, and each time, the screen went black. I thought it just turned off, but it locked it and would not turn back on until a battery pull

    It did it about 5 times. Finally it did work.

    I thought all was fine, until I gave my phone to a friend today to take a pic I wanted, well the same thing - the pic showed up then BLACK.

    I planned on writing this post. Before that, using Nova Prime, but having the stock TWiz and Go Launcher, I tried both of them to see if it was the launcher.. It was not Same problem

    I did however look in my battery charger and see the factory battery. I installed and worked perfectly on first try

    I bought 3 batteries from Amazon, have NEVER had a problem with all 7 Androids the past 2.5 years

    It very well could, or almost bet your life, is the NON-Oem battery correct?
    Or has this been a GS3 issue?

    Any feedback would be appreciated

    Regardless, I have a different line of batteries, not the cheaper ones with Samsung on it. I should have known they only charge to 90 percent. But the pure black ones with a black and white label.
    08-12-2012 06:01 PM
  2. jifejacobs's Avatar
    I thought I was the only one having this issue. I had the problem with it within a week of getting it, then no other problems. I thought maybe it was just a quirk. But tonight I was trying to take pictures of my son at the circus and it kept cutting off. I'm sure other people have had this problem, right?
    10-04-2012 10:36 PM
  3. eric0668's Avatar
    I use Nova Launcher Prime, NOT TouchWiz so I didn't know if it was Nova because I don't even goto TWiz or have the screens set up
    10-04-2012 10:42 PM