10-31-2016 06:59 AM
63 123
tools
  1. xveeeee's Avatar
    So I've had my Galaxy S3 for about 2 months now and I've never had a problem with connecting to the WiFi. However, today my phone started acting up. My phone can connect to wifi with weak signal strength but when I try to connect it to my router (Cisco) with very strong signal strength, it doesnt work. It says connecting for about 5-10 seconds but after that, it just stops and doesn't connect.
    I've tried the whole "dialing *#0011#" and forgetting the network but it doesn't help at all.
    Has anyone else had this problem?
    Help?

    Also here's some pictures to show what I mean. My phone just gives up on trying to connect to Cisco.
    Denise Cahoon likes this.
    05-12-2013 07:40 PM
  2. meyerweb#CB's Avatar
    No pictures in your post. If it connects to other WiFi APs, I'd do this:

    Delete this WiFi configuration from your phone.(You don't need#0011##. Just tap on that WiFi connection in Settings.)
    Reboot the router. Double check the router setup to see what type of security is enabled. For the initial setup, at least, make sure the SSID is visible.
    Recreate the connection on your phone.
    05-17-2013 10:28 AM
  3. newestDroidUser's Avatar
    I ve spent nearly 3 hours today and 4 hours last week trying to resolve this on my new S3. I was pretty flummoxed when the wifi signal seemed to drop off without any reason.

    After much hunting, my initial hunch seems to be correct

    a) Interference from other devices

    b) Unable to get an IP address

    c) I am just a layman when it comes to networking, but since all of my other devices at home the iPad, iPhone and my laptop seem to have no issues (my laptop occassionally has the same drop-off problem), I thought it's likely to be a phone issue rather than a router issue.

    To resolve this I found another thread on the forum and I tried this, and Bingo! it worked.

    Press these menu options on your phone: Settings > Wi-fi> (Choose your network by tapping on it for a few seconds) > Modify network config

    Check "Show advanced options"

    Choose IP Settings: "Static"

    Enter these details
    IP - 192.168.1.253 or 195.168.1.253

    Gateway - 195.168.1.1 (I chose 192.168.1.1 since that's my router address)

    NPL - 24

    Netmask - 255.255.255.0 (I could not find this option)

    DNS 1 - 8.8.4.4 or 8.8.8.8 (I had the latter by default and let it stay)

    DNS 2 - 4.4.4.4

    And save.

    Presto! It just connected in a few milliseconds.

    It may not be so simple for each phone, but it's certainly worthwhile to try.

    Here is the link the forum thread, where I resolved it: http://androidforums.com/samsung-gal...s-problem.html

    Good luck
    05-23-2013 12:04 PM
  4. Tim Henley's Avatar
    This has just happened to my phone and was hoping you had found the solution
    I've tried everything that has been suggested to you and still no joy
    06-10-2013 06:08 AM
  5. Naresh Tyagi's Avatar
    Go to WiFi advance settings and unchecked NETWORK NOTIFICATIONS and WiFi TIMER

    Also uninstall unusual apps specially camera related ... or other unauthentic apps

    Open WiFi and tap on connected network - tap forget - disconnect WiFi - restart your device - then again connect WiFi with password ..

    Do not forget restart your device ..
    merchant7 and jeremy rowe like this.
    07-01-2013 07:32 AM
  6. Pcamille's Avatar
    Thank you so much!! I was getting frustrated and you just saved me
    07-02-2013 11:05 AM
  7. joboyce7's Avatar
    still not working tried all this :-( how do u get into advance wifi settings?
    07-04-2013 05:53 PM
  8. limaro_83's Avatar
    Brilliant, I've tried everything, some that work some of the time and others that don't work at all but followed the instructions and it worked within milli seconds just like you said lol Cheers mate saved my second S3 from being launched!
    07-13-2013 10:34 AM
  9. churro#WN's Avatar
    For the sprint version its *#0011#
    07-15-2013 03:34 AM
  10. nigelparr's Avatar
    That was excellent information. The wifi connected in seconds
    07-20-2013 12:41 PM
  11. lid2013's Avatar
    Hi - My Samsung Galaxy Mini 3 will not connect to our Wi-Fi - and brings up the alert = NO INTERNET AVAILABLE then: Internet not available via selected Wi-Fi AP. Change Network? Please, please help sux crap.
    07-29-2013 03:15 AM
  12. Eran Erwin's Avatar
    @newest, thank you so much for the great info!!! You saved me from having to call tech support--and from doubling my data bill!!! Thanks again
    08-01-2013 09:46 AM
  13. David Chang1's Avatar
    this works. thanks a bunch!!
    08-02-2013 12:36 PM
  14. PolinaFly's Avatar
    thank you SO MUCH! This fixed my "poor internet connection avoided" issue is seconds!
    You are amazing, thank you for making my day, stay epic <3
    08-12-2013 11:27 AM
  15. MaggieAlaska's Avatar
    Thank you! Thank you! Thank you! This solution did the trick for me.
    08-18-2013 02:34 PM
  16. Kevin C Brown's Avatar
    I ve spent nearly 3 hours today and 4 hours last week trying to resolve this on my new S3. I was pretty flummoxed when the wifi signal seemed to drop off without any reason.

    After much hunting, my initial hunch seems to be correct

    a) Interference from other devices

    b) Unable to get an IP address

    c) I am just a layman when it comes to networking, but since all of my other devices at home the iPad, iPhone and my laptop seem to have no issues (my laptop occassionally has the same drop-off problem), I thought it's likely to be a phone issue rather than a router issue.

    To resolve this I found another thread on the forum and I tried this, and Bingo! it worked.

    Press these menu options on your phone: Settings > Wi-fi> (Choose your network by tapping on it for a few seconds) > Modify network config

    Check "Show advanced options"

    Choose IP Settings: "Static"

    Enter these details
    IP - 192.168.1.253 or 195.168.1.253

    Gateway - 195.168.1.1 (I chose 192.168.1.1 since that's my router address)

    NPL - 24

    Netmask - 255.255.255.0 (I could not find this option)

    DNS 1 - 8.8.4.4 or 8.8.8.8 (I had the latter by default and let it stay)

    DNS 2 - 4.4.4.4

    And save.

    Presto! It just connected in a few milliseconds.

    It may not be so simple for each phone, but it's certainly worthwhile to try.

    Here is the link the forum thread, where I resolved it: http://androidforums.com/samsung-gal...s-problem.html

    Good luck
    I've worked with networking for 20 years and this made zero sense to me, yet I gave it a try since nothing else made sense either.

    It worked!

    This has to do with something proprietary with Samsung, as it is NOT an Android/Linux networking work around.

    Thanks much for this information, it helped me get my wife's SIII Mini up and and running. I have two S4s that have no problem, so will have to track down the differences between the two builds.
    08-27-2013 05:09 PM
  17. vinhtq79's Avatar
    Hi guys, I'd like to share my experience on this bug. My galaxy S3 can detect well the wifi networks but can not connect to them even strong signal. It only work when I stay near the router. I find a lot of solutions and I confused. I think that it is the end of my S3.
    But luckily, I found the way by combination 2 methods. Firstly, I flash stock rom 4.1.2. After that I use code *#0011# to change the wifi mode to wifi power saving mode and it really did a amazing trick. I am quite sure that it can help guys who have the same issue of wifi and not been finding the way out!
    Good luck!
    update: Wifi connection is significantly improved, but it is not getting perfect compared with the wifi connectivity before bug occured. Continue to find solution. Maybe the wifi connection standard of galaxy S3 has been changed.
    09-16-2013 03:08 PM
  18. jsainju's Avatar
    i love u for this i tried everyhing even static ip thing but was not working but this one boom worked
    Denise Cahoon likes this.
    09-19-2013 10:41 AM
  19. KevinValenta's Avatar
    This worked for me on my Galaxy S3 (my IP Settings were not set on Static and my IP was set slightly differently). Thanks very much.
    10-07-2013 07:55 AM
  20. edonaghy's Avatar
    Hey guys!!
    On my Samsung galaxy young my internet worked fine 2 days ago but now it will not pick up any internet connections on my wifi settings. I have tried everything that has been mentioned above but it won't work. All other devices that I have can connect like my kindle and laptop but I don't know what is wrong with my phone internet!!!
    Can use please help me........
    10-07-2013 01:38 PM
  21. shoulderbanne's Avatar
    does anyone by chance know how I can get wifi to work on my Samsung galaxy s3 as I can connect to the wifi but I can use it at all and no error message comes up
    10-13-2013 01:31 PM
  22. algipan0's Avatar
    Hi have had same problem, solved it by resetting the router not just by switching off but holding in the reset with a thick paper clip for 15 seconds after all lights are green switch Wifi back on in phone and re enter password (KEY) worked first time. Good luck Galaxy S3
    10-21-2013 03:38 AM
  23. Bryan Elkins's Avatar
    so i have my galaxy s3 since my birthday on 10 19 of this year and i have no idea how to get it to connect to my wifi. i have tried several things but i am in no way a tech savy person so need some help.
    10-28-2013 08:13 PM
  24. SammieStarr22's Avatar
    My wifi works for my computer and I have no problems with using my computer but as of today my phone won't connect to my wifi. I've tried a ton of other suggestions from other forums and nothing is working. Every single time I try to connect to my wifi from my phone it says "Authenticating..." and then "Saved, Secured." repeatedly and nothing happens otherwise. I have a password for my wifi and I've even tried taking off the password but it still doesn't work. I put in the right password too.. So I don't know what else to do..
    10-28-2013 11:38 PM
  25. Dave Spagnol's Avatar
    I just had this problem - and I read this and other forums and tried many solutions. The one that worked was to log into my wireless router from my computer and change the start of the range of IP addresses to be allocated by DNS to 192.168.0.5 instead of 192.168.0.3 - I then found the MAC address of my S3 device (Settings/Wi-Fi then touch bottom left and select Advanced) and reserved 192.168.0.4 for it. If you don't know how to hack into a router you might have a problem and it would be wrong for me to say precisely how as different routers are different. But it seems to have worked.
    11-01-2013 01:05 PM
63 123

Similar Threads

  1. my Galaxy s3 will not connect to Mac
    By Matt Adamski in forum Samsung Galaxy S3
    Replies: 3
    Last Post: 09-11-2013, 10:22 AM
  2. Replies: 0
    Last Post: 03-19-2013, 12:16 PM
  3. Galaxy S3 will not connect to any WiFi network
    By Becciboo81 in forum T-Mobile Galaxy S III
    Replies: 1
    Last Post: 01-23-2013, 06:24 PM
  4. Samsung Galaxy S3 taking 30 seconds + to come out of sleep mode
    By shadoWyld in forum Samsung Galaxy SIII I9300
    Replies: 2
    Last Post: 11-02-2012, 06:58 PM
  5. Samsung Galaxy Tab 10.1 16 GB Wifi (with Samsung Case)
    By soccerfon711 in forum Marketplace Archive
    Replies: 4
    Last Post: 09-17-2011, 10:26 AM
LINK TO POST COPIED TO CLIPBOARD