1. itic's Avatar
    The phone is a 6 month old 16G T999 from T-mobile running 4.1.2 with a 32G SD card installed.

    I left the phone on the charger overnight and this morning the blue notification, white menu and back page lights were lit and the screen was black. When i pushed the power button the phone vibrated like it normally does when its booting up but it wouldnt advance beyond the SAMSUNG screen, the blue notification, white menu and back page lights lit up again and that was it. I tried to reboot the phone into recovery mode and pulled the battery twice and the phone didn't respond to either. I plugged the phone into my PC and the PC didn't acknowledge it and the phone didn't respond.

    Ive read about the I9300 "sudden death" issue and the US versions having motherboard/chip failures but neither of these issues seem to have the symptoms i'm experiencing. i called Samsung and they authorized me to send it to them from repair or replacement but before finalizing it i told the samsung rep i wanted to call t-mobile first and see if they had any other options available. T-mobile told me that if either samsung or t-mobile replace the phone it will most likely be a refurbished phone and didnt offer anything else. Is there anything else i can try on my own that "might" fix the problem or should i send it into samsung and take the chance of ending up with a refurbished phone.

    TIA, Happy Friday
    07-19-2013 12:21 PM
  2. Golfdriver97's Avatar
    The phone is a 6 month old 16G T999 from T-mobile running 4.1.2 with a 32G SD card installed.

    I left the phone on the charger overnight and this morning the blue notification, white menu and back page lights were lit and the screen was black. When i pushed the power button the phone vibrated like it normally does when its booting up but it wouldnt advance beyond the SAMSUNG screen, the blue notification, white menu and back page lights lit up again and that was it. I tried to reboot the phone into recovery mode and pulled the battery twice and the phone didn't respond to either. I plugged the phone into my PC and the PC didn't acknowledge it and the phone didn't respond.

    Ive read about the I9300 "sudden death" issue and the US versions having motherboard/chip failures but neither of these issues seem to have the symptoms i'm experiencing. i called Samsung and they authorized me to send it to them from repair or replacement but before finalizing it i told the samsung rep i wanted to call t-mobile first and see if they had any other options available. T-mobile told me that if either samsung or t-mobile replace the phone it will most likely be a refurbished phone and didnt offer anything else. Is there anything else i can try on my own that "might" fix the problem or should i send it into samsung and take the chance of ending up with a refurbished phone.

    TIA, Happy Friday
    It sounds like you covered all the basics. I can't think of anything to check aside from if you have a bulge in your battery. That may lift it slightly and disconnect the battery from the phone. Check by putting it on a table and try to spin it. If it does, even a little, get a new one.
    07-20-2013 12:09 AM

Similar Threads

  1. Calling from the Lock Screen via Bluetooth
    By CrossClown in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 02-23-2014, 03:51 PM
  2. samsung galaxy s4 lost half of device storage
    By jimmy_trees in forum General News & Discussion
    Replies: 6
    Last Post: 07-20-2013, 03:53 PM
  3. Motorola defy 525 screen problem
    By Zimba Odonti in forum Motorola Defy
    Replies: 1
    Last Post: 07-19-2013, 02:02 PM
  4. HELP!!! My S3 Wifi isn't working
    By Lionwellz in forum AT&T Galaxy S III
    Replies: 1
    Last Post: 07-19-2013, 09:54 AM
  5. Locked Screen with Password- Help!
    By newbie2013s4 in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 07-19-2013, 09:48 AM
LINK TO POST COPIED TO CLIPBOARD