1. markwithsamsung's Avatar
    When I put the battery in, it comes on to the point where I see the Samsung Galaxy III on the screen, then just a black screen and nothing. I tried using a friend's battery, but no change. When I plug the charger in, there are no lights. I tried the power button: nothing. I tried both the power button, up and down volume, and still nothing. Only when I take the battery out, and put it back in do I get anything.
    Does anyone have any idea of whats going on?
    08-08-2014 07:39 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Two suggestions:

    1. Try removing the SD card and booting up again. A corrupt card can cause various issues.
    2. Try booting into Recovery Mode and wiping the cache partition: http://forums.androidcentral.com/sam...2-s3-tab2.html
    08-08-2014 11:23 PM
  3. GSDer's Avatar
    When I put the battery in, it comes on
    Sounds like the Power switch on the mainboard is stuck - the phone should not turn itself on when you insert the battery.

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    B. Diddy likes this.
    08-10-2014 09:13 AM

Similar Threads

  1. Samsung Galaxy S
    By Makayla Kirk in forum Ask a Question
    Replies: 1
    Last Post: 03-31-2015, 11:43 PM
  2. Will my HTC One M7 work on T-Mobile?
    By dino v in forum T-Mobile
    Replies: 10
    Last Post: 01-17-2015, 03:23 PM
  3. Samsung S5 - will it get L update?
    By bbmjack in forum Android 5.0 Lollipop
    Replies: 30
    Last Post: 10-18-2014, 05:02 PM
  4. phone not ringing
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-08-2014, 07:12 PM
  5. Nexus 4 app notifications not received.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-08-2014, 05:02 PM