1. jeffreytz's Avatar
    Noticing some odd behavior with the Wi-Fi on the HTC Amaze; basically its disconnecting from my home Wi-Fi network if I'm not actively using it. It doesn't do this when I'm at work, but I think that's because during the day its constantly getting push email from the Exchange server, whereas when I'm home that volume drops off dramatically.

    My home network SSID is not broadcasting (hidden), and when I get home (with Wi-Fi turned on) it seems to take forever to actually connect to the network. At first I thought this was because the network was hidden, but I noticed if I then did something (like jump in to Dolphin Browser or enter the Android Market) it suddenly connected. The network SSID and settings are "saved" and I can see it when I go to manage wireless networks in the menu settings; it says "not in range" when it isn't connected.

    My EVO 4G and 3D don't do this at all; the minute I walk in the house they instantly connect to the Wi-Fi network and stay connected until I walk out of the house.

    Does anyone know if this is actually a design thing with the Amaze, some sort of strange power-saving feature? If it is its ill-advised; it's better to just leave it connected to the Wi-Fi network even if "isn't doing anything", because any push data that comes along won't have to go over the mobile network (which uses more battery AND uses up part of my 5GB data plan).

    If anyone else has seen this behavioral or knows of a way to fix/turn it off please let me know.(If you think its my phone I'd like to know that too )
    11-05-2011 12:35 PM
  2. victoria7x's Avatar
    I know this isn't related but I just got my amaze and it has so many screens. I double tapped the home button so it could show me all the home screens that I have but there's no way to get rid of them. I just can't figure it out. Help please?
    11-05-2011 10:18 PM
  3. mswscco's Avatar
    Sorry, haven't noticed this on my phone and not sure why yours would work that way.
    11-05-2011 11:46 PM
  4. dobiegillis's Avatar
    I know this isn't related but I just got my amaze and it has so many screens. I double tapped the home button so it could show me all the home screens that I have but there's no way to get rid of them. I just can't figure it out. Help please?
    Why did you post this in two unrelated threads? You could have just started a new one.

    Sent from my Nexus S using Tapatalk
    11-06-2011 06:44 AM
  5. Sasquatchian's Avatar
    I'm having the same problem. A quick workaround is to turn WiFi off and then back on. This seems to "wake up" the Wi-Fi. Anyone know of a more permanent solution?
    11-20-2011 01:13 PM
  6. cmccartin's Avatar
    I'm having a similar problem with my Amaze. I can connect to the WiFi network and use it, but after a few minutes, I am no longer able to access the internet at all, but the WiFi status shows that I'm connected at 48Mbps and the signal strength is Excellent. Other devices work fine on the same AP.
    11-22-2011 02:31 PM
  7. rider111's Avatar
    I bought 2 Amaze at same time, they both had this issue, side by side. Thought it was defective phones but after exchanging one of them, still did it, then thought it was a sim issue. Found out later that it was my D30 case. take it off its perfect, put it on, it disconnects. heard this happens with other cases as well.
    11-29-2011 01:52 AM
  8. rdchewie's Avatar
    I am having the same problem as well, as soon as I got on my home network, I was unable to access internet, it started with Facebook, then it went into my Market, and now I have no internet unless I turn off my wifi and use the 4G network, as soon as I do that, all good, but if I turn on wifi, back to no connection
    12-29-2011 09:23 PM
  9. rdchewie's Avatar
    ok so I followed rider111 suggestion, took off my case, restarted my phone and voila it works now, not sure if it was a fluke, or if maybe i just needed to restart my phone
    12-29-2011 09:27 PM
  10. jeffreytz's Avatar
    For me it turned out to be my phone, a hardware issue. It died, so T-Mobile sent me a replacement and the new phone doesn't have this issue at all. Now if they can just get wi-fi calling to work
    01-01-2012 04:43 PM
  11. MrVeda's Avatar
    Since the latest update, the WiFi calling works great on my Amaze
    01-01-2012 07:11 PM
  12. Knightstalker's Avatar
    Same here...
    01-02-2012 08:08 PM
  13. ChromeJob's Avatar
    I found that system codes like #225# , #646# error out with 'Unrecognized MMI code" with Wifi Calling enabled, but work fine when I disable it.

    For those having "wifi disconnect" issues, are you sure you're wifi isn't just going to sleep while the display is off, screen locked? I've seen this setting in Llama, don't know much about the specific function(s).

    Oh I determined that it's because Wifi Calling, when enabled and active, seems to turn the GSM radio off. Maybe good for battery savings...?
    01-02-2012 11:47 PM
  14. jeff275's Avatar
    I have this problem too. I'm on my second Amaze so I don't remember for sure if it happened with the first one. I do think it happened before I got a case but I'll take my case off tonight and see if that changes anything. Tuning wifi off and on sometimes works for me. Rebooting the phone usually works but not always. Sometimes I have to "forget" my home network on the Amaze and then re-add it. Nothing has worked all the time so far.
    01-05-2012 02:42 PM
  15. luiscruz04's Avatar
    I have the same problem with my htc amaze 4g with android 4.0 and the wifi doesnt work, help me please
    12-09-2012 07:13 AM
  16. dobermans rule's Avatar
    Try to go into settings, WiFi, WiFi settings, menu button and select advanced. Look at the WiFi sleep policy option. Helped me.

    Sent from my Droid Incredible 2 using Android Central Forums
    12-10-2012 08:09 PM