1. WaarrEagle's Avatar
    Running KitKat and currently traveling in Canada where I am using Wifi Calling, I get the data roaming message over and over: "Do you want to turn on data while in roaming? (International roaming charges apply)." I have tried different combinations of the various data/roaming settings but the message keeps appearing. How do I stop this message? I really don't care where I have to set it as I spend the majority of my time here on wifi and roaming in Canada is free now.
    03-02-2014 09:55 PM
  2. gmep's Avatar
    Similar problem here. I live in The Netherlands and work in Germany so I have a German provider. In The Netherlands I exclusively use WiFi and therefore I turned data roaming off. As I was running 4.2.2 I got the messages about data roaming being off when I was @home. They came about every 2 minutes. They went away as I set the mail app to automatically every 15 min. that's strange enough. Then I updated to KitKat and now I get that annoying messages when I'm in Germany connected to my provider even with full 3G signal! And they came with an horrible frequency (once a second). Today I tried to delete the phone app data. The messages still come but only every 2 minutes. When I'm in The Netherlands the messages about data roaming don't come any longer???? Any hint about how to get rid of this stupid messages will be greatly appreciated. LG support couldn't help so far

    Posted via Android Central App
    03-12-2014 05:17 PM
  3. WaarrEagle's Avatar
    I was able to find a temporary fix by going into the TMobile Wifi Calling settings and setting the device to "Never Use Cellular Network." It is a pain because TMobile offers free data roaming in Canada and I am not always near a wifi connection, but I found it to be the best compromise to stop the repeat messages from popping up.
    03-12-2014 09:40 PM
  4. gmep's Avatar
    I knew that workaround, already, but that's more than a pain :-( .

    Sent from my LG-D802 using Tapatalk
    03-13-2014 07:43 AM
  5. gmep's Avatar
    BTW, I'm on Vodafone so the problem seems not to be related to the provider.

    Sent from my LG-D802 using Tapatalk
    03-13-2014 07:45 AM
  6. gmep's Avatar
    Try switching flight mode on and then back off. That could help at least until you connect to another network. I' m really wondering who programmed that sh.. :-(

    Sent from my LG-D802 using Tapatalk
    03-15-2014 07:43 AM
  7. bbz71's Avatar
    Same problem for me here in Italy, after updated to kitkat.
    My mobile network operator is 3. I've tried to restore the system, without luck.
    Anyone have an idea on how fix it?
    04-08-2014 02:14 PM
  8. gmep's Avatar
    There is no real fix to that only a couple of workarounds. LG recommends (@ least in Germany) to switch flight mode on and then back off. It works and I think LG doesn't feel pressure enough to fix that bug instead. Btw, I'm not really sure whether LG or Google is responsible for this as it seems that also htc, samsung and other devices are affected.

    Sent from my LG-D802 using Tapatalk
    04-09-2014 04:48 AM
  9. gmep's Avatar

    I rooted my phone, installed xposed framework and finally installed G2 Tweaksbox (full version). It will let you stop that messages

    Sent from my LG-D802 using Tapatalk
    bbz71 likes this.
    04-10-2014 08:10 AM
  10. Frank Bevers's Avatar
    similar problem here in belgium; in order to be able to use mobile data while not roaming I have to enable dataroaming on my HTC desire 601. Wish I'd never install KitKat. Enabling WIFI now also fails intermittently & the volume is about half of what is used to be. HTC remains silent.
    05-02-2014 04:42 AM

Similar Threads

  1. LG G Pad 8.3 GPE
    By SteveISU in forum Marketplace Archive
    Replies: 4
    Last Post: 03-04-2014, 06:09 PM
  2. Replies: 1
    Last Post: 03-04-2014, 03:59 AM
  3. LG G2: SIM Swap.. Is this normal???
    By Sincs in forum LG G2
    Replies: 2
    Last Post: 03-03-2014, 08:03 AM
  4. led notification on the s5?
    By chris7021 in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 03-02-2014, 08:29 PM
  5. LG G2, Microphone really loud?
    By endrien in forum LG G2
    Replies: 0
    Last Post: 03-02-2014, 08:01 PM