1. anon(10090)'s Avatar
    Hi everyone, I've been helping a friend try to get his MyTouch 3G rooted, but I've been running into issues. I've googled the process for 2.2.1, and have tried 3-4 of the top processes and just can't get it. Here are the methods I've tried that have not worked.

    SuperOneClick - Freezes on "Waiting on Device"
    Ultimate Guide: How to root any myTouch/Magic and install custom recovery/ROM!!! - xda-developers

    Z4 - Crashes in android
    How To: Load a Custom ROM on Your Android Phone (After Any One Click Root Methods) | TheUnlockr

    UniversalAndroot - root fails
    [GUIDE] Universal AndRoot - 1-click root (works on MyTouch 3G 1.2) - Page 15 - xda-developers

    Factory Reset method - download link is broken for package #2
    How-To: Manually update myTouch 3g to Android 2.2.1 Froyo OS

    CyanogenMod wiki method - Got "Main Version is older" - read below about goldcard
    http://wiki.cyanogenmod.com/index.ph...(32B):_Rooting

    Here is some more info on the device in question:

    SAPPHIRE PVT 32B SHIP S-ON G
    HBOOT-1.33.0013 (SAPH30000)
    CPLD-10
    RADIO-2.22.28.25
    OCt 21 2009,22:33:27

    Android 2.2.1

    I've done my due diligence I think - I just spent the last 3 hours researching and trying these methods - and now I need the community's help. Thanks in advance for anything people can do to assist! (I'm wondering if it's going to require the goldcard method, which looked a little more intimidating than I wanted to try without hitting a wall with the others).
    03-05-2011 11:03 PM
  2. anon(10090)'s Avatar
    Bump.

    I really need some help on this. Since this post a couple weeks ago, I've tried the super one click method on 2 of my coworkers phones, which worked like a charm (they were droid 1's), so I know I'm doing it right, but it still locks up on his mytouch 3g.

    If anyone could lend a hand it would be much appreciated!
    03-16-2011 12:17 AM
  3. AnOmnimous's Avatar
    Did you try the going the GoldCard route?
    03-25-2011 01:53 AM
  4. setcos99's Avatar
    try superoneclickv1.9.5-shortfuse drivers. You must use the one with driver bilt in superoneclick. do not use 2.2.or 2.3.3 or anything else, and also use shell root.good luck
    08-11-2012 07:25 PM
LINK TO POST COPIED TO CLIPBOARD