04-12-2012 01:04 AM
32 12
  1. Paul627g's Avatar
    You waited and waited the time is finally here...

    Ice Cream Sandwich 4.0.4 update is now available. Credit: Chris Parson/Android Central Blogs

    Build # IMM76D

    If your currently running stock ICS 4.0.3 you can follow the instructions below.

    Keep in mind, this is for GSM devices only

    • Grab the OTA package here
    • Rename it to update.zip. This isn't needed for the Nexus S bootloader, but it makes things easy, if that's how you prefer them.
    • Copy it over to the internal storage on your Nexus S.
    • Power off, then hold volume up and power to reboot to the bootloader.
    • Using the volume key to navigate, select recovery, then use the power button to confirm
    • When you see the warning triangle and arrow, hold the power button and tap volume up. You'll see a menu.
    • From the menu, select "apply update from /sdcard", and choose update.zip from the list.
    • Let it do its thing and update your system, radio, and other partitions. When finished, choose "reboot system now"
    • Enjoy!

    So now you have updated, lets here what you have to say....
    03-28-2012 03:53 PM
  2. LNWJ's Avatar
    Grats T-mo users! Hopefully this is a sign the Sprint version is getting close too.
    03-28-2012 08:29 PM
  3. mwuagi's Avatar
    Error status 7 messages and then it aborts. Essentially useless.
    03-28-2012 08:55 PM
  4. kest009's Avatar
    Same, using stock 4.0.3 from the AC post a few months ago, not rooted/no mods at all and I get an Error status 7 message...Tmo nexus S
    03-28-2012 09:15 PM
  5. LNWJ's Avatar
    Google kinda reminds me of the Soup Nazi. See soup... no can have soup.

    03-28-2012 10:01 PM
  6. rickybello's Avatar
    Status 7 here too
    03-28-2012 10:28 PM
  7. keith.randy's Avatar
    Unfortunately, I can a test to that error 7 as well. Does Paul627g know how to fix this?
    03-28-2012 11:33 PM
  8. PhxBlue's Avatar
    03-28-2012 11:33 PM
  9. RickBosch's Avatar
    You need to be completely stock, unrooted 4.0.3 for this update to work. If not, flash the 4.0.3 ota, reboot your device. Once done flash cwm via fastboot and then flash the update. Worked perfectly for me. You will need to root again though, but it's as easy as flashing superuser via cwm.

    Although a quick loom through the xda nexus s development forum has a flash able zip of the update which is even easier.

    Sent from my Nexus S
    03-29-2012 09:42 AM
  10. Paul627g's Avatar
    I have been reading up on the update and have seen mixed results.

    Complete stock seems to be the ticket but no promise there either for some. Those users end up turning around and installing CWM recovery and flashing the custom package/update.

    Why things can't smooth, who knows.....

    Sent from my Nexus S 4G using Tapatalk 2 Beta-4
    03-29-2012 11:35 AM
  11. TonyD23's Avatar
    No luck, error. Completely stock ICS.
    03-29-2012 05:32 PM
  12. skatedaddy's Avatar
    same here - Completely stock ICS and getting the status 7 error message
    03-30-2012 02:05 AM
  13. venkatramanp's Avatar
    Hitting the following error after selecting the update.zip file in recovery from sdcard mode:

    "E: Error in /tmp/sideload/package.zip
    (Status 7)
    Installation aborted"

    I had previously updated from 2.3.4 to 4.0.3 using an OTA available as download from android central. I hope that was stock 4.0.3!!
    03-31-2012 01:55 PM
  14. Paul627g's Avatar
    From what I have been gathering reading various posts at XDA on this subject you basically have two options...

    1. Wait for the actual OTA update notification to push out, that should work.

    2. Unlock your bootloader (yes this wipes the device)
    2a. Install CWM recovery on the device
    2b. Then flash the update.zip file using CWM and it seems to work.

    I know bogus solutions but that seems to be what is working from everything I keep reading...
    03-31-2012 02:08 PM
  15. Filipe Galego's Avatar
    You can install the factory image from Google after unlock the bootloader. It worked for me...

    Sent from my Nexus S using Tapatalk
    04-01-2012 03:59 PM
  16. ChevytheCoolest's Avatar
    With my Nexus S for Tmob it was rooted, tried to basically unroot and flash down to the stock then upgrade to the 4.0.3 manually but that is not working. Also, I locked the bootloader to try and see if it will work. Unsuccessful in getting the the OTA 4.0.4 to install as well. Any suggestions? Thanks.
    04-02-2012 08:57 PM
  17. zorak950's Avatar
    I can confirm the OTA worked for me; I was also unable to update from stock recovery.
    04-03-2012 01:22 AM
  18. li2327's Avatar
    Awe. Where's the cdma version. We need love too.
    04-03-2012 01:28 AM
  19. Rahabib's Avatar
    yay got mine OTA last night. worked fine.
    04-03-2012 09:40 AM
  20. BartmanJax's Avatar
    Got 4.0.4 OTA this afternoon. Working fine! I'm happy!
    04-03-2012 04:55 PM
  21. jomcty's Avatar
    I finally got my OTA ICS v4.0.4 update last night for my Nexus S i9020T which was running a manually installed ICS v4.0.3.

    Contacts and Phone app launch faster, still exploring the update.
    04-04-2012 09:55 AM
  22. Zapped's Avatar
    I'm another Tmo Nexus S owner who had manually installed ICS 4.0.3 when it was first available back in December 2011. Two days ago (Mon Apr 2 2012) I got an automatic update to ICS 4.0.4. Yesterday I saw that Google+ was the biggest battery user & since I don't use it I disabled it, because I wasn't allowed to uninstall it.

    Since disabling Google+ I've been surprised that the built-in Gallery application is the largest drain reported by on my Battery status page. This morning the phone has been unplugged for about 2.5hrs, and Gallery is at 69%. Next is Wifi at 7%, Cell standby at 6%, Screen at 6%, then Android System, Phone, and Android OS all at 3% each.

    I never use the Gallery since I prefer QuickPic. But I can't disable or uninstall Gallery, and if I Force Stop it I'll still see it running when I check a few minutes later. I checked my three Gmail accounts under Gallery Settings and none of them are set to sync - Sync is OFF for all three Gmail accounts in Gallery.

    Since it's the most obvious explanation, I'm guessing that disable Google+ has caused a problem with Gallery, but my battery drain will be bad again if I re-enable Google+. Anyone else seeing this sort of thing with ICS 4.0.4?
    04-04-2012 10:36 AM
  23. font1975's Avatar
    Nope, not having any battery drain issues. I had a lot of drain when ICS was first pushed, but it's been better as of late even before the update to 4.0.4. Since 4.0.4 the battery rate has been pretty close to my Ginger bread days. I still have 30%-40% left after 18 hours.

    I see idle/wifi and sometimes Maps as the big drainers.
    04-04-2012 12:05 PM
  24. skatedaddy's Avatar
    Just had my 4.0.4 update OTA, finally its finally rolling out in the UK. Was getting fed up with the status 7 error message :banghead:
    masterblaster2012 likes this.
    04-05-2012 02:19 PM
  25. acithium's Avatar
    I got tired of waiting so I just installed the factory image. It was an interesting process, but everything seems to be working.

    masterblaster2012 likes this.
    04-05-2012 02:21 PM
32 12

Tags for this Thread