1. sibsdroid's Avatar
    Using a Samsung Nexus S with Android 4.1

    So the other night someone down the pub decided to try and unlock my phone, and apparently got the pattern wrong so many times it's now requiring me to enter my Google account details.

    Fine, I enter the username / pass, only it says they're wrong - I know they're correct because I've just confirmed they are by logging into Gmail. It says they're incorrect so quickly that I suspect it's not even connecting to the web to check. The icons at the top imply there is signal, but it looks as though 3G / data is off, and there's no WiFi icon even though I'm sat next to my wireless router. Ideally I just want to somehow turn on WiFi / 3G & data so it will accept my Gmail details and unlock the phone - but I can't find anyway to do this. Seems totally bizarre that Android is requiring me to validate my identity online yet not allowing me to turn on anything to let me connect. I did try going into and then out of aeroplane mode to see if this would re-enable any settings like WiFi or data, but no luck.

    Looking at various other forums people have suggested a hard reset - I really want to avoid this as I'll lose all the data, but can do so as a last resort. Anyway, I tried a hard reset (phone off, hold down the Volume Up button, press the power button) but it just boots up normally and takes me to the "Too many pattern attempts" screen again. I tried as well with Volume Down rather than Up, same thing, then again with both Volume buttons, same. So now I can't even seem to do a factory reset!

    Other things I've tried:
    - USB Connected to a PC - the device doesn't show up, presumably because USB is not enabled
    - Using ADB (Android Debug Bridge) when the device is connected by USB and calling "adb devices" - lists no devices
    - Making a call to the phone works - and I can even get to the text message app by going "custom message" rather than answering the call, but I can only send a reply and see the messages sent to/from that number - can't get to the main text message app menu or anything

    Any help would be most welcome - as I say, ideally I want to avoid wiping the phone, but at this point if someone can tell me a successful method of factory resetting I'd probably take it!

    [UPDATE] - So I just managed to get into Fastboot Mode (not sure what I did differently - only thing I can think of is the phone wasn't connected to the PC by USB this time). Anyway, I selected Recovery, saw the screen with the Android lying down and the red exclamation mark, then the phone booted - but nothing has changed! I'm still on the 'Too many pattern attempts' screen, and it looks like the device is still remembering my Gmail details since after powering on I get a notification that I have unread mail (presumably from previously when I did have 3G / data on). Is there anything else I can do in Fastboot Mode? Load a different version of the OS for instance that would allow me to enable WiFi / USB debugging / etc?

    [UPDATE-2] - Have installed fastboot:
    [How To] Root Nexus S on Jelly Bean or Ice Cream Sandwich (Android 4.x) | dotTech
    [Android] Downloads links for USB (adb and fastboot) drivers for Windows for all Android phones and tablets | dotTech
    How To: Install ADB and Fastboot on your Windows computer for use with your Android phone | dotTech

    When I run "fastboot devices" I can see the phone listed, however bizarrely "adb devices" lists nothing.
    "fastboot oem unlock" seems to work (the phone prompts me to confirm I want to give root access & delete all user data). I haven't done this yet as I want to see if I can save my data somehow using adb or fastboot commands, but I suppose this is one way of factory resetting if I need to. If anyone knows much about fastboot / adb and knows how to copy / backup files using it, the help would be very much appreciated!

    [UPDATE-3] - From what I understand you can't copy files off the phone using fastboot commands, but can using adb (push / pull commands) - so a few questions:
    - Does anyone know why adb wouldn't see my device (when I run "adb devices") but fastboot does (note that I'm on the fastboot screen)?
    - Does adb require debugging mode to be on?

    [UPDATE-4] - Still can't get adb working, suspect it's because USB debugging isn't enabled (though not sure how I can check?). I did try using fastboot to erase the /cache partition in case the lockout data was stored in there - but this didn't work unfortunately. Looking likely I'll just have to wipe it with fastboot oem unlock
    11-18-2012 12:20 PM
  2. TOOLEY's Avatar
    I don't recall if it erases or phone I think it does. Backup everything 1st. Than request the master lock code n it will reset the device to new. I am not sure if you may wish to look into a new Google account I believe all ur previous account info may not be transferable. Perhaps call Google customer service if you hadn't tried already.

    Sent from my Galaxy Nexus using Android Central Forums
    11-18-2012 12:27 PM
  3. dave the builder's Avatar
    I have the same issue. Please help!!!
    11-18-2012 01:10 PM
  4. DevSteven's Avatar
    Turn the phone off. Then hold down the power button and the volume button down at the same time. Then select recovery. When the phone reboots into recovery hold down volume up/down and power and select wipe device. You will lose all your data.

    Sent from my Nexus S using Android Central Forums
    12-09-2012 01:08 AM
  5. Auriel Manolson's Avatar
    This is perhaps not the greatest help for users who do not have such an app, but I was stuck in exactly the same situation : phone locked (from being in my pocket while swing dancing, lol) , and data and wifi turned off ... fortunately I had an app called "androidlost" installed on the device. This allowed me to send a txt message to the device instructing it to turn its wifi on, and was able to then enter my gmail password and unlock the device.

    Everybody who owns an android should install or some similar app... they are too many situations that could happen where you want to be able to control your phone like this. I am grateful I didn't need to wipe the device to unlock it.

    ( i have no affiliation with androidlost, just a happy user)
    03-28-2013 12:51 AM
  6. tabi007's Avatar
    Samsung Google Nexus S Android hard reset - PDA Smartphone PNA hard reset soft reset
    dude try this, worked for my nexus s, had the same problum
    04-05-2013 09:45 AM
  7. momo 420's Avatar
    hey please help me out i have a same problem with my nexus S n i have entered my google account soo many times but no result im scared now
    06-18-2014 03:04 AM

Similar Threads

  1. Replies: 90
    Last Post: 10-07-2016, 10:33 PM
  2. Cannot connect to working wifi
    By truegiantbdc in forum Droid RAZR
    Replies: 2
    Last Post: 01-31-2014, 06:00 AM
  3. Replies: 3
    Last Post: 09-15-2012, 04:11 PM
  4. Is the Nexus 7 already out of favor with Google?
    By greatgoogly in forum Google Nexus 7 Tablet (2012)
    Replies: 66
    Last Post: 09-14-2012, 02:20 PM
  5. have to login to google act. multiple times a day
    By evelweevel in forum Verizon Fascinate
    Replies: 3
    Last Post: 04-07-2012, 09:42 PM