1. snookiesnoo's Avatar
    So this is odd. My first Nexus S from Best Buy was incapable of getting 3G or Edge data or any data over anything but wi-fi. But I was able to make and receive voice call's. So I called T-Mobile and they thought it was the phone. Went back to Best Buy and got a new Nexus S and a new SIM card. Same issue. T-Mobile has no idea what the problem is. Three different people in 3 calls checked my account and said it was setup right. They also reset my network connection. i have force reset the phone multiple times. Nothing will make it get data in any location over a wide area. The phone has really grown on me though so now I'm not so keen to just take it back and cancel my account. Any ideas?
    12-19-2010 05:30 PM
  2. DroidXcon's Avatar
    So this is odd. My first Nexus S from Best Buy was incapable of getting 3G or Edge data or any data over anything but wi-fi. But I was able to make and receive voice call's. So I called T-Mobile and they thought it was the phone. Went back to Best Buy and got a new Nexus S and a new SIM card. Same issue. T-Mobile has no idea what the problem is. Three different people in 3 calls checked my account and said it was setup right. They also reset my network connection. i have force reset the phone multiple times. Nothing will make it get data in any location over a wide area. The phone has really grown on me though so now I'm not so keen to just take it back and cancel my account. Any ideas?
    well first best bet would to make sure its not the phone, is there any other phone you can remove the sim card and try it on?
    12-19-2010 05:33 PM
  3. Smokexz's Avatar
    hmmmm... could you maybe try a bunch of devices right at the Best Buy store? Maybe it was just a HUGE batch that didn't work right... try using some of their devices before walking out...
    12-19-2010 07:10 PM
  4. DumbUglyDragon's Avatar
    Is this a new activation? I got a new SIM card to replace my old one and couldn't get data. The employee at the TMobile store told me it actually takes a few minutes to a few hours before I would get data, even though I could make calls. I was skeptical, but a few hours later, the data did come back on for my phone.
    12-19-2010 07:54 PM
  5. snookiesnoo's Avatar
    Thanks for the ideas so far.

    It is a new activation and a new account. I had them put a new SIM in the replacement phone but that has not helped.

    I could put the sim in my iPhone 4 and see if it works, I would at least get Edge but not 3G on T-Mobiles network.

    I dunno, it's really aggravating. I've spent a lot of time trying all sorts of things and talking to T-Mobile and am about to give up on the phone and T-Mobile.

    They said it could take up to 48 hours for data to start but that seems really odd unless it's just a T-Mobile thing. Never seen that with any other carrier.
    12-19-2010 11:09 PM
  6. NEST600's Avatar
    I have no idea why this would work but it did for me after a T-Mobile employee searched their internal forum and suggested it. My problem was the same, a SIM and plan that got data fine on a Vibrant and a G2 suddenly didn't on a Nexus S.

    He gave me the SIM unlock code/PUK or whatever it's called. Not the four/six digit one but the emergency one if you get SIM locked. Then I internally entered the wrong SIM PIN a BUNCH of times until it lockeds. Unlocked it with the sequence he gave me and set my PIN again (done within that actual sequence). Voila. Data started working immediately.

    I still can't understand why this would help but if you've tried everything else I guess this might be worth a shot too. Cheers, -Pk
    12-20-2010 01:53 AM
  7. evilpika's Avatar
    I having the same issue here!!! i called tmobile and they dont know how to fix it, im desperate i mean i love my nesux s but with no data from tmobile i dont know what i gonna do.

    please please if someone solved this issue already please tell me how to fix it.

    thank you
    12-20-2010 08:45 PM
  8. evilpika's Avatar
    by the way i have a nexus s unlocked with tmobile coming from a nexus one, chicago area
    12-20-2010 08:48 PM
  9. singlesooner's Avatar
    You should try calling Samsung Premium Nexus S Support (1-855-392-6398) to see if they can help. I got this number after registering my phone at SAMSUNG
    12-20-2010 11:47 PM
  10. Baconator's Avatar
    I still haven't activated my phone on the T-Mobile network but when I do I will tell you how it goes. Hope it doesn't mess up. I am activating it Wednesday.
    12-20-2010 11:59 PM
LINK TO POST COPIED TO CLIPBOARD