07-09-2012 10:51 AM
33 12
tools
  1. ronschaeffer's Avatar
    I guess that I must be missing something obvious here. Apologies if the issue has been covered elsewhere, but I haven't found anything by searching forums or Google.

    How can I set the photo of "Me" that is shown in the Messaging app on my Nexus S? I don't see a setting on the phone, and it doesn't pick up the photos from either my Google account or Google Apps account.

    Thanks.
    01-20-2011 04:34 AM
  2. gbpal's Avatar
    You could add yourself to your contacts list and then add a pic
    01-20-2011 10:09 PM
  3. Droid800's Avatar
    Yeah, I've noticed that gingerbread doesn't do that great of a job of linking your picture. Mine used to link with facebook (and it did on Froyo), but gingerbread doesn't.
    01-21-2011 12:26 AM
  4. ronschaeffer's Avatar
    Mine links in Contact but not to "Me" in the Messaging app.

    Sent from my Nexus S using Tapatalk
    01-21-2011 12:35 AM
  5. gbpal's Avatar
    Hmm my pic shows up but I don't remember the exact way I did it, I think I long pressed the "me" in the messaging app and added myself to the contacts list then added my pic and now I can see my pic in the "me" of all the messages I sent. If this doesn't work I'LL try to duplicate what I did
    01-21-2011 11:10 AM
  6. font1975's Avatar
    That seemed to work for me thanks! Didn't really notice this as an issue until Ron brought it up [Gee, thanks]. The issue has now been fixed. :-)
    01-21-2011 01:26 PM
  7. ronschaeffer's Avatar
    Thanks, but that doesn't work for me either, oddly. A long press on the Me box does nothing except briefly flash a yellow outline when I list my finger. A long press on the accompanying message pops up message options like forwarding.
    01-21-2011 02:50 PM
  8. gbpal's Avatar
    ok, so this is what i did. I deleted myself off my contacts list to make sure this works. Then instead of long pressing the Me box, I just tapped it and it asked if i would like to add this number to contacts. So i clicked yes then create new contact, added my own name, then added a picture, then clicked done. Then when i went back to the messaging app, my pic is there and it still says Me. Hope this helps, if not, then i dont know what else lol
    01-21-2011 04:46 PM
  9. ronschaeffer's Avatar
    Thanks much for the tips, but still no luck after trying that and several variations. Strangely, tapping never gives me the option to add a contact.

    Sent from my Nexus S using Tapatalk
    01-23-2011 03:05 PM
  10. font1975's Avatar
    Ok. Try this. Before you do anything; are there any contacts already in your contact list that have your phone number defined? If so, remove the number or delete the existing contact.

    Then try these:
    1. In the messaging app, go back to the main list (the one showing all your threads)
    2. Tap on a thread.
    3. In the conversation, you probably see the grey Android icon representing you. Tap the icon itself, not the message. (That's a normal tap, not a long press)
    4. You should see a box that says "Add <your phone number> to Contacts?"
    5. Say OK, which takes you to the Contact list.
    6. Select "Create New Contact", then in the next window, select "Done"
    7. Edit the contact and change the picture

    If you don't have any luck, try plan "B"

    1. Open your Contacts folder
    2. Click on the menu button and select "New Contact"
    3. Type your phone number in the Phone field
    4. Save the contact; don't enter any other info
    5. Edit the contact and add a picture.

    You may need to back all the way out of the messaging app (by using the "back" key not the "home" key) and then relaunch it.

    Both of these methods seemed to work for me.

    Hope this helps! :-)
    01-23-2011 05:46 PM
  11. ronschaeffer's Avatar
    Thanks a lot, font1975. I'd actually tried both of these methods with no luck.

    Your post, though, describes a possibly key difference between what's on your phone and what's on mine. I don't see a gray Android representing me. I instead see a solid, darker gray box. Other people that I don't have photos for are represented by a gray android. When I tap the gray androids, it asks me if I want to save the number to contacts. In contrast, it does nothing except briefly flash the yellow highlight when I tap the gray box next to "Me".

    I'm feeling more than a little vain, trying so hard to see a picture of myself!
    01-24-2011 10:15 AM
  12. font1975's Avatar
    Hmm, does sound like something else is going on then

    I'm feeling more than a little vain, trying so hard to see a picture of myself!
    Not even sure what the bottle of sparkling wine I choose for my picture says about me
    01-24-2011 12:59 PM
  13. ronschaeffer's Avatar
    OK, I've finally figured out what the problem was: My phone number was not stored on my SIM card.

    Apparently, the system links the SIM card phone number, a corresponding contact, and the Me icon in Messaging.

    font1975, your mention of the tappable android icon got me thinking that the issue had to lie outside of Messaging and outside of Contacts. I noticed while exploring Settings that the entry under Settings/About phone/My phone number was Unknown. In contrast, a friend whose Me photo in Messaging worked properly had his number there. I guessed that might be the issue.

    So, the simple fix was to use an old phone that allowed editing of my own phone number on the SIM. I entered my number, popped the SIM back in the Nexus S and, sure enough, there was a tappable android icon instead of a dark gray box next to Me in Messaging.

    Google really ought to change this so that you're prompted to add your phone number to the SIM if Messaging can't find a match.

    Thanks to everyone for their suggestions.
    01-25-2011 08:50 AM
  14. lyk13's Avatar
    Can anyone further advise how would one store their phone number on the SIM card? I'm having the same problem and yes, my phone number is listed as Unknown as well.
    01-25-2011 10:33 AM
  15. druk75's Avatar
    Is there no way you can add your name into the sim form your nexus s? And an old phone will allow only a number. You cannot put in a pic of yours there. So where do you put your number?
    01-25-2011 12:33 PM
  16. font1975's Avatar
    What is meant by putting your number on the SIM:
    Under settings, go to "About Phone"
    Select "Status" and the line that says "My Phone Number" should list your number.

    I've not found a way to modify this on an Android phone. As Ron mentioned, he put his SIM into an old phone and modified this field using the old phone. Otherwise I'm not sure how.

    @druk75:
    Assuming the "My Telephone Number" lists your number and doesn't say "Unknown"; all you need to do to add a picture is to create an address book entry with your phone number in your contacts. I didn't even name my entry, just created new entry typed a phone number, added a picture and hit Save.
    01-25-2011 03:15 PM
  17. lyk13's Avatar
    So what examples of phone allow us to enter the number onto the SIM card? Never encounter such a utility before.
    01-25-2011 06:36 PM
  18. ronschaeffer's Avatar
    I used a Motorola RAZR V3x to set my phone number on the SIM. The option was under Initial Setup. A search online shows that the iPhone also allows you to enter/change the SIM number. Try borrowing someone's?

    Finally, your cellular network should be able to update your SIM card with the number over the air. You could try calling customer service.
    01-26-2011 05:17 PM
  19. druk75's Avatar
    Most old phones allow you to do that i presume. All feature phones too. Just open up contacts ( in any old nokia phone) go to my number and add your phone number and name. I donno if this will do the trick. i am a bit confused after the previous post which tries to say that one is entering/changing the sim number......every sim has a particular 12 digit code. So i donno if he means we have to change that code and put our phone number instead. I think its just enough to add your number into the sim memory via the "contacts" - my phone number.....in any older gen feature phone.

    And @font 1975 my ohone also shows "unknown" in the my phone number field. And i have the same problem of blank gray box alongside my number in the sms threads. Only i never noticed it until it was mentioned here. So now i know the solution but dont want to go through the hassle of taking my sim out and putting it into another phone just to get my pic....i just wondered if there was a way to do it from the phone itself. I am still sure there is...Somebody will soon get to it. Andy boy and this phone just about lets you do almost anything with it....
    01-27-2011 07:07 AM
  20. font1975's Avatar
    i am a bit confused after the previous post which tries to say that one is entering/changing the sim number......every sim has a particular 12 digit code. So i donno if he means we have to change that code and put our phone number instead.
    No, we're not talking about changing the SIM's 12 digit code or whatever serial number it has. There is apparently a field that stores your phone number that can be modified on some phones. That field is what shows under "My Phone Number" in the Status screen.
    And @font 1975 my ohone also shows "unknown" in the my phone number field. And i have the same problem of blank gray box alongside my number in the sms threads. Only i never noticed it until it was mentioned here. So now i know the solution but dont want to go through the hassle of taking my sim out
    Yeah, i never thought about puttying my picture in SMS until this thread, either!

    Too be honest, I've never had to modify my phone number on the SIM, and never really tried. Ron mentions it here, and I've seen it elsewhere that older phones let you update that phone number field, maybe under the Phone's properties or SIM information screens. But I believe it's supposed to be updated from the carrier. When we ported my wife's number to T-Mobile after her ATT contract was up, the "My Phone Number" screen updated itself with the new number about 24 hours later.
    01-27-2011 12:47 PM
  21. Flakie's Avatar
    I guess that I must be missing something obvious here. Apologies if the issue has been covered elsewhere, but I haven't found anything by searching forums or Google.

    How can I set the photo of "Me" that is shown in the Messaging app on my Nexus S? I don't see a setting on the phone, and it doesn't pick up the photos from either my Google account or Google Apps account.

    Thanks.
    Set My Number in Android when it is Unknown:

    Anyone that needs to do this go to the market and download an app called:

    "My Phone Number" by Lytsing

    It works

    Also, this does write it to the sim and is not just some software hack. I tested by putting the sim in another phone without the app installed and My Number is now visible (as is my pic in the messaging app).
    01-27-2011 01:02 PM
  22. dadds27's Avatar
    i tried to install my phone number but the install was unsuccessful?
    01-27-2011 02:58 PM
  23. font1975's Avatar
    Set My Number in Android when it is Unknown:

    Anyone that needs to do this go to the market and download an app called:

    "My Phone Number" by Lytsing
    The description of the app sounds as though it requires Root or a Custom ROM?
    01-27-2011 03:19 PM
  24. druk75's Avatar
    Downloaded, but not installing.......i guess font is right, maybe only a rooted device can install it.
    01-27-2011 04:01 PM
  25. Flakie's Avatar
    Downloaded, but not installing.......i guess font is right, maybe only a rooted device can install it.
    Sorry this may be the case, looking at the authors notes.
    My phone (ZTE Blade/ Orange SF) has both a replacement ROM and is rooted. Is this not possible with the Nexus S?
    01-28-2011 12:42 AM
33 12
LINK TO POST COPIED TO CLIPBOARD