1. cporier91's Avatar
    so i needed to unroot my nexus because of warranty reasons, and i updated successfully to 2.3.2 but when i try to apply the 2.3.3 update my phone will not open it and install it. has this happened to someone else before? on the recovery it says

    E: Error in /tmp/sideload/package.zip
    (status 7)
    installation aborted

    I don't know if the radio in the phone is messed up or if i just forgot about something. i tried doing system check in's but those aren't working. i'm really pissed about this, and frustrated. Please help if you know a solution or heard of this happening before.
    03-14-2011 05:56 PM
  2. font1975's Avatar
    If this is for a return or factory repair, I wouldn't worry about it. My NS (still stock) has yet to receive the update notification, too.

    All checkin does is check in to Google's servers. If the update isn't queued for your phone, you won't get it.

    As to why the manual update is failing, I don't know.
    03-14-2011 08:42 PM
  3. Baconator's Avatar
    Well try this, I am not sure if it will work but we will see. Plug your Nexus S into your computer and then look for files that you think could be stopping it from updating. Delete them or at least save them somewhere else on your computer (just in case) and then try to update manually. Tell me if this helps.
    03-14-2011 10:43 PM
  4. 1stGenRex's Avatar
    there's a patch you need to apply if you get the status 7 error before you can update to 2.3.3 (I was having this issue). I followed these instructions and everything went well.

    VPetkov.net Google Nexus S – update manually to 2.3.1, 2.3.2, and 2.3.3
    Baconator and cporier91 like this.
    03-17-2011 10:40 AM
  5. cporier91's Avatar
    Thank you so much 1stGenRex i'm going to try this and let you know how it goes!
    03-18-2011 12:55 AM
  6. cporier91's Avatar
    sorry 1stGenRex, i'm stil getting the same message. Could it be that something got messed up in the unrooting process? even though i followed all the directions? i'm hoping its a simple fix, and nothing drastic...
    03-18-2011 02:26 AM
  7. cporier91's Avatar
    ok, 1stGenRex, i email the guy that posted those instructions, and emailed me back telling me that my radio version is totally different than the one he posted, he told me that my baseband version is "XXKB3". So this makes sense now, i knew it had something to do with the radio. I just had to dig a little deeper i guess.

    **still doesn't work...**
    03-18-2011 02:57 PM
  8. 1stGenRex's Avatar
    Well, at least you were pointed in the right direction, eventually :P
    03-18-2011 06:39 PM
  9. cporier91's Avatar
    yeah the guy managed to have the right update for me, and now my phone is fully up to date. thank you again for the website
    03-19-2011 04:07 PM
  10. mindyourself's Avatar
    yeah the guy managed to have the right update for me, and now my phone is fully up to date. thank you again for the website
    can you send me what he sent you? i'm running into the same problem
    04-08-2011 05:18 AM
  11. cporier91's Avatar
    VPetkov.net Google Nexus S – update manually to 2.3.1, 2.3.2, and 2.3.3

    first off what is your current version and baseband version?
    04-08-2011 11:56 AM
  12. conkhong's Avatar
    Ok...I got the same problem..can you guys help ..
    xxkb3 is what I have
    04-10-2011 08:29 AM
  13. cporier91's Avatar
    ok, on the website i just posted, download the last file the guy has posted on the blog "THE LAST RESORT" update, its to upload the whole 2.3.3 system on your phone. are you on 2.3.1 or 2.3.2?
    04-10-2011 02:02 PM
  14. Arasin's Avatar
    If you still haven't figured it out, you have to flash the radio via fastboot back to the stock XXKB1 Radio for GRI40 from the GRI54 XXKB3 Radio. Then do the update manually via the update.zip package.

    If you want to be completely thorough though, I have found that The best way to update everything is to return back to complete stock, flashing the older bootloader and all, that way the phone won't mark it as already upgraded when it checks itself against the servers at Google. Had the same thing happen to a few friends and myself.

    It's a pain in the ***, but here's a link to the XDA-Developers forums thread that will get you going in the right direction:

    [ROM][NANDROID BACKUP] Nexus S 2.3.2 Build GRH78C + Bootloader + Radio - xda-developers
    05-01-2011 10:59 AM
  15. cporier91's Avatar
    for future references: when you unroot your phone, the radio image doesn't update to proper radio image for stock. So if you have a custom rom and unroot, that radio image will stay the same.
    05-01-2011 06:51 PM