1. hcristobal89's Avatar
    Trying to get my tmobile s4 to forget the att wifi it keeps automatically joining when I hit forget it says failed to forget network. The only way around this is turning wifi off could it be that my last phone was att and it saved the settings? Anyone know how I can fix this it's annoying thanks

    Posted via Android Central App
    edybala and dealmaster00 like this.
    08-25-2013 02:50 PM
  2. edybala's Avatar
    I have the same issue. I just moved from ATT to Sprint and have this same issue. Any news on how to fix?
    10-10-2013 11:56 AM
  3. fourDot0's Avatar
    Has anyone figured this out? I have the same problem and it's really annoying. I don't want to have to root my S4 just to stop auto-joining attwifi.
    10-28-2013 07:07 PM
  4. dealmaster00's Avatar
    Trying to get my tmobile s4 to forget the att wifi it keeps automatically joining when I hit forget it says failed to forget network. The only way around this is turning wifi off could it be that my last phone was att and it saved the settings? Anyone know how I can fix this it's annoying thanks

    Posted via Android Central App
    I have the same issue. I just moved from ATT to Sprint and have this same issue. Any news on how to fix?
    Has anyone figured this out? I have the same problem and it's really annoying. I don't want to have to root my S4 just to stop auto-joining attwifi.
    Hey guys. I also encountered this issue, and spent some time figuring out how to fix it. I have an LG G2 running stock android 4.2, rooted. Note that you will need a rooted phone in order to do this. Here are the steps I took:

    1.) Get a text editor capable of using root.

    2.) Open /data/misc/wifi/wpa_supplicant.conf using your text editor. Make a backup of this file while you're at it.

    3.) Find the 'attwifi' entry and rename it (I renamed it to 'attwifi2'.) You could also probably remove the entry but I didn't try that.

    4.) Turn off and turn on Wifi
    * Note, I couldn't turn on wifi at first once I changed wpa_supplicant's conf file. It turned out to be a permission issue - my text editor did not save the file with the correct permissions. I had to run 'chmod 777 /data/misc/wifi/wpa_supplicant.conf' in a terminal window to give permissions back (it probably just needs chmod 666).

    5.) Find 'attwifi2' in your saved wifi list and 'forget network'. It should now be forgetten. There is no more attwifi or attwifi2.

    If this doesn't work for you, then you are probably using a different version of android where the conf file is in a different path. Try grepping for attwifi via a terminal window. If you mess up your phone, you can try running 'dmesg' in a terminal window to see the system log. Best of luck!
    02-15-2014 04:28 PM

Similar Threads

  1. Help with rooting Galaxy S4 Fido SGH-I337M 4.2.2
    By kasek in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 15
    Last Post: 09-04-2013, 07:42 PM
  2. Connecting to The Internet :::
    By Morgan7600 in forum General Help and How To
    Replies: 1
    Last Post: 08-25-2013, 05:07 PM
  3. New app: Cast to UPnP/DLNA for GMusic
    By bobbie424242 in forum Google Chromecast
    Replies: 0
    Last Post: 08-25-2013, 02:21 PM
  4. Cannot locate pictures/albums on Galaxy s4
    By dmelnyk in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 08-25-2013, 01:50 PM
  5. LG Optimus P880 4X HD Connect To Samsung TV HELP !!!!
    By Joshua Falls in forum LG Optimus 4X HD
    Replies: 0
    Last Post: 08-25-2013, 01:00 PM
LINK TO POST COPIED TO CLIPBOARD