1. PhiPsi32's Avatar
    I went into T-Mo store for an "advanced SIM" for use with Softcard. Store Rep tried two. My S4 gave a no SIM detected error. Standard SIM works fine. Anyone else having this issue? Thanks.
    12-14-2014 11:27 PM
  2. Dan29466's Avatar
    Is your S4 a T-Mobile branded device? There are three models of S4 that will work 100% on the T-Mobile network, but the advanced SIMs will only work in the T-Mobile branded model (SGH-M919). Nobody seems to know for sure if it will work in a MetroPCS version of the SGH-M919 or not.

    Dan
    12-28-2014 02:51 PM
  3. PhiPsi32's Avatar
    Yes, I have the T-Mobile branded handset. I've tried a few advanced SIMs without success. Most of the non NFC SIMs don't work either. I had to reactivate my old SIM card to get the phone running again.
    02-26-2015 09:20 PM

Similar Threads

  1. Sim unlock page not showing up
    By angelisawesome in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 10-05-2016, 06:59 PM
  2. The Best Rom for Asus Memo Pad HD7 Dual Sim Tablet
    By R o N a L d O in forum ASUS MeMO Pad HD7
    Replies: 1
    Last Post: 12-15-2014, 08:03 AM
  3. Droid Bionic, (no sim) wont download anything??
    By squishsquish in forum General Help and How To
    Replies: 2
    Last Post: 12-14-2014, 11:55 PM
  4. Replies: 2
    Last Post: 12-14-2014, 07:03 PM
  5. Sim Unlock Code
    By angelisawesome in forum Samsung Galaxy S5 Rooting, ROMs & Hacks
    Replies: 0
    Last Post: 12-14-2014, 02:56 PM
LINK TO POST COPIED TO CLIPBOARD