1. Kirito_theBlackSwordsman's Avatar
    For the past few days, the data on my phone has not been working. Recently this morning, I tried following a few online tutorials to change the APn name and settings, none of that has worked.

    Bit of background: I go through MetroPCS as my carrier and my phone is an LG model of that's applicable.

    My question is, if I tried updating the APN settings and that hasn't worked, is there another way to get my 4g back? Sometimes it will say 2g next to the signal bars but right now as of typing this (on WiFi), there is no data despite having a signal. I've tried all I can try. Is there something I have overlooked or should I have someone look at my phone?

    Thanks in advance for your help and replies.
    03-14-2019 11:17 AM
  2. Javier P's Avatar
    Have you already contacted Metro? There could be a problem in your area or something wrong with your SIM card.
    03-14-2019 11:20 AM
  3. Almeuit's Avatar
    For the past few days, the data on my phone has not been working. Recently this morning, I tried following a few online tutorials to change the APn name and settings, none of that has worked.

    Bit of background: I go through MetroPCS as my carrier and my phone is an LG model of that's applicable.

    My question is, if I tried updating the APN settings and that hasn't worked, is there another way to get my 4g back? Sometimes it will say 2g next to the signal bars but right now as of typing this (on WiFi), there is no data despite having a signal. I've tried all I can try. Is there something I have overlooked or should I have someone look at my phone?

    Thanks in advance for your help and replies.
    Are you in a known 4G area? If you are and you are sure the APN is right I would go to Metro. It could be a SIM card or account issue that is preventing the towers from giving you LTE.
    03-14-2019 12:57 PM
  4. Kirito_theBlackSwordsman's Avatar
    Thank you for your response. I checked the coverage map and my area is covered. I've tried restarting my phone several times, even taking the battery out. I will go into my MetroPCS store if the problem doesn't correct itself. Should I try taking out the simcard and puting it back in?
    03-14-2019 01:04 PM
  5. Javier P's Avatar
    Thank you for your response. I checked the coverage map and my area is covered. I've tried restarting my phone several times, even taking the battery out. I will go into my MetroPCS store if the problem doesn't correct itself. Should I try taking out the simcard and puting it back in?
    Yes, that could help. It could be good if you can try the SIM card in another phone and see if there's a problem with your phone or with your card/network.
    03-14-2019 01:18 PM
  6. Kirito_theBlackSwordsman's Avatar
    I tried putting my SIM card in another phone like you suggested and it said "No service." I'm going to have to take it into one of the MetroPCS stores and see if they can help me. It was working just fine at the beginning of the week/over this past weekend.
    Javier P likes this.
    03-14-2019 01:58 PM

Similar Threads

  1. Why won't my hardware work for my flashlight
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-15-2019, 11:17 PM
  2. Why isnt my galaxy s10+ updating
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-15-2019, 02:18 AM
  3. My Samsung G7, answer and decline appears but does nothing when swiped
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 03-14-2019, 03:23 PM
  4. Go phones like Fiesta to have an antivirus installed
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-14-2019, 11:56 AM
  5. My Samsung G7, answer and decline appears but does nothing when swiped
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 03-14-2019, 10:51 AM
LINK TO POST COPIED TO CLIPBOARD